Bug 206943 - aaa
Summary: aaa
Status: RESOLVED DUPLICATE of bug 1
Alias: None
Product: Networking
Classification: Unclassified
Component: IPV4 (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-25 08:37 UTC by fengxw18
Modified: 2020-03-27 03:11 UTC (History)
0 users

See Also:
Kernel Version: version 3.9
Tree: Mainline
Regression: No


Attachments

Description fengxw18 2020-03-25 08:37:58 UTC
A forged ICMP "Fragmentation Needed" message embedded with an echo reply data can be used to defer the feedback of path MTU, thus tricking a Linux-based host (version 3.9 and higher) into fragmenting TCP segments, even if the host performs Path MTU discovery (PMTUD). Hence, an off-path attacker can poison the TCP data via IP fragmentation.
Comment 1 fengxw18 2020-03-25 09:17:27 UTC

*** This bug has been marked as a duplicate of bug 1 ***
Comment 2 Stephen Hemminger 2020-03-27 03:11:49 UTC
(In reply to fengxw18 from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 1 ***

You marked as duplicate of wrong bug. Looks like should be 203945

Note You need to log in before you can comment on or make changes to this bug.