Bug 206921 - hid-uclogic not working anymore since changes introduced in xHCI
Summary: hid-uclogic not working anymore since changes introduced in xHCI
Status: RESOLVED DUPLICATE of bug 206897
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-22 13:53 UTC by Valerio Passini
Modified: 2020-04-08 09:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.3 and further
Tree: Mainline
Regression: Yes


Attachments

Description Valerio Passini 2020-03-22 13:53:14 UTC
Hello,

I have an Huion" New 1060 plus" graphic tablet that I used now and then and has worked very well in the past just compiling the hci-uclogic in-tree kernel driver on my laptop with Debian/Sid or using the stock kernel.
In these late days I have found that the graphic tablet is not working with new kernels (5.3.x and 5.4.x), it's not recognized at all upon connecting, but the issue can be solved disabling USB3.0 through BIOS.

This workaround is not possible on every laptop as you probably know since the possibility to tweak the BIOS varies within laptops brand.

There is a patch on xhci that restores the driver functionality, but I don't think that acting on xHCI side is in the right direction.
https://github.com/menaechmi/Huion1060P-kernel-patch/blob/master/digimend_xhci.patch
Comment 1 Hector 2020-03-22 18:24:47 UTC
Hi!

This bug is related to https://bugzilla.kernel.org/show_bug.cgi?id=206897
Comment 2 Valerio Passini 2020-03-23 05:30:31 UTC
Hi Hector, from your description is very likely that this bug report can be merged with your.
Comment 3 Valerio Passini 2020-03-23 05:31:07 UTC

*** This bug has been marked as a duplicate of bug 206897 ***

Note You need to log in before you can comment on or make changes to this bug.