Bug 206661 - iwlwifi:9260: missing PCI subdevice entries for 0x2526 (0x04010, 0x4018 and 0x401C)
Summary: iwlwifi:9260: missing PCI subdevice entries for 0x2526 (0x04010, 0x4018 and 0...
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-25 02:22 UTC by Mark Bidewell
Modified: 2020-03-26 05:25 UTC (History)
4 users (show)

See Also:
Kernel Version: 5.6 RC2
Tree: Mainline
Regression: Yes


Attachments
Boot Log of Error (5.62 KB, text/plain)
2020-02-25 02:22 UTC, Mark Bidewell
Details
patch with potential fix (1.63 KB, patch)
2020-03-10 12:40 UTC, Luca Coelho
Details | Diff

Description Mark Bidewell 2020-02-25 02:22:34 UTC
Created attachment 287603 [details]
Boot Log of Error

I am using Kernel 5.6 RC2 and I am seeing issues where firmware is not being loaded for my Intel Corporation Wireless-AC 9260 card.  Attached is the boot logging.

If I can do anything to debug, let me know,
Comment 1 Brett Hassall 2020-02-26 05:57:31 UTC
same problem on Dell Precision 5530 with Intel 9260.

boot log is the same trying to load (null)nn.ucode.

same partition works fine when booted with 5.5.0-0.rc6.git3.1.fc32.x86_64

has not worked with 5.6 rc1, rc2 or rc3.

If you need further info, let me know too.
Comment 2 Brett Hassall 2020-03-05 21:15:28 UTC
same problem in 5.6 rc4
Comment 3 Luca Coelho 2020-03-10 12:40:57 UTC
Created attachment 287849 [details]
patch with potential fix

Oops, my mistake.  As Brett pointed out on a private email, this bug was caused by this commit:

https://patchwork.kernel.org/patch/11318853/

Please try this patch to see if it solves the problem for you.
Comment 4 Mark Bidewell 2020-03-11 01:02:01 UTC
Thanks!  I'll test it as soon  as I figure out why custom kernels I build boot in a Qemu VM but not on the UEFI host.
Comment 5 Brett Hassall 2020-03-11 20:19:26 UTC
Confirm that the patch worked.

[adminu@fed32 ~]$ uname -a
Linux fed32 5.6.0-rc5-bug206661 #4 SMP Thu Mar 12 04:34:08 AEST 2020 x86_64 x86_64 x86_64 GNU/Linux
[adminu@fed32 ~]$ sudo journalctl -b | grep iwl
fed32 kernel: iwlwifi 0000:3b:00.0: enabling device (0000 -> 0002)
fed32 kernel: iwlwifi 0000:3b:00.0: Found debug destination: EXTERNAL_DRAM
fed32 kernel: iwlwifi 0000:3b:00.0: Found debug configuration: 0
fed32 kernel: iwlwifi 0000:3b:00.0: loaded firmware version 46.6bf1df06.0 9260-th-b0-jf-b0-46.ucode op_mode iwlmvm
fed32 kernel: iwlwifi 0000:3b:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324

Thanks Luca
Comment 6 Mark Bidewell 2020-03-12 15:06:35 UTC
I got a good kernel build,  I can confirm that your patch resolves this issue when applied to 5.6-rc5
Comment 7 Mark Bidewell 2020-03-12 18:46:31 UTC
Any chance this will make the 5.6 final?
Comment 8 Luca Coelho 2020-03-17 10:36:15 UTC
I sent the patch out now.  I think it will make it to v5.6 final.  I asked Kalle to apply it directly to his -fixes tree to speed things up.

https://patchwork.kernel.org/patch/11442507/
Comment 9 Brett Hassall 2020-03-26 04:50:35 UTC
I just noticed that the patch has gone into Linus' tree for v5.6.

Thanks to Luca and Kalle for the timely resolution.
Comment 10 Luca Coelho 2020-03-26 05:25:53 UTC
Thanks for reporting!

Note You need to log in before you can comment on or make changes to this bug.