Bug 206543 - snd_hda_intel no codecs found! on ASUS ROG ZENITH EXTREME II pci-id 1022:1487 subsystem 1043:874f
Summary: snd_hda_intel no codecs found! on ASUS ROG ZENITH EXTREME II pci-id 1022:1487...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-15 21:34 UTC by Yann Le Moigne
Modified: 2020-08-13 14:47 UTC (History)
9 users (show)

See Also:
Kernel Version: 5.5.2
Tree: Mainline
Regression: No


Attachments
lspci and alsainfo and other error which may be related (247.42 KB, text/plain)
2020-02-15 21:34 UTC, Yann Le Moigne
Details
content of /proc/asound/card4/usbmixer (5.21 KB, text/plain)
2020-04-07 14:34 UTC, Denis
Details
Test patch (1018 bytes, patch)
2020-04-07 15:29 UTC, Takashi Iwai
Details | Diff
Another patch for HD-audio blacklisting (1.05 KB, patch)
2020-04-07 15:40 UTC, Takashi Iwai
Details | Diff
Contents of /proc/asound/card2/usbmixer from TRX40 AORUS PRO WIFI (5.25 KB, text/plain)
2020-04-07 17:05 UTC, acs+kernel
Details
lsusb -tv from TRX40 AORUS PRO WIFI (2.16 KB, text/plain)
2020-04-07 17:06 UTC, acs+kernel
Details
lsusb -v -s 7:8 from TRX40 AORUS PRO WIFI (118.48 KB, text/plain)
2020-04-07 17:07 UTC, acs+kernel
Details
dmesg from TRX40 AORUS PRO WIFI (2.16 KB, text/plain)
2020-04-07 17:09 UTC, acs+kernel
Details
lspci -nv of TRX40 AORUS PRO WIFI (36.29 KB, text/plain)
2020-04-07 18:52 UTC, acs+kernel
Details
lsusb (120.17 KB, text/plain)
2020-04-07 19:10 UTC, scorpio
Details
Revised patch for USB-audio (2.19 KB, patch)
2020-04-08 07:14 UTC, Takashi Iwai
Details | Diff
Revised patch for HD-audio blacklisting (2.00 KB, patch)
2020-04-08 07:15 UTC, Takashi Iwai
Details | Diff

Description Yann Le Moigne 2020-02-15 21:34:25 UTC
Created attachment 287413 [details]
lspci and alsainfo and other error which may be related

On boot, I have the following message : 
kernel: snd_hda_intel 0000:23:00.4: no codecs found!


using kernel :
# uname -a
Linux panzer 5.5.2-1-MANJARO #1 SMP PREEMPT Tue Feb 4 19:22:35 UTC 2020 x86_64 GNU/Linux


If I can help by providing more/other information or by testing, I'm ready to do so.
Comment 1 dunc4n 2020-03-15 21:12:33 UTC
Having the exact same problem on Gigabyte TRX40 Aorus Pro Wifi, kernel 5.6-rc5.

This seems to be a common problem for most TRX40 Threadripper boards. They used a dual codec (ALC4050H and ALC1220-VB) with some sort of internal USB bridge?

"Because of the design of the HD audio portion of TRX40, it’s actually going through USB internally rather than through the HD audio onboard codecs, because TRX40 has no onboard HD audio codec. You’re better off using a working USB solution rather than the non-working USB solution trying to translate HD Audio interface data to USB and back.

This is something AMD missed when designing TRX40."

from:

https://forum.level1techs.com/t/asus-strx4-motherboards-s-pdif-out-issue/151850/2
Comment 2 Denis 2020-03-31 06:30:53 UTC
Same problem appears on MSI TRX40 Creator. Tested on kernels 5.5.0, 5.5.1 and 5.6.0.

dmesg flooded with messages like this:

usb 7-5: cannot get ctl value: req = 0x83, wValue = 0xc00, wIndex = 0x1300, type = 4
usb 7-5: 19:0: cannot get min/max values for control 12 (id 19)
Comment 3 Takashi Iwai 2020-04-07 14:25:32 UTC
Could you give the content of /proc/asound/card*/usbmixer file, too?
It's basically a USB-audio firmware bug, and we need some workaround...
Comment 4 Denis 2020-04-07 14:34:50 UTC
Created attachment 288251 [details]
content of /proc/asound/card4/usbmixer
Comment 5 Takashi Iwai 2020-04-07 15:28:32 UTC
Thanks.  Could you try the patch below?  At least it should skip the buggy firmware response of the reported control.
Comment 6 Takashi Iwai 2020-04-07 15:29:03 UTC
Created attachment 288253 [details]
Test patch
Comment 7 Takashi Iwai 2020-04-07 15:40:18 UTC
Also another patch to ignore the non-existing HD-audio controller.  Apply both patches.

This one contains only the already known PCI SSID: 1043:874f and 1462:cb60.
If any other devices need the same workaround, let me know here.
Comment 8 Takashi Iwai 2020-04-07 15:40:47 UTC
Created attachment 288255 [details]
Another patch for HD-audio blacklisting
Comment 9 scorpio 2020-04-07 16:59:24 UTC
Thanks Takashi. 
theses patches on 5.6.2 fixed warnings on MSI TRX40-PRO-10G.
Comment 10 acs+kernel 2020-04-07 17:05:16 UTC
Created attachment 288257 [details]
Contents of /proc/asound/card2/usbmixer from TRX40 AORUS PRO WIFI
Comment 11 acs+kernel 2020-04-07 17:06:27 UTC
Created attachment 288259 [details]
lsusb -tv from TRX40 AORUS PRO WIFI
Comment 12 acs+kernel 2020-04-07 17:07:59 UTC
Created attachment 288261 [details]
lsusb -v -s 7:8 from TRX40 AORUS PRO WIFI
Comment 13 acs+kernel 2020-04-07 17:09:02 UTC
Created attachment 288263 [details]
dmesg from TRX40 AORUS PRO WIFI
Comment 14 acs+kernel 2020-04-07 17:14:09 UTC
(In reply to Takashi Iwai from comment #7)
> Also another patch to ignore the non-existing HD-audio controller.  Apply
> both patches.
> 
> This one contains only the already known PCI SSID: 1043:874f and 1462:cb60.
> If any other devices need the same workaround, let me know here.

I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI. Does the patch apply to this board too?
Comment 15 Takashi Iwai 2020-04-07 17:14:55 UTC
Could you guys give both the PCI SSID of the entry showing "no codecs" error and the USB audio ID, as well as the board/device name?

Then I'll cook up all those into the patches to be submitted to upstream.
Comment 16 Takashi Iwai 2020-04-07 17:16:22 UTC
(In reply to acs from comment #14)
> (In reply to Takashi Iwai from comment #7)
> > Also another patch to ignore the non-existing HD-audio controller.  Apply
> > both patches.
> > 
> > This one contains only the already known PCI SSID: 1043:874f and 1462:cb60.
> > If any other devices need the same workaround, let me know here.
> 
> I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI. Does the
> patch apply to this board too?

No, I guess yours isn't listed in those patches.  Please give PCI SSID and USB ID.

FWIW, PCI SSID can be seen from "lspci -nv" output.
Comment 17 Denis 2020-04-07 18:09:42 UTC
For MSI Creator TRX40:
(1462:cb59) usb_id=0x0db00d64
23:00.4 0403: 1022:1487
        Subsystem: 1462:cb59
        Flags: bus master, fast devsel, latency 0, IRQ 162
        Memory at 91400000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
Comment 18 Gianni Chiappetta 2020-04-07 18:41:41 UTC
Asus Rog Strix TRX40-E

    22:00.4 0403: 1022:1487
    	Subsystem: 1043:874f
    	Flags: bus master, fast devsel, latency 0, IRQ 135
    	Memory at b2200000 (32-bit, non-prefetchable) [size=32K]
    	Capabilities: <access denied>
    	Kernel driver in use: snd_hda_intel

    Bus 009 Device 008: ID 0b05:1917 ASUSTek Computer, Inc. USB Audio

also, slightly off-topic, but for those who find this thread and are interested in disabling the onboard sound until the patch reaches them, you can disable the offending USB audio device with udev and blacklist the onboard audio with alsa. e.g.:

# /etc/udev/rules.d/81-disable-onboard-audio.rules
# 
# Disable onboard Asustek USB audio device (replace values with your vendor/product id)

SUBSYSTEM=="usb", ATTRS{idVendor}=="0b05", ATTRS{idProduct}=="1917", ATTR{authorized}="0"

# /etc/modprobe.d/alsa.conf
# 
# Disable hardware sound

blacklist snd_hda_intel
Comment 19 acs+kernel 2020-04-07 18:50:15 UTC
(In reply to Takashi Iwai from comment #16)
> (In reply to acs from comment #14)
> > (In reply to Takashi Iwai from comment #7)
> > > Also another patch to ignore the non-existing HD-audio controller.  Apply
> > > both patches.
> > > 
> > > This one contains only the already known PCI SSID: 1043:874f and
> 1462:cb60.
> > > If any other devices need the same workaround, let me know here.
> > 
> > I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI. Does the
> > patch apply to this board too?
> 
> No, I guess yours isn't listed in those patches.  Please give PCI SSID and
> USB ID.
> 
> FWIW, PCI SSID can be seen from "lspci -nv" output.

I'm not quite sure what PCI SSID it has. I will post the full output of "lspci -nv". The USB ID should be 0414:a002 according to lsusb:

Bus 012 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 011 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 004: ID 05e3:0723 Genesys Logic, Inc. GL827L SD/MMC/MS Flash Card Reader
Bus 009 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 009 Device 002: ID 8087:0029 Intel Corp. 
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 004: ID 0451:8140 Texas Instruments, Inc. TUSB8041 4-Port Hub
Bus 008 Device 003: ID 0451:8140 Texas Instruments, Inc. TUSB8041 4-Port Hub
Bus 008 Device 002: ID 0557:2410 ATEN International Co., Ltd 4-Port USB 3.0 Hub
Bus 008 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 007 Device 009: ID 048d:8297 Integrated Technology Express, Inc. ITE Device(8595)
Bus 007 Device 007: ID 0414:a002 Giga-Byte Technology Co., Ltd USB Audio
Bus 007 Device 005: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 007 Device 006: ID 0451:8142 Texas Instruments, Inc. TUSB8041 4-Port Hub
Bus 007 Device 003: ID 0451:8142 Texas Instruments, Inc. TUSB8041 4-Port Hub
Bus 007 Device 008: ID 1e7d:3232 ROCCAT 4-Port USB 2.0 Hub
Bus 007 Device 004: ID 0557:8021 ATEN International Co., Ltd Hub
Bus 007 Device 002: ID 0557:5411 ATEN International Co., Ltd 4-Port USB 2.0 Hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Comment 20 acs+kernel 2020-04-07 18:52:44 UTC
Created attachment 288267 [details]
lspci -nv of TRX40 AORUS PRO WIFI
Comment 21 Gianni Chiappetta 2020-04-07 18:54:14 UTC
(In reply to acs from comment #19)
> (In reply to Takashi Iwai from comment #16)
> > (In reply to acs from comment #14)
> > > (In reply to Takashi Iwai from comment #7)
> > > > Also another patch to ignore the non-existing HD-audio controller. 
> Apply
> > > > both patches.
> > > > 
> > > > This one contains only the already known PCI SSID: 1043:874f and
> > 1462:cb60.
> > > > If any other devices need the same workaround, let me know here.
> > > 
> > > I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI. Does the
> > > patch apply to this board too?
> > 
> > No, I guess yours isn't listed in those patches.  Please give PCI SSID and
> > USB ID.
> > 
> > FWIW, PCI SSID can be seen from "lspci -nv" output.
> 
> I'm not quite sure what PCI SSID it has. I will post the full output of
> "lspci -nv". The USB ID should be 0414:a002 according to lsusb:

if you grep `/var/log/dmesg.log` for `codec` you should find a message with an ID that you can match to the output of `lspci -nv`
Comment 22 scorpio 2020-04-07 19:10:24 UTC
Created attachment 288269 [details]
lsusb
Comment 23 Denis 2020-04-07 19:10:52 UTC
Just checked on MSI Creator TRX40. All error messages in log dissapeared. Front panel sound/mic don't work.
Comment 24 scorpio 2020-04-07 19:12:41 UTC
For MSI TRX40-PRO-10G.
21:00.1 0403: 1002:aae0
        Subsystem: 1da2:aae0
        Flags: bus master, fast devsel, latency 0, IRQ 166
        Memory at e1e60000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel



23:00.4 0403: 1022:1487
        Subsystem: 1462:cb60
        Flags: fast devsel, IRQ 255
        Memory at e1d00000 (32-bit, non-prefetchable) [disabled] [size=32K]
        Capabilities: <access denied>
        Kernel modules: snd_hda_intel
Comment 25 acs+kernel 2020-04-07 19:35:15 UTC
(In reply to Gianni Chiappetta from comment #21)
> (In reply to acs from comment #19)
> > (In reply to Takashi Iwai from comment #16)
> > > (In reply to acs from comment #14)
> > > > (In reply to Takashi Iwai from comment #7)
> > > > > Also another patch to ignore the non-existing HD-audio controller. 
> > Apply
> > > > > both patches.
> > > > > 
> > > > > This one contains only the already known PCI SSID: 1043:874f and
> > > 1462:cb60.
> > > > > If any other devices need the same workaround, let me know here.
> > > > 
> > > > I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI. Does
> the
> > > > patch apply to this board too?
> > > 
> > > No, I guess yours isn't listed in those patches.  Please give PCI SSID
> and
> > > USB ID.
> > > 
> > > FWIW, PCI SSID can be seen from "lspci -nv" output.
> > 
> > I'm not quite sure what PCI SSID it has. I will post the full output of
> > "lspci -nv". The USB ID should be 0414:a002 according to lsusb:
> 
> if you grep `/var/log/dmesg.log` for `codec` you should find a message with
> an ID that you can match to the output of `lspci -nv`

"cat /var/log/dmesg | grep codec" gives no results. There seems to be no "codec" message or error.

However i did search for "audio" inside dmesg and have found following:

[    0.244199] kernel: ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    4.012212] kernel: snd_hda_intel 0000:21:00.1: Handle vga_switcheroo audio client
[    4.012520] kernel: snd_hda_intel 0000:48:00.1: Handle vga_switcheroo audio client
[    6.664910] kernel: usb 7-5: Product: USB Audio
[   10.013493] kernel: usbcore: registered new interface driver snd-usb-audio
[   10.028532] kernel: input: Generic USB Audio Consumer Control as /devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:44:00.1/usb7/7-5/7-5:1.7/0003:0414:A002.0004/input/input10
[   10.088290] kernel: input: Generic USB Audio as /devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:44:00.1/usb7/7-5/7-5:1.7/0003:0414:A002.0004/input/input11
[   10.088371] kernel: hid-generic 0003:0414:A002.0004: input,hiddev0,hidraw0: USB HID v1.11 Device [Generic USB Audio] on usb-0000:44:00.1-5/input7

Could it be "44:00.1" ?


44:00.1 0c03: 1022:149c (prog-if 30 [XHCI])
	Subsystem: 1022:1486
	Flags: bus master, fast devsel, latency 0, IRQ 76
	Memory at e1300000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Kernel driver in use: xhci_hcd
Comment 26 Takashi Iwai 2020-04-07 20:32:35 UTC
(In reply to acs from comment #25)
> (In reply to Gianni Chiappetta from comment #21)
> > (In reply to acs from comment #19)
> > > (In reply to Takashi Iwai from comment #16)
> > > > (In reply to acs from comment #14)
> > > > > (In reply to Takashi Iwai from comment #7)
> > > > > > Also another patch to ignore the non-existing HD-audio controller. 
> > > Apply
> > > > > > both patches.
> > > > > > 
> > > > > > This one contains only the already known PCI SSID: 1043:874f and
> > > > 1462:cb60.
> > > > > > If any other devices need the same workaround, let me know here.
> > > > > 
> > > > > I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI. Does
> > the
> > > > > patch apply to this board too?
> > > > 
> > > > No, I guess yours isn't listed in those patches.  Please give PCI SSID
> > and
> > > > USB ID.
> > > > 
> > > > FWIW, PCI SSID can be seen from "lspci -nv" output.
> > > 
> > > I'm not quite sure what PCI SSID it has. I will post the full output of
> > > "lspci -nv". The USB ID should be 0414:a002 according to lsusb:
> > 
> > if you grep `/var/log/dmesg.log` for `codec` you should find a message with
> > an ID that you can match to the output of `lspci -nv`
> 
> "cat /var/log/dmesg | grep codec" gives no results. There seems to be no
> "codec" message or error.
> 
> However i did search for "audio" inside dmesg and have found following:
> 
> [    0.244199] kernel: ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
> [    4.012212] kernel: snd_hda_intel 0000:21:00.1: Handle vga_switcheroo
> audio client
> [    4.012520] kernel: snd_hda_intel 0000:48:00.1: Handle vga_switcheroo
> audio client
> [    6.664910] kernel: usb 7-5: Product: USB Audio
> [   10.013493] kernel: usbcore: registered new interface driver snd-usb-audio
> [   10.028532] kernel: input: Generic USB Audio Consumer Control as
> /devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:44:00.1/usb7/
> 7-5/7-5:1.7/0003:0414:A002.0004/input/input10
> [   10.088290] kernel: input: Generic USB Audio as
> /devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:44:00.1/usb7/
> 7-5/7-5:1.7/0003:0414:A002.0004/input/input11
> [   10.088371] kernel: hid-generic 0003:0414:A002.0004:
> input,hiddev0,hidraw0: USB HID v1.11 Device [Generic USB Audio] on
> usb-0000:44:00.1-5/input7
> 
> Could it be "44:00.1" ?

No, yours doesn't seem to expose the dummy HD-audio bus unlike others.

Do you see the very same error as seen in comment 2?
Comment 27 acs+kernel 2020-04-07 20:41:09 UTC
(In reply to Takashi Iwai from comment #26)
> (In reply to acs from comment #25)
> > (In reply to Gianni Chiappetta from comment #21)
> > > (In reply to acs from comment #19)
> > > > (In reply to Takashi Iwai from comment #16)
> > > > > (In reply to acs from comment #14)
> > > > > > (In reply to Takashi Iwai from comment #7)
> > > > > > > Also another patch to ignore the non-existing HD-audio
> controller. 
> > > > Apply
> > > > > > > both patches.
> > > > > > > 
> > > > > > > This one contains only the already known PCI SSID: 1043:874f and
> > > > > 1462:cb60.
> > > > > > > If any other devices need the same workaround, let me know here.
> > > > > > 
> > > > > > I've attached some files for the Gigabyte TRX40 AORUS PRO WIFI.
> Does
> > > the
> > > > > > patch apply to this board too?
> > > > > 
> > > > > No, I guess yours isn't listed in those patches.  Please give PCI
> SSID
> > > and
> > > > > USB ID.
> > > > > 
> > > > > FWIW, PCI SSID can be seen from "lspci -nv" output.
> > > > 
> > > > I'm not quite sure what PCI SSID it has. I will post the full output of
> > > > "lspci -nv". The USB ID should be 0414:a002 according to lsusb:
> > > 
> > > if you grep `/var/log/dmesg.log` for `codec` you should find a message
> with
> > > an ID that you can match to the output of `lspci -nv`
> > 
> > "cat /var/log/dmesg | grep codec" gives no results. There seems to be no
> > "codec" message or error.
> > 
> > However i did search for "audio" inside dmesg and have found following:
> > 
> > [    0.244199] kernel: ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
> > [    4.012212] kernel: snd_hda_intel 0000:21:00.1: Handle vga_switcheroo
> > audio client
> > [    4.012520] kernel: snd_hda_intel 0000:48:00.1: Handle vga_switcheroo
> > audio client
> > [    6.664910] kernel: usb 7-5: Product: USB Audio
> > [   10.013493] kernel: usbcore: registered new interface driver
> snd-usb-audio
> > [   10.028532] kernel: input: Generic USB Audio Consumer Control as
> >
> /devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:44:00.1/usb7/
> > 7-5/7-5:1.7/0003:0414:A002.0004/input/input10
> > [   10.088290] kernel: input: Generic USB Audio as
> >
> /devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:44:00.1/usb7/
> > 7-5/7-5:1.7/0003:0414:A002.0004/input/input11
> > [   10.088371] kernel: hid-generic 0003:0414:A002.0004:
> > input,hiddev0,hidraw0: USB HID v1.11 Device [Generic USB Audio] on
> > usb-0000:44:00.1-5/input7
> > 
> > Could it be "44:00.1" ?
> 
> No, yours doesn't seem to expose the dummy HD-audio bus unlike others.
> 
> Do you see the very same error as seen in comment 2?

Yes. I have the same error.


[  249.092202] usb 7-5: cannot get ctl value: req = 0x83, wValue = 0xc00, wIndex = 0x1300, type = 4
[  249.092207] usb 7-5: 19:0: cannot get min/max values for control 12 (id 19)
[  249.092694] usb 7-5: cannot get ctl value: req = 0x81, wValue = 0xc00, wIndex = 0x1300, type = 4
[  249.154195] usb 7-5: cannot get ctl value: req = 0x83, wValue = 0xc00, wIndex = 0x1300, type = 4
[  249.154199] usb 7-5: 19:0: cannot get min/max values for control 12 (id 19)
Comment 28 Takashi Iwai 2020-04-07 21:14:10 UTC
Then try to apply the patch in comment 6, and pass the following option to snd-usb-audio module
  quirk_alias=0414a002:0db00d64

This makes the usb-audio driver parsing as if it were other TRX40 device.
Comment 29 Takashi Iwai 2020-04-08 07:14:24 UTC
Below are the revised patches.  They contain the currently known devices (including AORUS PRO WIFI).

If they are OK, I'm going to submit and merge to upstream later today.
Comment 30 Takashi Iwai 2020-04-08 07:14:57 UTC
Created attachment 288271 [details]
Revised patch for USB-audio
Comment 31 Takashi Iwai 2020-04-08 07:15:36 UTC
Created attachment 288273 [details]
Revised patch for HD-audio blacklisting
Comment 32 scorpio 2020-04-08 12:07:27 UTC
Linux debian 5.6.3-vanilla #1 SMP Wed Apr 8 13:54:13 CEST 2020 x86_64 GNU/Linux
patched with 0001-ALSA-usb-audio-Add-mixer-workaround-for-TRX40-and-co.patch and 0002-ALSA-hda-Add-driver-blacklist.patch, is ok for me.

dmesg -lerr -lcrit :
[    0.390917] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.WT1A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390923] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390926] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.MT1A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390929] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390931] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.WT2A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390933] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390935] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.MT2A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390938] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390940] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.WT3A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390942] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390944] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.MT3A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390946] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390949] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.WT4A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390951] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390954] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.MT4A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390956] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390959] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CA.MT5A], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390961] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390965] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.WT1B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390967] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390969] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.MT1B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390972] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390974] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.WT2B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390977] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390979] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.MT2B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390981] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390984] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.WT3B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390986] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390988] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.MT3B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390991] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390993] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.WT4B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.390996] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.390998] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.MT4B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391000] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391003] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CB.MT5B], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391005] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391009] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.WT1C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391011] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391013] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.MT1C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391016] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391018] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.WT2C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391021] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391023] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.MT2C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391025] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391028] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.WT3C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391030] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391033] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.MT3C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391035] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391037] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.WT4C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391040] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391042] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.MT4C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391044] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391047] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CC.MT5C], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391049] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391053] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.WT1D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391055] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391057] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.MT1D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391060] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391062] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.WT2D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391065] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391067] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.MT2D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391069] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391072] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.WT3D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391074] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391077] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.MT3D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391079] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391081] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.WT4D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391084] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391086] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.MT4D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391089] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    0.391091] ACPI BIOS Error (bug): Failure creating named object [\_SB.I2CD.MT5D], AE_ALREADY_EXISTS (20200110/dswload2-323)
[    0.391093] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200110/psobject-220)
[    2.979721] sp5100-tco sp5100-tco: Watchdog hardware is disabled

Not sound issue reported, thanks
Comment 33 acs+kernel 2020-04-08 21:55:13 UTC
Kernel 5.6.3 and Ubuntu 19.10 - TRX40 AORUS PRO WIFI

Installed both patches. The errors are gone. Audio on the back seems to work. No sound on the front. But this problem also exists without installed patch.

Thanks.
Comment 34 dunc4n 2020-04-08 23:49:01 UTC
Another TRX40 AORUS PRO WIFI user here. Tried with the two provided patches on kernel 5.6.3 but still getting 'no codecs found' error.
Comment 35 dunc4n 2020-04-09 02:14:29 UTC
Was a bit too quick. 3.5mm ports seem to work, but SPDIF is dead, as well as front ports.
Comment 36 Takashi Iwai 2020-04-09 12:58:23 UTC
The patches have been merged and on the way to 5.7-rc1, so let's close this bug.

If any other devices are to be added to the existing table, open another bug report to track.  There, please give the PCI SSID and USB ID of the corresponding devices.

For the rest, the lack of the function (front jack and SPDIF), please open another bug report, too.  There, please give alsa-info.sh output (run with --no-script option and attach to Bugzilla).
Comment 37 Takashi Iwai 2020-04-11 10:21:12 UTC
FYI, further fixes for USB-audio devices are developed in bug 206873.

It'd be appreciated if you can try the patches there, and report back what I/O corresponds to each PCM substream (for both playback and capture) on your system, as well as alsa-info.sh output and stream* proc contents.
Comment 38 Jason Birch 2020-04-24 01:19:20 UTC
Is there a way to force load through this blacklist?

The ASUS Rampage VI Extreme — an Intel X299 board — also uses one of these devices, and doesn't seem to suffer from these quirks (seen here booted into an older kernel):

```
$ lspci -knn -s 00:1f.3
00:1f.3 Audio device [0403]: Intel Corporation 200 Series PCH HD Audio [8086:a2f0]
	Subsystem: ASUSTeK Computer Inc. Device [1043:874f]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
```

And on older kernels, works a treat — codecs are found and sound is fine:

```
$ journalctl -b -t kernel | grep -E "Linux version|snd_hda_intel|ALC1220"
Apr 23 13:46:31 evilmorty kernel: Linux version 5.5.16-200.fc31.x86_64 (mockbuild@bkernel03.phx2.fedoraproject.org) (gcc version 9.3.1 20200317 (Red Hat 9.3.1-1) (GCC)) #1 SMP Wed Apr 8 16:43:33 UTC 2020
Apr 23 18:46:36 evilmorty kernel: snd_hda_intel 0000:17:00.1: Disabling MSI
Apr 23 18:46:36 evilmorty kernel: snd_hda_intel 0000:17:00.1: Handle vga_switcheroo audio client
Apr 23 18:46:36 evilmorty kernel: snd_hda_intel 0000:65:00.1: Disabling MSI
Apr 23 18:46:36 evilmorty kernel: snd_hda_intel 0000:65:00.1: Handle vga_switcheroo audio client
Apr 23 18:46:36 evilmorty kernel: snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1220: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line

$ aplay -l | grep -a2 ALC1220
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC1220 Digital [ALC1220 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
```


However, no such luck recently:

```
$ journalctl -b -1 -t kernel | grep -E "Linux version|snd_hda_intel|ALC1220"
Apr 23 13:22:18 evilmorty kernel: Linux version 5.6.6-200.fc31.x86_64 (mockbuild@bkernel03.phx2.fedoraproject.org) (gcc version 9.3.1 20200408 (Red Hat 9.3.1-2) (GCC)) #1 SMP Tue Apr 21 15:34:22 UTC 2020
Apr 23 18:22:23 evilmorty kernel: snd_hda_intel 0000:00:1f.3: Skipping the blacklisted device
Apr 23 18:22:23 evilmorty kernel: snd_hda_intel 0000:17:00.1: Disabling MSI
Apr 23 18:22:23 evilmorty kernel: snd_hda_intel 0000:17:00.1: Handle vga_switcheroo audio client
Apr 23 18:22:23 evilmorty kernel: snd_hda_intel 0000:65:00.1: Disabling MSI
Apr 23 18:22:23 evilmorty kernel: snd_hda_intel 0000:65:00.1: Handle vga_switcheroo audio client
```

Which removes the onboard line-out and friends for this motherboard.
Comment 39 Takashi Iwai 2020-04-24 06:14:35 UTC
Currently no way.  But the blacklist entry for ROG was already removed in sound.git tree and it'll be merged to 5.7-rc3 today.
The proper blacklist process will be merged after that, but likely to 5.8.
So, ROG user will see the empty HD-audio slot again until 5.8-rc1, but it should be harmless.
Comment 40 Takashi Iwai 2020-04-24 07:13:00 UTC
On the second thought, the additional fix is fairly safe and might help for other cases with the shared PCI SSID, so I put now to for-linus branch, which is destined for 5.7-rc4.
Comment 41 Jason Birch 2020-04-26 01:33:36 UTC
Thank you for clarifying, and thanks for driving it!
Comment 42 Ronny 2020-08-13 14:47:39 UTC
Hello! I have the Gigabyte TRX40 Dignare and I have updated to the 5.8 kernel on Ubuntu, but I still don't have any sound, which of the patches should I try to install?

sudo dmesg | grep intel
[    9.427508] snd_hda_intel 0000:26:00.4: enabling device (0000 -> 0002)
[    9.428448] snd_hda_intel 0000:49:00.1: enabling device (0000 -> 0002)
[    9.428659] snd_hda_intel 0000:49:00.1: Disabling MSI
[    9.428684] snd_hda_intel 0000:49:00.1: Handle vga_switcheroo audio client
[    9.430976] snd_hda_intel 0000:26:00.4: no codecs found!

Note You need to log in before you can comment on or make changes to this bug.