Bug 206503 - Built-in Speakers do not work by default on MSI Laptops
Summary: Built-in Speakers do not work by default on MSI Laptops
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-12 03:46 UTC by João Victor
Modified: 2020-02-17 15:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.4.17-200.fc31.x86_64
Tree: Mainline
Regression: No


Attachments
My alsa info (43.64 KB, text/plain)
2020-02-12 03:46 UTC, João Victor
Details

Description João Victor 2020-02-12 03:46:37 UTC
Created attachment 287319 [details]
My alsa info

Pretty much the same problem as Bug 204159, but with my laptop being a MSI GP63 Leopard 8RE instead of an MSI GL73 9SE. They use the same audio card (ALC1220),and are just one generation apart, so I gather the mixer path mistake is the same. Would the fix be the same, but instead of:

SND_PCI_QUIRK(0x1462, 0x1276, "MSI-GL73", ALC1220_FIXUP_CLEVO_P950),

It would be:

SND_PCI_QUIRK(0x1462, 0x1276, "MSI-GP63", ALC1220_FIXUP_CLEVO_P950),

?
Comment 1 Takashi Iwai 2020-02-12 08:16:19 UTC
Yours looks like 1462:1228, so replace 1276 with 1228 and check whether the quirk works.
Comment 2 João Victor 2020-02-13 14:25:08 UTC
Thanks for the quick reply. Will apply the patch this weekend and report back.
Comment 3 João Victor 2020-02-17 15:09:19 UTC
Thanks, it works!

After patching the kernel, my built-in speakers work normally now.
Comment 4 Takashi Iwai 2020-02-17 15:21:08 UTC
OK, good to hear.  I submitted and applied the fix to sound git tree, commit a655e2b107d463ce2745188ce050d07daed09a71
    ALSA: hda/realtek - Apply quirk for MSI GP63, too

It'll be included in the next pull request for 5.6-rc3 and will be backported to stable trees later.

Note You need to log in before you can comment on or make changes to this bug.