Bug 206333 - iwlwifi: 3168: Can't parse phy_sku in B0, empty sections
Summary: iwlwifi: 3168: Can't parse phy_sku in B0, empty sections
Status: RESOLVED DUPLICATE of bug 206329
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-28 02:57 UTC by Clément Guérin
Modified: 2020-02-12 18:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.5.0
Tree: Mainline
Regression: Yes


Attachments
dmesg output (85.24 KB, text/plain)
2020-01-28 02:57 UTC, Clément Guérin
Details

Description Clément Guérin 2020-01-28 02:57:47 UTC
Created attachment 287005 [details]
dmesg output

I just upgraded to linux 5.5.0 and the wifi doesn't work. Please find the dmesg attached.

[    6.296140] iwlwifi 0000:04:00.0: Can't parse phy_sku in B0, empty sections
[    6.296142] iwlwifi 0000:04:00.0: Failed to read NVM: -61
[    6.296145] iwlwifi 0000:04:00.0: Collecting data: trigger 16 fired.
[    6.297316] iwlwifi 0000:04:00.0: Start IWL Error Log Dump:
[    6.300482] iwlwifi 0000:04:00.0: Status: 0x00000040, count: 6
[    6.300484] iwlwifi 0000:04:00.0: Loaded firmware version: 29.163394017.0
Comment 1 Clément Guérin 2020-01-28 04:35:09 UTC
Updating linux-firmware to 20200122 sadly didn't help.
Comment 2 joanbrugueram 2020-01-28 11:58:19 UTC
Potential duplicate of Bug 206329.
Comment 3 Clément Guérin 2020-02-03 05:48:27 UTC
I can confirm it's a duplicate, the patch mentioned in that bug solves the problem for me.

*** This bug has been marked as a duplicate of bug 206329 ***
Comment 4 Clément Guérin 2020-02-12 18:02:17 UTC
Fixed with linux 5.5.3.
Comment 5 Clément Guérin 2020-02-12 18:58:42 UTC
Disregard the previous comment, it was fixed by the Arch Linux maintainers with v5.5.2-arch2

Note You need to log in before you can comment on or make changes to this bug.