Bug 205959 - Audio not working after kernel update - dummy output - HP Spectre x360 15-dfxxx
Summary: Audio not working after kernel update - dummy output - HP Spectre x360 15-dfxxx
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-24 17:33 UTC by Fily1212
Modified: 2020-02-22 17:20 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.4.6-050406-generic
Tree: Mainline
Regression: No


Attachments
lspci-vnvn (70.61 KB, text/plain)
2019-12-24 17:33 UTC, Fily1212
Details
dmesg (107.97 KB, text/plain)
2020-01-06 13:39 UTC, FatTony
Details

Description Fily1212 2019-12-24 17:33:47 UTC
Created attachment 286423 [details]
lspci-vnvn

I have a HP Spectre x360 15-df0006nl. 
Audio was working on Linux Kernel 5.3.18.
After update on 5.4 (I've tried 5.4.5 and 5.4.6) audio doesn't work. I can't see any devices in alsamixer. 

This is my OS version: 
Linux version 5.4.6-050406-generic (kernel@kathleen) (gcc version 9.2.1 20191130 (Ubuntu 9.2.1-21ubuntu1)) #201912211140 SMP Sat Dec 21 11:43:01 UTC 2019

Let me know if I have to submit more information. I attach lspci-vnvn log.
Comment 1 Takashi Iwai 2020-01-04 10:58:36 UTC
Maybe the device is now supported by SOF driver and you didn't enable the driver or miss the firmware / topology files.

If you need to use the legacy driver, passing snd_hda_intel.dmic_detect=0 option should work.
Comment 2 FatTony 2020-01-06 13:39:07 UTC
Created attachment 286653 [details]
dmesg

search for dmic_detect or sof-audio-pci to find the relevant error messages.
Comment 3 FatTony 2020-01-06 13:46:27 UTC
Sorry for double-posting.

I seem to have the same issue. My laptop is a `HP Spectre x360 df0709nz`. It worked on kernel 5.3.x.

`alsa-info.sh` gave me the device ID: `00:1f.3 0401: 8086:9dc8 (rev 30) Subsystem: 103c:8518`

On kernel `5.4.7-200.fc31.x86_64`, the sound card is not detected. See dmesg, search for `sof-audio-pci` for the relevant errors.

Adding kernel parameter `snd_hda_intel.dmic_detect=0` didn't help. I got this error in dmesg: `snd_hda_intel: unknown parameter 'dmic_detect' ignored`.

How can I try SOF drivers?
Comment 4 Jaroslav Kysela 2020-01-06 15:43:57 UTC
The dmic_detect parameter was removed from snd_hda_intel and replaced by "snd-intel-dspcfg.dsp_driver=1" kernel parameter in the latest kernel code.

  echo "options snd-intel-dspcfg dsp_driver=1" > /etc/modprobe.d/alsa.conf
Comment 5 FatTony 2020-01-08 10:25:15 UTC
@Jaroslav Kysela: Thanks. Sound and mic work again.
Comment 6 Benjamin Lowry 2020-01-11 21:12:13 UTC
Editing /etc/modprobe.d/alsa.conf made sound work again on my ThinkPad X1 Carbon 7, but now the top-firing speakers don't work, only the rear ones do. All of the speakers worked fine on 5.3.x.
Comment 7 FatTony 2020-01-17 16:12:36 UTC
On kernel `5.4.10-200.fc31.x86_64`, the workaround is not necessary anymore to get sound. However, the Laptop's mic isn't working. (Headphone mic works.)

❯ sudo lspci -vnvn | grep audio -A16
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Cannon Point-LP High Definition Audio Controller [8086:9dc8] (rev 30)
	Subsystem: Hewlett-Packard Company Device [103c:8518]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 183
	Region 0: Memory at 6043118000 (64-bit, non-prefetchable) [size=16K]
	Region 4: Memory at 6043000000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [50] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [80] Vendor Specific Information: Len=14 <?>
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
		Address: 00000000fee00838  Data: 0000
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl
Comment 8 FatTony 2020-02-22 16:45:23 UTC
On kernel `5.5.5-200.fc31.x86_64`, the problem reappeared and can be fixed with the same workaround. (`echo "options snd-intel-dspcfg dsp_driver=1" > /etc/modprobe.d/alsa.conf`)
Comment 9 Jaroslav Kysela 2020-02-22 17:20:38 UTC
The long term goal is to enable the SOF driver by default. Please, follow https://bugzilla.redhat.com/show_bug.cgi?id=1772498 and report your problem there (install all suggested updates at first).

Note You need to log in before you can comment on or make changes to this bug.