Bug 205855 - 5.4.2 -> 5.4.3 results in strange & unusable sound output on hda-intel (nvidia)
Summary: 5.4.2 -> 5.4.3 results in strange & unusable sound output on hda-intel (nvidia)
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
: 205865 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-14 14:02 UTC by Christopher Frömmel
Modified: 2019-12-21 17:39 UTC (History)
6 users (show)

See Also:
Kernel Version: 5.4.3
Tree: Mainline
Regression: No


Attachments

Description Christopher Frömmel 2019-12-14 14:02:40 UTC
After updating from 5.4.2 to 5.4.3 hda-intel sound output of my Nvidia card is broken regarding quality and volume control.
 
I had to go back to .2 on my gentoo system.
GFX is GTX970 running with nvidia-drivers v440.40

Unfortunately I have not discovered logs providing some errors yet.
Any confirmation or clues?

Regards. Chris
Comment 1 Christopher Frömmel 2019-12-14 15:18:57 UTC
I have found something in 5.4.3 changelog that might be linked with my hdmi-codec based (?) sound problems.

commit d050d2807328a5fbd721759266a9b6ee5691be12
Author: Takashi Iwai <tiwai@suse.de>
Date:   Mon Dec 2 08:49:47 2019 +0100

    ALSA: hda: Modify stream stripe mask only when needed
    
    commit e38e486d66e2a3b902768fd71c32dbf10f77e1cb upstream.
    
    The recent commit in HD-audio stream management for changing the
    stripe control seems causing a regression on some platforms.  The
    stripe control is currently used only by HDMI codec, and applying the
    stripe mask unconditionally may lead to scratchy and static noises as
    seen on some MacBooks.
    
    For addressing the regression, this patch changes the stream
    management code to apply the stripe mask conditionally only when the
    codec driver requested.
    
    Fixes: 9b6f7e7a296e ("ALSA: hda: program stripe bits for controller")
    BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=204477
    Tested-by: Michael Pobega <mpobega@neverware.com>
    Cc: <stable@vger.kernel.org>
    Link: https://lore.kernel.org/r/20191202074947.1617-1-tiwai@suse.de
    Signed-off-by: Takashi Iwai <tiwai@suse.de>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Comment 2 Takashi Iwai 2019-12-14 15:52:57 UTC
Could you try the patch in
  https://bugzilla.kernel.org/attachment.cgi?id=286287
?
Comment 3 Christopher Frömmel 2019-12-14 16:51:07 UTC
(In reply to Takashi Iwai from comment #2)
> Could you try the patch in
>   https://bugzilla.kernel.org/attachment.cgi?id=286287
> ?

It's working.
Thanks a lot!
Chris
Comment 4 Takashi Iwai 2019-12-15 19:50:44 UTC
*** Bug 205865 has been marked as a duplicate of this bug. ***
Comment 5 Philip Langdale 2019-12-15 20:33:28 UTC
Works for me as well. Thanks.
Comment 6 Richard Narron 2019-12-16 12:23:08 UTC
(In reply to Takashi Iwai from comment #2)
> Could you try the patch in
>   https://bugzilla.kernel.org/attachment.cgi?id=286287
> ?

Takashi, this fixes my 5.4.3 kernel.

But should we be sending the original patch which caused the bug,
"ALSA: hda: Modify stream stripe mask only when needed",
to all older kernels?

Should not we wait until this fix is available too?
Comment 7 Takashi Iwai 2019-12-16 12:26:35 UTC
Don't worry, the fix was already submitted to upstream and merged to sound git tree.  It will be included in the next pull request which will be eventually backported to stable trees.
Comment 8 Richard Narron 2019-12-16 12:31:56 UTC
(In reply to Christopher Frömmel from comment #1)
> I have found something in 5.4.3 changelog that might be linked with my
> hdmi-codec based (?) sound problems.
> 
> commit d050d2807328a5fbd721759266a9b6ee5691be12
> Author: Takashi Iwai <tiwai@suse.de>
> Date:   Mon Dec 2 08:49:47 2019 +0100
> 
>     ALSA: hda: Modify stream stripe mask only when needed
>     
>
Yes, reverting this patch fixed the problem for me.
Comment 9 Kfir Itzhak 2019-12-19 11:10:36 UTC
Hi,

I would just like to add that 5.3.16 is also affected. I upgraded to kernel 5.3.16 and suffered from the same problem with my Nvidia card. Booting with older kernel fixed it.

Thank you,
Kfir
Comment 10 Christopher Frömmel 2019-12-21 17:39:00 UTC
Fixed in 5.4.6 stable release

Note You need to log in before you can comment on or make changes to this bug.