Bug 205717 - tg3 silently drops all traffic
Summary: tg3 silently drops all traffic
Status: RESOLVED DUPLICATE of bug 12877
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-29 23:47 UTC by Nathan Shearer
Modified: 2020-09-27 05:58 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.4
Tree: Mainline
Regression: Yes


Attachments
macmini 6,2 dmidecode (28.17 KB, text/plain)
2019-11-29 23:50 UTC, Nathan Shearer
Details
Unaffected Kernel Config 4.4.203 (183.67 KB, text/plain)
2019-12-02 15:31 UTC, Nathan Shearer
Details
Affected Kernel Config 5.4 (234.57 KB, text/plain)
2019-12-02 15:33 UTC, Nathan Shearer
Details

Description Nathan Shearer 2019-11-29 23:47:54 UTC
This is a regression. The tg3 driver works fine on 4.4.203 on Mac Mini 6,1 and 6,2 computers, but will silently drop all packets after a tiny load on all newer kernel versions.

To reproduce:
 1) use a Mac Mini 6,1 or 6,2 or computer with the same network chip.
 2) ssh root@macmini dd if=/dev/urandom | dd of=/dev/null
 3) watch the bandwidh on the macmini. It will drop to 0b/s after a few moments

Mac Mini 6,2
  4.4.203 is not affected (12 hours, high cpu load, over 800GB transferred without error)
  4.9.203 is affected (eth0 timeout after only 6.3GB of transfer, no messages in dmesg)
  4.14.156 is affected (eth0 timeout in seconds after only 1.5GB of transfer, no messages in dmesg)
  5.3.11 is affected (eth0 timeout after only 6.3GB of transfer, no messages in dmesg)
  5.4 is affected (eth0 timeout after only 10GB of transfer, no messages in dmesg)

Changing tx rx sg and tso with ethtool does not help.
Comment 1 Nathan Shearer 2019-11-29 23:50:29 UTC
Created attachment 286123 [details]
macmini 6,2 dmidecode
Comment 2 Nathan Shearer 2019-12-02 15:31:30 UTC
Created attachment 286149 [details]
Unaffected Kernel Config 4.4.203
Comment 3 Nathan Shearer 2019-12-02 15:33:04 UTC
Created attachment 286151 [details]
Affected Kernel Config 5.4
Comment 4 Nathan Shearer 2020-09-27 04:48:32 UTC
This is duplicate of bug 12877
Comment 5 Nathan Shearer 2020-09-27 05:58:08 UTC

*** This bug has been marked as a duplicate of bug 12877 ***

Note You need to log in before you can comment on or make changes to this bug.