Bug 205119 - It takes long time to wake up from s2idle on Dell XPS 7390 2-in-1
Summary: It takes long time to wake up from s2idle on Dell XPS 7390 2-in-1
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_pci@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-08 02:56 UTC by AceLan Kao
Modified: 2019-10-14 05:59 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.4-rc2
Tree: Mainline
Regression: No


Attachments
dmesg log (140.80 KB, text/plain)
2019-10-08 02:56 UTC, AceLan Kao
Details

Description AceLan Kao 2019-10-08 02:56:27 UTC
Created attachment 285395 [details]
dmesg log

1. Enter s2idle at 28.39s
2. Press power button at 246.10s
3. The machine stuck until 412.30s and spit out thunderbolt warning messages
4. thunderbolt port keeps working after s2idle, plug-in Dell WD19TB dock(472.45s), and the "boltctl list" shows the dock info correctly.

BTW, I also found that there are 2 tbt ports on the machine, and if I plug in one TBT dock, and the wakeup time could be reduced by 80 seconds. And if I plug in 2 docks in both TBT ports, the machine wakes up from s2idle quick enough as the normal system.

I believe the 2 lines are related.
[  330.388604] thunderbolt 0000:00:0d.3: failed to send driver ready to ICM
[  412.308083] thunderbolt 0000:00:0d.2: failed to send driver ready to ICM
Comment 1 wendy.wang 2019-10-14 02:24:54 UTC
It should be the BIOS issue. 
Please contact Dell BIOS engineer to understand whether BIOS 1.0.9 08/02/2019 is based on the latest Intel reference BIOS code. 

If not, please try with the latest BIOS version (should base on the Intel reference BIOS code version newer than v3241).
Comment 2 AceLan Kao 2019-10-14 05:59:34 UTC
Yes, after upgraded the BIOS to v1.0.13, the issue is gone.
Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.