Bug 205083 - With Sound Open Firmware audio doesn't work on Dell Venue 11 Pro 7140 (Broadwell)
Summary: With Sound Open Firmware audio doesn't work on Dell Venue 11 Pro 7140 (Broadw...
Status: RESOLVED DUPLICATE of bug 204237
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-03 17:10 UTC by RussianNeuroMancer
Modified: 2019-10-25 05:03 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.2.9
Tree: Mainline
Regression: No


Attachments
Linux 5.3.1 with CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT=y (63.11 KB, text/plain)
2019-10-03 17:12 UTC, RussianNeuroMancer
Details
Linux 5.3.1 without CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT (62.17 KB, text/plain)
2019-10-03 17:12 UTC, RussianNeuroMancer
Details

Description RussianNeuroMancer 2019-10-03 17:10:02 UTC
Hello!

I noticed that since Linux 5.2rc2 audio playback no longer works on Dell Venue 11 Pro 7140 (Intel Core M-5Y71; rt286). Turns out that happened because SND_SOC_SOF_BROADWELL_SUPPORT was enabled in kernel binary builds since 5.2rc2: https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.2-rc2/

To verify this assumption I tested two builds of Linux 5.3.1.
1. Build with enabled SND_SOC_SOF_BROADWELL_SUPPORT from https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.3.1/

Audio playback doesn't work, dmesg:
[    4.072800] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.212606] broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
[    4.238009] broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
[    4.294920] broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
[    4.407351] broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
[    4.428922] broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
[    4.458926] broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
[    4.472113] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
[    4.472118] haswell-pcm-audio haswell-pcm-audio: fw image intel/IntcPP01.bin not available(-2)
[    4.472735] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[    4.474607] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System Pin mapping ok
[    4.474676] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload0 Pin mapping ok
[    4.474741] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload1 Pin mapping ok
[    4.474807] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Loopback Pin mapping ok
[    4.476377] broadwell-audio broadwell-audio: rt286-aif1 <-> snd-soc-dummy-dai mapping ok
[    4.480344] input: broadwell-rt286 Headset as /devices/pci0000:00/INT3438:00/broadwell-audio/sound/card1/input14
[    7.892659] haswell-pcm-audio haswell-pcm-audio: error: message type 7 header 0x87000000
[   13.015379] haswell-pcm-audio haswell-pcm-audio: error: reset stream 2 still running
[   13.127262] haswell-pcm-audio haswell-pcm-audio: error: reset stream 0 still running
[   19.623436] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- ipcx 0x86120000 isr 0x00000000 ipcd 0x47000000 imrx 0x7fff0000
[   19.623446] haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 faile

2. Build with disabled SND_SOC_SOF_BROADWELL_SUPPORT.

Audio playback works, dmesg:
[    4.839028] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
[    4.839034] haswell-pcm-audio haswell-pcm-audio: fw image intel/IntcPP01.bin not available(-2)
[    4.839644] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[    4.851204] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.907386] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System Pin mapping ok
[    4.907475] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload0 Pin mapping ok
[    4.909831] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload1 Pin mapping ok
[    4.909931] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Loopback Pin mapping ok
[    4.912149] broadwell-audio broadwell-audio: rt286-aif1 <-> snd-soc-dummy-dai mapping ok
[    4.929629] input: broadwell-rt286 Headset as /devices/pci0000:00/INT3438:00/broadwell-audio/sound/card1/input14
Comment 1 RussianNeuroMancer 2019-10-03 17:12:31 UTC
Created attachment 285325 [details]
Linux 5.3.1 with CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT=y
Comment 2 RussianNeuroMancer 2019-10-03 17:12:59 UTC
Created attachment 285327 [details]
Linux 5.3.1 without CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT
Comment 3 David Ward 2019-10-25 03:02:34 UTC
This is a duplicate of bug 204237.
Comment 4 RussianNeuroMancer 2019-10-25 05:03:52 UTC

*** This bug has been marked as a duplicate of bug 204237 ***

Note You need to log in before you can comment on or make changes to this bug.