Bug 205069 - Black screen when starting graphical environment
Summary: Black screen when starting graphical environment
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-01 20:53 UTC by freddyreimer
Modified: 2019-10-02 23:10 UTC (History)
0 users

See Also:
Kernel Version: 5.3.1, 5.4.0-rc1, latest
Tree: Mainline
Regression: No


Attachments
kernel .config 5.4.0-rc1 (172.19 KB, text/plain)
2019-10-01 20:53 UTC, freddyreimer
Details
dmesg (78.50 KB, text/plain)
2019-10-01 20:54 UTC, freddyreimer
Details
lsmod (10.00 KB, text/plain)
2019-10-01 20:54 UTC, freddyreimer
Details
lspci -vv (26.68 KB, text/plain)
2019-10-01 20:54 UTC, freddyreimer
Details
Xorg log from amdgpu freeze startx (14.42 KB, text/plain)
2019-10-01 20:55 UTC, freddyreimer
Details

Description freddyreimer 2019-10-01 20:53:17 UTC
Created attachment 285285 [details]
kernel .config 5.4.0-rc1

Hello there

On kernels 5.3.1 and 5.4.0-rc1, I get a black screen with a white underscore
cursor in the upper left. The display gets stuck in this state, with no way to
switch to a different TTY or leave this aside from hitting the reset button.
I can secure-shell into the box and get a login at this time, but killing the
process does not fix the display. Sway WM also does this, with it just getting
stuck at the prompt entry.

I have an AMD RX 5700 graphics card, using the amdgpu driver. When I do some
manual configuration by blacklisting amdgpu and writing a stanza in xorg conf
for vesa, I am able to get X running using vesa.

uname -a output: Linux gentoo 5.4.0-rc1 #1 SMP Tue Oct 1 14:24:57 EDT 2019 x86_64 AMD Ryzen 5 3600 6-Core Processor AuthenticAMD GNU/Linux
Comment 1 freddyreimer 2019-10-01 20:54:08 UTC
Created attachment 285287 [details]
dmesg
Comment 2 freddyreimer 2019-10-01 20:54:34 UTC
Created attachment 285289 [details]
lsmod
Comment 3 freddyreimer 2019-10-01 20:54:58 UTC
Created attachment 285291 [details]
lspci -vv
Comment 4 freddyreimer 2019-10-01 20:55:51 UTC
Created attachment 285293 [details]
Xorg log from amdgpu freeze startx
Comment 5 freddyreimer 2019-10-01 21:03:58 UTC
I've seen another report on a similar issue, where the suggestion (solution?) was to be using a newer mesa and llvm. I am on llvm 9 and mesa 19.2.0


*  media-libs/mesa
      Latest version available: 19.2.0
      Latest version installed: 19.2.0_rc4

*  sys-devel/llvm
      Latest version available: 9.0.0
      Latest version installed: 9.0.0
Comment 6 Michel Dänzer 2019-10-02 08:54:03 UTC
Was Mesa built against LLVM 9, not an older version?

It looks like the problem occurs when the Xorg driver tries loading glamor, so a Mesa/LLVM issue is most likely.
Comment 7 freddyreimer 2019-10-02 23:10:42 UTC
Gotcha. I did not know until very recently that the graphics output for this kernel navi driver required a specific set of userland libraries to exist. I recompiled mesa and also got onto a new version of llvm-common for good measure.

This worked! Thank you for your help! I am able to launch Xorg on AMDGPU driver, without resorting to vesa, and can also run Sway wm. No display freezing or anything like that. I'll set this as resolved.

Reminder for future reference if someone comes across this with the same issue. You need at minimum LLVM 9 and Mesa 19.2.0. The LLVM has to be installed first.

Thank you again.

Note You need to log in before you can comment on or make changes to this bug.