Bug 204965 - [amdgpu]] *ERROR* ring gfx test failed (-110) upon wake from sleep, no video or frozen video
Summary: [amdgpu]] *ERROR* ring gfx test failed (-110) upon wake from sleep, no video ...
Status: RESOLVED DUPLICATE of bug 204241
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-23 13:59 UTC by David
Modified: 2019-10-23 16:46 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.2.13-126.current
Tree: Mainline
Regression: No


Attachments
journalctl bits (6.11 KB, text/plain)
2019-09-23 13:59 UTC, David
Details
5.3.4-arch1-1-ARCH (3.24 KB, text/plain)
2019-10-18 11:46 UTC, Mario
Details

Description David 2019-09-23 13:59:46 UTC
Created attachment 285115 [details]
journalctl bits

Solus 4, issue has been present since an AMD card (RX580 4GB) was installed in this machine in july and has happened nine times.

The machine, asleep, wakes up, fans and LEDs come on, but there is either no video signal out or there is a signal showing only a frozen screen of a clock when the machine fell asleep. No keyboard input has an effect.
The machine still responds to pings over the network. DVI or DP interface makes no difference.


Radeon RX 580 Series (POLARIS10 DRM 3.32.0 5.2.13-126.current LLVM 8.0.1) v: 4.5 Mesa 19.1.6  on Z170-HD3 mainboard, i7 6700 CPU.
Comment 1 Mario 2019-10-18 11:46:45 UTC
Created attachment 285545 [details]
5.3.4-arch1-1-ARCH

Happened to me too on 5.3.4-arch1-1-ARCH after wake from suspend.
Comment 2 Andrey Grodzovsky 2019-10-18 19:12:56 UTC
Seems to me the same as https://bugzilla.kernel.org/show_bug.cgi?id=204241 - which is resolved already - give those patches a try.
The OOPS following the resume failure is a side issue and should be handled separatly.
Comment 3 David 2019-10-22 05:48:45 UTC
Thanks for the replies. Yes, looks like a dupe; I'll try to apply the last patch attached as soon as I've read up on how patch works. You can close this I guess.
Comment 4 David 2019-10-23 16:46:53 UTC

*** This bug has been marked as a duplicate of bug 204241 ***

Note You need to log in before you can comment on or make changes to this bug.