Bug 204851 - nouveau kernel module won't load (not available) on Sony laptop with NVIDIA G86M [GeForce 8400M GT] ID: 10de:0426
Summary: nouveau kernel module won't load (not available) on Sony laptop with NVIDIA G...
Status: CLOSED MOVED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: acpi_bios
URL: http://fm.no-ip.com/Tmp/Linux/Xorg/Nv/
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-15 09:30 UTC by Felix Miata
Modified: 2019-09-29 12:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.2.11; 5.2.14
Tree: Mainline
Regression: No


Attachments
dmesg using vanilla 5.2.14 on openSUSE Tumbleweed (52.76 KB, text/plain)
2019-09-15 09:30 UTC, Felix Miata
Details

Description Felix Miata 2019-09-15 09:30:44 UTC
Created attachment 284969 [details]
dmesg using vanilla 5.2.14 on openSUSE Tumbleweed

Original summary:
nouveau won't load (not available) on Sony laptop with NVIDIA G86M [GeForce 8400M GT] ID: 10de:0426 

This errant behavior is similarly exhibited by openSUSE Tumbleweed, 15.0, 13.1 and 12.2; Linuxmint 19.0 live installation media; Knoppix 8.2 and 8.6 live media; antiX 17.4. Using vanilla kernel 5.2.14 doesn't help.

Actual behavior:
1-nouveau kernel module doesn't load
2-ttys limited to 1024x768 mode
3-X runs only with VESA or FBDEV drivers and limited to 1024x768 mode
4-/dev/dri/card0 is absent
5-hwinfo reports HDTV display supports maximum VESA 1024x768 mode
6-GeForce 8400M gfx reported by lspci is not found by Xorg
7-[drm] Failed to open DRM device for pci:0000:01:00.0: -19
8-hwinfo improperly detects display
9-laptop locks up (requires poweroff reset) unless cmdline includes acpi=off

Expected behavior:
1-ttys use display's native 1920x1080 mode
2-X uses modesetting DDX or nouveau DDX and native 1920x1080 mode

# inxi -GxxSMaz
System:    Host: vaio Kernel: 5.2.11-1-default x86_64 bits: 64 compiler: gcc v: 9.2.1 
           parameters: root=/dev/sda9 ipv6.disable=1 net.ifnames=0 noresume mitigations=auto consoleblank=0 
           drm.debug=0x1e log_buf_len=1M acpi=off vga=791 video=1280x720@60 video=1024x768@60 video=1440x900@60 3 acpi=off 
           Console: tty 3 dm: N/A Distro: openSUSE Tumbleweed 20190907 
Machine:   Type: Laptop System: Sony product: VGN-AR730E v: C3LR1E11 serial: <filter> Chassis: type: 10 serial: N/A 
           Mobo: Sony model: VAIO serial: N/A BIOS: Phoenix v: R2090J8 date: 02/26/2008 
Graphics:  Device-1: NVIDIA G86M [GeForce 8400M GT] vendor: Sony driver: N/A bus ID: 01:00.0 chip ID: 10de:0426 
           Display: server: X.org 1.20.5 driver: nouveau,vesa unloaded: fbdev,modesetting alternate: nv,nvidia tty: 128x48 
           Message: Advanced graphics data unavailable in console for root. 
# lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G86M [GeForce 8400M GT] (rev a1)
# lspci -vv -d 10de:0426
01:00.0 VGA compatible controller: NVIDIA Corporation G86M [GeForce 8400M GT] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Sony Corporation Device 9016
	Physical Slot: 1
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 5
	Region 0: Memory at ce000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at cc000000 (64-bit, non-prefetchable) [size=32M]
	Region 5: I/O ports at 2000 [size=128]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <4us
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 75.000W
		DevCtl:	CorrErr- NonFatalErr- FatalErr- UnsupReq-
			RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <512ns, L1 <4us
			ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
		LnkCtl:	ASPM L0s L1 Enabled; RCB 128 bytes Disabled- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s (ok), Width x16 (ok)
			TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
	Kernel modules: nouveau
# dmesg | grep veau
# journalctl -b | grep veau
# lsmod | grep veau
# lsmod | grep video
uvcvideo              118784  0
videobuf2_vmalloc      20480  1 uvcvideo
videobuf2_memops       20480  1 videobuf2_vmalloc
video                  53248  0
videobuf2_v4l2         28672  1 uvcvideo
videobuf2_common       57344  2 videobuf2_v4l2,uvcvideo
videodev              233472  3 videobuf2_v4l2,uvcvideo,videobuf2_common
media                  57344  4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
usbcore               303104  5 ehci_pci,usbhid,uvcvideo,ehci_hcd,uhci_hcd
# modprobe nouveau
modprobe: ERROR: could not insert 'nouveau': No such device
# hwinfo --monitor
31: None 00.0: 10000 Monitor
  [Created at fb.71]
  Unique ID: rdCR.EY_qmtb9YY0
  Hardware Class: monitor
  Model: "Generic Monitor"
  Vendor: "Generic"
  Device: "Monitor"
  Resolution: 1024x768@76Hz
  Year of Manufacture: 0
  Week of Manufacture: 0
  Driver Info #0:
    Max. Resolution: 1024x768
    Vert. Sync Range: 50-90 Hz
    Hor. Sync Range: 31-61 kHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown
# hwinfo --gfxcard
16: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.386]
  Unique ID: VCu0.3ZIBFiHqnhE
  Parent ID: vSkL.__4Fox8chd3
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GeForce 8400M GT"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0426 "GeForce 8400M GT"
  SubVendor: pci 0x104d "Sony Corporation"
  SubDevice: pci 0x9016 
  Revision: 0xa1
  Memory Range: 0xce000000-0xceffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xcc000000-0xcdffffff (rw,non-prefetchable)
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 5 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000426sv0000104Dsd00009016bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: nv
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)
Primary display adapter: #16
# egrep 'dri|ailed|veau' /var/log/Xorg.0.log | grep -v 't driver'
[  2155.322] (II) Scanning /etc/X11/xorg_pci_ids directory for additional PCI ID's supported by the drivers
[  2155.322] (==) Matched nvidia as autoconfigured driver 0
[  2155.322] (==) Matched nouveau as autoconfigured driver 1
[  2155.322] (==) Matched nv as autoconfigured driver 2
[  2155.322] (==) Matched modesetting as autoconfigured driver 3
[  2155.322] (==) Matched fbdev as autoconfigured driver 4
[  2155.322] (==) Matched vesa as autoconfigured driver 5
[  2155.322] (==) Assigned the driver to the xf86ConfigLayout
[  2155.322] (EE) Failed to load module "nvidia" (module does not exist, 0)
[  2155.322] (II) LoadModule: "nouveau"
[  2155.323] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[  2155.323] (II) Module nouveau: vendor="X.Org Foundation"
[  2155.323] (EE) Failed to load module "nv" (module does not exist, 0)
[  2155.323] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[  2155.323] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[  2155.324] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[  2155.324] (II) NOUVEAU driver 
[  2155.324] (II) NOUVEAU driver for NVIDIA chipset families :
[  2155.324] (II) FBDEV: driver for framebuffer: fbdev
[  2155.324] (II) VESA: driver for VESA chipsets: vesa
[  2155.535] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[  2155.536] (EE) open /dev/dri/card0: No such file or directory
[  2155.536] (EE) open /dev/dri/card0: No such file or directory
[  2156.135] (II) VESA(0): VESA VBE DDC read failed
[  2156.135] (II) VESA(0): VESA VBE PanelID read failed
Comment 1 Felix Miata 2019-09-15 16:46:15 UTC
http://fm.no-ip.com/Tmp/Linux/Xorg/Nv/ is my data and logs collection since beginning to troubleshoot this.
Comment 2 Zhang Rui 2019-09-16 01:57:25 UTC
hmm, this sounds like a graphics issue, please file a bug at freedesktop.org instead.
Comment 3 Felix Miata 2019-09-16 02:08:31 UTC
Yes it's a graphics issue, caused because the kernel won't load the nouveau kernel module.
Comment 4 Felix Miata 2019-09-16 03:51:31 UTC
Linux vaio 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) x86_64 x86_64 x86_64 GNU/Linux

Binutils            	2.32
Util-linux          	2.34
Mount               	2.34
Module-init-tools   	26
E2fsprogs           	1.45.3
Xfsprogs            	5.0.0
PPP                 	2.4.7
Nfs-utils           	2.1.1
Linux C Library     	2.29
Dynamic linker (ldd)	2.29
Linux C++ Library   	6.0.27
Procps              	3.3.15
Kbd                 	2.0.4
Console-tools       	2.0.4
Sh-utils            	8.31
Udev                	242
Modules Loaded      	ata_generic ata_piix auth_rpcgss cdrom cfg80211 coretemp crc_itu_t dm_mod dm_multipath dns_resolver drm drm_kms_helper ehci_hcd ehci_pci fb_sys_fops fscache gpio_ich grace hid_generic i2c_algo_bit i2c_i801 iTCO_vendor_support iTCO_wdt irqbypass iscsi_boot_sysfs iscsi_ibft joydev kvm ledtrig_audio lockd lpc_ich mac80211 media msr nfs nfsv4 pcmcia pcmcia_core pcmcia_rsrc pcspkr rfkill rpcsec_gss_krb5 scsi_dh_alua scsi_dh_emc scsi_dh_rdac serio_raw sg sky2 snd snd_hda_codec snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_codec_realtek snd_hda_core snd_hda_intel snd_hwdep snd_pcm snd_timer soundcore sr_mod sunrpc syscopyarea sysfillrect sysimgblt tifm_7xx1 tifm_core ttm uhci_hcd usbcore usbhid video yenta_socket
Comment 5 Felix Miata 2019-09-16 03:55:43 UTC
Linux vaio 5.2.14-2.g7f85414-vanilla #1 SMP Fri Sep 13 11:31:46 UTC 2019 (7f85414) x86_64 x86_64 x86_64 GNU/Linux

Binutils            	2.32
Util-linux          	2.34
Mount               	2.34
Module-init-tools   	26
E2fsprogs           	1.45.3
Xfsprogs            	5.0.0
PPP                 	2.4.7
Nfs-utils           	2.1.1
Linux C Library     	2.29
Dynamic linker (ldd)	2.29
Linux C++ Library   	6.0.27
Procps              	3.3.15
Kbd                 	2.0.4
Console-tools       	2.0.4
Sh-utils            	8.31
Udev                	242
Modules Loaded      	arc4 ata_generic ata_piix cdrom cfg80211 coretemp crc_itu_t dm_mod dm_multipath drm drm_kms_helper ehci_hcd ehci_pci fb_sys_fops firewire_core firewire_ohci gpio_ich hid_generic i2c_algo_bit i2c_i801 iTCO_vendor_support iTCO_wdt irqbypass iscsi_boot_sysfs iscsi_ibft iwl4965 iwlegacy joydev kvm ledtrig_audio lpc_ich mac80211 media msr pcmcia pcmcia_core pcmcia_rsrc pcspkr rfkill scsi_dh_alua scsi_dh_emc scsi_dh_rdac serio_raw sg sky2 snd snd_hda_codec snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_codec_realtek snd_hda_core snd_hda_intel snd_hwdep snd_pcm snd_timer soundcore sr_mod syscopyarea sysfillrect sysimgblt tifm_7xx1 tifm_core ttm uhci_hcd usbcore usbhid uvcvideo video videobuf2_common videobuf2_memops videobuf2_v4l2 videobuf2_vmalloc videodev yenta_socket
Comment 6 Zhang Rui 2019-09-29 08:06:24 UTC
I mean you should file a bug at freedesktop.org, the nouveau related bugs are handled there.
This bug is closed.
Comment 7 Felix Miata 2019-09-29 09:51:58 UTC
And I mean this is a kernel module bug, not a freedesktop bug.
Comment 8 Felix Miata 2019-09-29 10:47:09 UTC
I finally stumbled onto https://nouveau.freedesktop.org/wiki/Bugs/ which does claim to be the right place, even though most of freedesktop has moved to https://gitlab.freedesktop.org/xorg/ where I had no luck finding anything about nouveau. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.