Bug 204751 - No C-states on Dell XPS 15 9570 after resume from deep sleep
Summary: No C-states on Dell XPS 15 9570 after resume from deep sleep
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpuidle (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-02 09:54 UTC by s.zharkoff
Modified: 2019-09-10 06:46 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.3-rc1
Tree: Mainline
Regression: Yes


Attachments
turbostat log before suspend (19.70 KB, text/plain)
2019-09-03 14:32 UTC, s.zharkoff
Details
turbostat log after suspend (19.65 KB, text/plain)
2019-09-03 14:32 UTC, s.zharkoff
Details

Description s.zharkoff 2019-09-02 09:54:51 UTC
Dell XPS 15 9570. Kernel 5.2.10 - all ok, suspend-resume, C states available.

Kernel 5.3-rc6 - powertop shows 0% of package C-states, power consumption increases.
Comment 1 s.zharkoff 2019-09-02 14:50:01 UTC
Looks like all 5.3-rc kernels  have this bug
Comment 2 Zhang Rui 2019-09-03 13:14:29 UTC
please run "turbostat --debug -i 5 -o ts-before-suspend.out" before suspend and "turbostat --debug -i 5 -o ts-after-suspend.out" after suspend, keep each command run 30 seconds before you kill it.
Comment 3 s.zharkoff 2019-09-03 14:32:09 UTC
Created attachment 284777 [details]
turbostat log before suspend
Comment 4 s.zharkoff 2019-09-03 14:32:43 UTC
Created attachment 284779 [details]
turbostat log after suspend
Comment 5 s.zharkoff 2019-09-03 14:34:32 UTC
Added the logs. CPU cores are reaching c-states, but the package is not. I've tested on  recently released 5.3-rc7.
Comment 6 Zhang Rui 2019-09-09 02:52:16 UTC
before suspend
CPU%c7	CoreTmp	PkgTmp	GFX%rc6	GFXMHz	Totl%C0	Any%C0	GFX%C0
99.40	38	38	99.85	350	1.29	0.79	0.14
after resume
CPU%c7	CoreTmp	PkgTmp	GFX%rc6	GFXMHz	Totl%C0	Any%C0	GFX%C0
99.49	39	39	1.32	350	1.21	1.00	95.04

It is graphics that blocks cpu from entering package c-state.
Please file a bug at freedesktop.org and attach the full dmesg output with kernel parameter drm.debug=0xe, after the problem reproduced.
Comment 7 s.zharkoff 2019-09-10 06:46:40 UTC
Opened freedesktop bug
https://bugs.freedesktop.org/show_bug.cgi?id=111623

Note You need to log in before you can comment on or make changes to this bug.