Bug 204677 - Crackling sound on Ryzen 5 2500U
Summary: Crackling sound on Ryzen 5 2500U
Status: RESOLVED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-23 21:58 UTC by Haxk20
Modified: 2019-12-22 18:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.3rc5
Tree: Mainline
Regression: No


Attachments
dmesg (114.79 KB, text/plain)
2019-08-23 21:58 UTC, Haxk20
Details

Description Haxk20 2019-08-23 21:58:31 UTC
Created attachment 284579 [details]
dmesg

This has been an issue for a long time but we havent got to reporting it as we didnt know what was the cause of the issue. Now we know.
The issue comes from the fact that the OEM charger for the laptops dont filter out any noice other device may cause. And somehow this affects the audio in some scenarios. For me its youtube and when i launch discord web the audio goes nuts.
When we remove other devices from outlet it all goes away.
I know you may now think that this isnt Linux Kernel issue but well this does not occur in any way on Windows so there is surely something wrong somewhere in code.

Im attaching dmesg but if you need anything else just tell.
Oh and here is post on phoronix from user who actually discovered the cause of this: https://bit.ly/2TY4dG0
Comment 1 Haxk20 2019-08-23 22:08:45 UTC
Scratch the statement about power outlet stuff. It seemed too crazy it was. Rebooted laptop without power plugged in and launched discord. Unexpectedly the crackling begun.
TBH this is really annoying.
Comment 2 Haxk20 2019-08-23 22:14:35 UTC
It just seems like that after we unplug power from laptop it doesnt happen anymore or its just that it doesnt happen anymore after it dissapers after the first one. Will test tomorrow.
Comment 3 alpha_one_x86 2019-09-02 13:11:55 UTC
Same with 3400G and TUF Gaming B450M-PLUS here, tested with 5.2.11 kernel
Comment 4 Haxk20 2019-09-02 13:35:32 UTC
(In reply to alpha_one_x86 from comment #3)
> Same with 3400G and TUF Gaming B450M-PLUS here, tested with 5.2.11 kernel

I dont think you have the same bus as this. So far we have confirmed this only on laptops and desktops have similar bug that is fixed in 5.3
Comment 5 Haxk20 2019-10-27 23:36:40 UTC
havent seen this bug in a while now.
Comment 6 Luna 2019-12-22 18:47:15 UTC
Sadly this bug still seem to exist. Tested on Kernel 5.4.3 with an X3700 CPU + X570 Aorus Pro. All audio devices (Onboard, Creative Soundblaster X-Fi HD, Corsair Void Wireless) suffer from it the same way on all possible outputs.

Note You need to log in before you can comment on or make changes to this bug.