Bug 204607 - es8316 multiple issues
Summary: es8316 multiple issues
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-17 22:54 UTC by xenobro
Modified: 2019-08-17 22:59 UTC (History)
0 users

See Also:
Kernel Version: 5.2.9
Tree: Mainline
Regression: No


Attachments
alsa-info.txt (72.36 KB, text/plain)
2019-08-17 22:54 UTC, xenobro
Details

Description xenobro 2019-08-17 22:54:31 UTC
Created attachment 284481 [details]
alsa-info.txt

Using only ALSA on my Positivo 2 em 1 Q432A (motherboard CHT12CP, es8316 sound card, kernel 5.2.9), speakers only work with headphones plugged in.
Using Pulseaudio, speakers work without hps, but many other problems remain: no microphones work; speakers are muted every boot and anytime hps are unplugged, have no volume control and are only a mute/unmute switch; there are more than 160 controls in alsamixer's bytcht-es8316 card, most having no effect on sound output; and I still couldn't test hdmi audio.
UCM files might solve these issues, but I have no experience with those, so any help would be dearly appreciated.
If any other info is needed, just tell me and I'll add it.
Thank you very much.
Comment 1 xenobro 2019-08-17 22:59:57 UTC
Please erase my previous bug description because it was too long: https://bugzilla.kernel.org/show_bug.cgi?id=204539

Note You need to log in before you can comment on or make changes to this bug.