Bug 204577 - iwlwifi: 8260: firmware crashes repeatedly with LMAC ASSERT 0xEDC
Summary: iwlwifi: 8260: firmware crashes repeatedly with LMAC ASSERT 0xEDC
Status: CLOSED DUPLICATE of bug 203315
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-14 13:31 UTC by Bob Vincent
Modified: 2019-08-20 13:14 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.2.0-050200rc4-lowlatency
Tree: Mainline
Regression: No


Attachments
dmesg output (22.07 KB, application/pgp-encrypted)
2019-08-14 13:31 UTC, Bob Vincent
Details
firmware crash log (1.35 MB, application/octet-stream)
2019-08-14 13:32 UTC, Bob Vincent
Details
kern.log (3.39 KB, application/octet-stream)
2019-08-14 13:36 UTC, Bob Vincent
Details

Description Bob Vincent 2019-08-14 13:31:58 UTC
Created attachment 284383 [details]
dmesg output

Folllowed directions on https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging

Attaching dmesg and crash log, encrypted to the developers, as directed.
Comment 1 Bob Vincent 2019-08-14 13:32:57 UTC
Created attachment 284385 [details]
firmware crash log
Comment 2 Bob Vincent 2019-08-14 13:36:28 UTC
Created attachment 284387 [details]
kern.log
Comment 3 Bob Vincent 2019-08-14 13:42:11 UTC
From a user perspective, network traffic suddenly stops.  Typing "ip addr" shows no address associated with the wireless interface.  But NetworkManager still shows the device as connected.

Disconnecting / Reconnecting temporarily resolves the problem.

Starting a large number of connections (such as "apt-get update") usually causes the problem to reoccur.

I am running Ubuntu Disco with the lowlatency kernel:

Package: linux-lowlatency
Version: 5.0.0.25.26
Priority: optional
Section: kernel
Source: linux-meta
Origin: Ubuntu
Maintainer: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 15.4 kB
Depends: linux-image-lowlatency (= 5.0.0.25.26), linux-headers-lowlatency (= 5.0.0.25.26)
Supported: 9m
Download-Size: 1,860 B
APT-Sources: http://security.ubuntu.com/ubuntu disco-security/main amd64 Packages
Description: Complete lowlatency Linux kernel
 This package will always depend on the latest complete lowlatency Linux kernel
 available.
Comment 4 Bob Vincent 2019-08-14 13:44:36 UTC
bobvin@T560:~/Downloads/iwlwifi-bug-report ethtool -i wlp4s0 | grep firmware
firmware-version: 36.9f0a2d68.0
Comment 5 Luca Coelho 2019-08-20 13:14:26 UTC

*** This bug has been marked as a duplicate of bug 203315 ***

Note You need to log in before you can comment on or make changes to this bug.