Bug 204549 - Confusing warning about edid_firmware kernel parameters, possibly simple typo
Summary: Confusing warning about edid_firmware kernel parameters, possibly simple typo
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: All Linux
: P1 low
Assignee: drivers_video-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-11 11:58 UTC by Göran Uddeborg
Modified: 2019-08-22 07:43 UTC (History)
0 users

See Also:
Kernel Version: 5.2.5-200.fc30.x86_64
Tree: Mainline
Regression: No


Attachments

Description Göran Uddeborg 2019-08-11 11:58:26 UTC
When looking through the boot messages more closely than usual, I found the message

  aug 10 12:01:53 mimmi kernel: [drm] drm_kms_firmware.edid_firmware is deprecated, please use drm.edid_firmware instead.

When trying to do as I was told, it was confusing since I couldn't find I used "drm_kms_firmware" when grep:ing through my configurations.  It turns out I used the parameter drm_kms_helper.edid_firmware.  If I understand how the code in drivers/gpu/drm/drm_kms_helper_common.c correctly, that is indeed the parameter being warned about.  This might simply be a typo in the message, unless there is something I'm missing.
Comment 1 Jani Nikula 2019-08-21 09:44:03 UTC
Thanks for the report, fix posted at http://patchwork.freedesktop.org/patch/msgid/20190821094312.5514-1-jani.nikula@intel.com
Comment 2 Jani Nikula 2019-08-22 07:43:34 UTC
Thanks for the report, fixed in drm-misc-next branch by

commit ade925995b172f1d7410d1c665b2f47c5e99bef0
Author: Jani Nikula <jani.nikula@intel.com>
Date:   Wed Aug 21 12:43:12 2019 +0300

    drm: fix module name in edid_firmware log message

Note You need to log in before you can comment on or make changes to this bug.