Bug 2044 - boot hang unless "nolapic" - hp pavilion ze4125
boot hang unless "nolapic" - hp pavilion ze4125
Status: REJECTED DUPLICATE of bug 1269
Product: ACPI
Classification: Unclassified
Component: BIOS
i386 Linux
: P2 high
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-07 07:52 UTC by Michael Calabrese
Modified: 2004-08-13 19:40 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.2
Tree: Mainline
Regression: ---


Attachments
HP ZE4125 acpidmp (tz.gz) (32.94 KB, application/octet-stream)
2004-02-07 07:56 UTC, Michael Calabrese
Details
test patch to not re-enable LAPIC if BIOS disabled it (666 bytes, patch)
2004-04-23 22:25 UTC, Len Brown
Details | Diff

Description Michael Calabrese 2004-02-07 07:52:38 UTC
Distribution: Slackware 
Hardware Environment: HP Pavilion ze4125 
Software Environment: 
Problem Description: 
kernel boot hangs on line "executing _Sta and_INI methods:...." on nb presario 
2154ea 
 
Steps to reproduce: Boot with a 2.6.2 kernel with ACPI enabled. (and 
APMdisabled) (Last known working is 2.4.20 and it does not work using 2.6.0 
kernel.) 
 
I have updated my bios to the most current (KA.M1.24).  I did not see any 
futher patchs. 
 
I will include my acpidmp.
Comment 1 Michael Calabrese 2004-02-07 07:56:00 UTC
Created attachment 2046 [details]
HP ZE4125 acpidmp (tz.gz)
Comment 2 Michael Calabrese 2004-02-10 15:29:55 UTC
Still does not work in 2.6.3rc2
Comment 3 Shaohua 2004-02-12 16:40:40 UTC
did you enable lapic? we have some problems with both acpi and lapic enabled.
Comment 4 Michael Calabrese 2004-02-17 14:43:37 UTC
Sorry it took me so long to respond. Yes that worked.  I can't adjust the cpu
freq, but I suspect that may not be possible on my laptop.  I can not get
temprature and battery.  If you have any clues on the cpu (Athlon XP) I would
love to hear them.
Comment 5 Michael Calabrese 2004-02-17 16:55:36 UTC
I meant to say, I CAN get the temperature and battery.
Comment 6 Len Brown 2004-03-04 14:00:18 UTC
so this problem goes away with "nolapic"?
is "nolapic" still needed in 2.6.4?

thanks,
-Len
Comment 7 Michael Calabrese 2004-03-08 07:48:36 UTC
That is correct. Using nolapic fixes the problem.
Comment 8 Len Brown 2004-04-12 22:34:11 UTC
is nolapic still required on 2.6.5? 
Comment 9 Len Brown 2004-04-23 22:25:51 UTC
Created attachment 2681 [details]
test patch to not re-enable LAPIC if BIOS disabled it

please test this patch w/o any boot parameters and let me know
if 2.6.5 (or so) boots.  There are several ways of enabling the LAPIC,
and this patch disable the technique where Linux enables the
LAPIC when the BIOS had it disabled.  It might be that we always
want to do this when in ACPI mode.
Comment 10 Len Brown 2004-05-12 21:00:28 UTC

*** This bug has been marked as a duplicate of 1269 ***
Comment 11 Justin F. 2004-05-15 12:13:19 UTC
Len,

I applied the patch as suggested in your reply to me on the lkml (re: new laptop
woes), my hp pavillion ze4430us/slackware box boots fine w/ the patch applied to
either 2.6.5 or 2.6.6, although it still prints the ACPI: IRQ9 SCI: Level
Trigger. message that it hung on, and your statements:

LENB: !cpu_has_apic
LENB: NOT reenabling LAPIC

also printed, aside from that as far as I can tell, everything is working fine.
BUT it definatly boots ;]
thanks.

Note You need to log in before you can comment on or make changes to this bug.