Bug 204325 - Black screen after boot
Summary: Black screen after boot
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: x86-64 Linux
: P1 blocking
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-26 13:58 UTC by Wes Newell
Modified: 2019-08-15 14:52 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.2.1 through 5.2.5
Tree: Mainline
Regression: Yes


Attachments

Description Wes Newell 2019-07-26 13:58:06 UTC
Upgrading from 5.1.19 to 5.2.x leaves system unusable as all I get is a black screen. System may be running but can't get any video at all. Screen stays black no matter what I do. Can;t even get to a separate login using ctrl alt F keys.
Asrock AB350 mb AMD 2300G cpu using internal video.
Comment 1 Nic Ola 2019-07-31 20:43:17 UTC
I have the same issue using AMD 2400G (Wes I think you did a typo) on Asrock (AB350M Pro4) as well.

I don't have a black screen but some logs displayed when the boot is failing. I reported it here: https://bugzilla.kernel.org/show_bug.cgi?id=204369

It is probably a duplicate.

Thanks in advance for the quick investigation as the 5.1 branch is EOL.
Comment 2 Wes Newell 2019-08-01 05:02:11 UTC
yep. I have a Ryzen 3 2200G (not 2300G), 16GB ram. But I'm completely locked out after boot with nothing but a black screen and no keyboard access. Xubuntu 18.04.2 LTS xfce desktop with latest updates. I've tried all the latest kernels including 5.2.5. same with all of them. I haven't tried to login remotely. if someone needs some testing, just let me know. This is my main mthtv server that runs 24/7, so currently running 5.1.21.
Comment 3 Wes Newell 2019-08-01 06:06:26 UTC
Booting kernel 5.2.5. Keyboard and screen locked, but system is running as I can both log in to mythtv server from remote frontend machine. Can also ssh into system. Looking at kern.log I see lots of *Error* messages on amdgpu and it is disabled. I don't know what's changed from 5.1.21 kernel, but none of the 5.2 kernels work.
Comment 4 Nic Ola 2019-08-01 09:18:04 UTC
Thanks Wes for the update: so it should probably be re-routed to Drivers product, Video component. 
I tried I cannot do it on mine. I don't know if some admin could take it in charge..
Comment 5 Wes Newell 2019-08-01 15:24:24 UTC
Don't know much about this, but just changed top of report to drivers. Not sure what else to do, or if that even worked.
Comment 6 Wes Newell 2019-08-01 15:28:08 UTC
Seems it did. changed to drivers - video. Hope someone can fix this.
Comment 7 Nic Ola 2019-08-01 21:05:09 UTC
Nice, I think you can tag it as a regression as well. As it is working fine on 5.1.x
Comment 8 Wes Newell 2019-08-02 20:38:36 UTC
Aug  2 15:05:30 mythfe0 kernel: [  513.998930] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=1, emitted seq=3
Aug  2 15:05:30 mythfe0 kernel: [  513.999017] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process Xorg pid 1112 thread Xorg:cs0 pid 1155
Aug  2 15:05:30 mythfe0 kernel: [  513.999020] [drm] GPU recovery disabled.

These lines are repeated about 10 times at the end of kern.log when trying to boot 5.2.x kernels. Had to ssh in to get this. Hope this helps.
Comment 9 Nic Ola 2019-08-02 21:23:33 UTC
If you want you can add the log file in attachment. It could help (if someone comes around here.. :))
Comment 10 Wes Newell 2019-08-05 08:35:35 UTC
Just tried kernel 2.5.6 with same result. Is anyone looking at this?
Comment 11 Wes Newell 2019-08-07 14:51:23 UTC
5.2.7 doesn't work either.
Comment 12 Kenji 2019-08-10 16:16:08 UTC
Try my workaround

I downloaded the latest drivers from amd

https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-navi-linux

extracted them all

ran

 sudo ./amdgpu-pro-install

reboot
Comment 13 Wes Newell 2019-08-11 05:35:39 UTC
Installed the above drivers on 5.1.21 kernel. The loaded 5.2.7 kernel and everything works perfect so far, so installed just released 5.2.8 and it seems to be ok too. Thanks Only question I have is why aren't these part of the new 5.2.x kernels?
Comment 14 Kenji 2019-08-11 18:47:59 UTC
No idea, maybe an admin knows, I just fix stuff lol
Comment 15 Nic Ola 2019-08-15 14:52:42 UTC
This solution is not quite acceptable (at least for me) as amdgpu pro is the proprietary driver, so it only replaces the open source one (which looks faulty on 5.2 branch). I am using MESA from the padoka stable ppa, which is currently on MESA 19.1 https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa

Note You need to log in before you can comment on or make changes to this bug.