Bug 204167 - Intel AC 9560 firmware 46.a41adfe7.0 FW error in SYNC CMD GEO_TX_POWER_LIMIT
Summary: Intel AC 9560 firmware 46.a41adfe7.0 FW error in SYNC CMD GEO_TX_POWER_LIMIT
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: DO NOT USE - assign "network-wireless-intel" component instead
URL:
Keywords:
: 204233 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-13 21:50 UTC by Daniel.Albers
Modified: 2019-09-20 06:25 UTC (History)
8 users (show)

See Also:
Kernel Version: 5.2.0
Tree: Mainline
Regression: No


Attachments
dmesg (90.46 KB, text/plain)
2019-07-13 21:50 UTC, Daniel.Albers
Details
dmesg with 46.0e6a7071.0 (91.28 KB, text/plain)
2019-07-16 08:55 UTC, xavier B
Details
firmware-version: 46.a41adfe7.0 with debug=1 (93.18 KB, text/plain)
2019-07-19 19:12 UTC, dyegomb
Details
dmesg (90.70 KB, text/plain)
2019-07-21 08:50 UTC, Muhajirin Ilyas
Details
don't send GEO_TX_POWER_LIMIT on version < 41 (2.85 KB, patch)
2019-07-22 13:23 UTC, haim.dreyfuss
Details | Diff
patch applied log (2.16 MB, text/plain)
2019-07-22 21:40 UTC, xavier B
Details
46.a41adfe7.0 on AC 9462 (182.18 KB, text/plain)
2019-08-12 10:36 UTC, dobs
Details

Description Daniel.Albers 2019-07-13 21:50:35 UTC
Created attachment 283671 [details]
dmesg

Hi,

the firmware version 46.a41adfe7.0 on AC 9560 is failing with the error: FW error in SYNC CMD GEO_TX_POWER_LIMIT

This happens with kernel: 5.2.0 and 5.1.0

Firmware version 46.3cfab8da.0 seems to work fine.
Comment 1 xavier B 2019-07-16 08:55:38 UTC
Created attachment 283735 [details]
dmesg with 46.0e6a7071.0
Comment 2 xavier B 2019-07-16 08:55:59 UTC
hi!

So apparently the change dates from 2019-06-20, by Luca Coelho <luciano.coelho@intel.com>	

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=e58cbf78678fd872d0cf7ab858ba0030cd8695b0

I also tried with the firmware version: 46.0e6a7071.0 (from b44321804352ea595cddffbd8fad81a6c91c128d just before on the same day)

and it doesn't work either.

In summary, with both kernel 5.2.0 and 5.1.0,
46.3cfab8da.0  WORKS
46.0e6a7071.0  FAILS
46.a41adfe7.0  FAILS
Comment 3 dyegomb 2019-07-19 19:12:46 UTC
Created attachment 283849 [details]
firmware-version: 46.a41adfe7.0 with debug=1

The same occurs to me.
Comment 4 Muhajirin Ilyas 2019-07-21 08:02:23 UTC
*** Bug 204233 has been marked as a duplicate of this bug. ***
Comment 5 haim.dreyfuss 2019-07-21 08:09:40 UTC
Can you please run it with debug=0x80 or even better with debug=0xffffffff,
modprobe iwlwifi debug=0xffffffff
Comment 6 Muhajirin Ilyas 2019-07-21 08:50:13 UTC
Created attachment 283875 [details]
dmesg

(In reply to haim.dreyfuss from comment #5)
> Can you please run it with debug=0x80 or even better with debug=0xffffffff,
> modprobe iwlwifi debug=0xffffffff
Comment 7 haim.dreyfuss 2019-07-22 13:23:43 UTC
Created attachment 283917 [details]
don't send GEO_TX_POWER_LIMIT on version < 41

Please apply this patch and give it a try.
Comment 8 xavier B 2019-07-22 21:40:24 UTC
Created attachment 283923 [details]
patch applied log

Hi!

I've tested the patch with linux 5.2.2
and firmware version 46.a41adfe7.0.

Appears to works fine!

just in case, I include the full debug log.
Comment 9 xavier B 2019-07-27 09:48:32 UTC
For the record: 

updated to "Linux version 5.2.3-arch1-1-ARCH" with doesn't contain the change from attachment 283923 [details].
and firmware 46.a41adfe7.0 loads and works just fine.
Comment 10 dobs 2019-08-12 10:36:46 UTC
Created attachment 284333 [details]
46.a41adfe7.0 on AC 9462

Hello,

I am using Fedora 30, on Dell Inc. Vostro 5481/0PK27Y, BIOS 1.0.0 09/05/2018.

WiFi does not work after updating the kernel to version: 5.2.6-200.fc30.x86_64.

The firmware version 46.a41adfe7.0 on AC 9462 is failing with the error: FW error in SYNC CMD GEO_TX_POWER_LIMIT

You can find more details in the attachments
Comment 11 dobs 2019-08-13 13:54:11 UTC
Upd: This solution helped for me
https://bugzilla.redhat.com/show_bug.cgi?id=1733369


sudo dnf downgrade -y iwl7260-firmware
sudo rmmod iwlmvm iwlwifi
sudo modprobe iwlwifi

Note You need to log in before you can comment on or make changes to this bug.