Bug 204099 - systemd-networkd fails on 5.2 - same version works on 5.1.16
Summary: systemd-networkd fails on 5.2 - same version works on 5.1.16
Status: RESOLVED DUPLICATE of bug 203769
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 low
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-09 00:44 UTC by Ian Kumlien
Modified: 2019-07-09 15:26 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.2
Tree: Mainline
Regression: No


Attachments

Description Ian Kumlien 2019-07-09 00:44:01 UTC
This is more FYI, I haven't had time to properly debug it.

Booting 5.2 causes systemd-networkd to fail to bring any interface up, it will fail with: "Could not bring up interface: Invalid argument"

However, booting 5.1.16 with the same software works just fine.

Sounds like something was changed in, what I assume is, the netlink API
Comment 1 Yanko Kaneti 2019-07-09 15:19:12 UTC
This is a duplicate of bug 203769
Comment 2 Stephen Hemminger 2019-07-09 15:26:26 UTC

*** This bug has been marked as a duplicate of bug 203769 ***

Note You need to log in before you can comment on or make changes to this bug.