Bug 204009 - iwlwifi: 3165: WiFi connection stalls with high traffic
Summary: iwlwifi: 3165: WiFi connection stalls with high traffic
Status: CLOSED DUPLICATE of bug 203315
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-27 16:44 UTC by Rthomsen
Modified: 2019-06-27 18:49 UTC (History)
0 users

See Also:
Kernel Version: 5.1
Tree: Mainline
Regression: No


Attachments
Microcode SW error (3.00 KB, text/plain)
2019-06-27 18:42 UTC, Rthomsen
Details

Description Rthomsen 2019-06-27 16:44:46 UTC
After upgrading to 5.1.x kernel my wifi-connection stalls when downloading at high speeds after a few seconds. The connection is not dropped, but the speed slows down to zero and I can't open any websites at all. Disconnecting and re-connecting to the access point fixes the problem. This has only happened when downloading torrents at speeds >6MB/s. Downgrading to any 5.0.x kernel fixes the problem. I have the most recent firmware (iwlwifi-7265D-29.ucode).

I tried disabling powersave and tcp_ecn but it didn't solve the problem.

Output from "lspci|grep Wireless":
02:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99)

Output from "journalctl -b|grep iwl":
jun 26 21:54:03 mephisto kernel: iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
jun 26 21:54:03 mephisto kernel: iwlwifi 0000:02:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
jun 26 21:54:03 mephisto kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
jun 26 21:54:03 mephisto kernel: iwlwifi 0000:02:00.0: base HW address: e0:94:67:a9:82:79
jun 26 21:54:03 mephisto kernel: ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
jun 26 21:54:03 mephisto kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
jun 26 21:54:03 mephisto NetworkManager[389]: <info>  [1561578843.6212] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/ieee80211/phy0/rfkill1) (driver iwlwifi)

Output from "lsmod |grep iwl":
iwlmvm                229376  0
iwlwifi               188416  1 iwlmvm
Comment 1 Rthomsen 2019-06-27 16:46:19 UTC
Also there is no output in dmesg or journalctl when the connections stalls.
Comment 2 Rthomsen 2019-06-27 18:42:56 UTC
Created attachment 283465 [details]
Microcode SW error

I noticed that sometimes when the problem occurs (though not always) there is a microcode error in the kernel log.
Comment 3 Emmanuel Grumbach 2019-06-27 18:48:52 UTC
Ah - this has been fixed already.

Please check https://bugzilla.kernel.org/show_bug.cgi?id=203315.

I am marking this as duplicate, you can re-open if the fix from https://bugzilla.kernel.org/show_bug.cgi?id=203315 doesn't help.

*** This bug has been marked as a duplicate of bug 203315 ***
Comment 4 Emmanuel Grumbach 2019-06-27 18:49:34 UTC
I meant this:

https://bugzilla.kernel.org/show_bug.cgi?id=203315#c42

Note You need to log in before you can comment on or make changes to this bug.