Bug 203833 - TEO governor occasionally causes processes to hog the cpu
Summary: TEO governor occasionally causes processes to hog the cpu
Status: RESOLVED UNREPRODUCIBLE
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpuidle (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-06 09:17 UTC by Martin
Modified: 2019-07-15 23:02 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.1.6
Tree: Mainline
Regression: No


Attachments

Description Martin 2019-06-06 09:17:23 UTC
I have reason to believe that the new and shiny TEO governor wreaks havoc on my system, resulting unpredictably in processes claiming 100% cpu, which can only be resolved by restarting my laptop.

After upgrading to 5.1 and reading about the new governor I've switched to TEO, for the sake of "trying something new". Since then, I've encountered multiple occasions of processes going berzerk in one week (claiming 100% cpu usage for each thread). I was unable to kill the processes (leaving a 100% cpu using zombie when killed using SIGKILL) and each time the only remedy was a full restart. Also, there was no relation in the affected processes.

I have now been running 5.1.5/6 for more than a week on menu and have yet to see the  problem again. I realise this is all circumstantial evidence and I don't have a recipe to reliably reproduce the poblem, but it's the best I can do at the moment even if it's only creating awareness.
Comment 1 GYt2bW 2019-06-15 06:18:04 UTC
Interesting! I think I've only encountered such an issue once so far, with `stress` program, but it eventually finished on its own(I don't remember how many minutes later of 100% cpu usage aka 1 core) and exited due to SIGALRM, no other signals could kill it, couldn't even attach gdb until it ended due to SIGALRM! and it went way way past the command line 10 seconds timeout (and I never issued SIGALRM to it). So either that was because of TEO as you say, or it was something else I can't explain. I'm switching to menu now, thanks!
Comment 2 Martin 2019-06-26 16:38:27 UTC
Just to make a point I switched back to TEO two weeks ago but haven't seen the problem anymore on recent kernels (5.1.10+). I guess this ticket could be closed as it turns out not to be reproducable anymore?
Comment 3 GYt2bW 2019-07-15 23:02:33 UTC
Regarding my previous Comment 1, I've just realized that what I experienced was due to https://bugzilla.kernel.org/show_bug.cgi?id=204165 and it wasn't the 'teo' governor (since I'm using 'menu' now). So, disregard! :)

Note You need to log in before you can comment on or make changes to this bug.