Bug 203809 - iwlwifi: 8265: Microcode SW error detected. Restarting 0x82000000
Summary: iwlwifi: 8265: Microcode SW error detected. Restarting 0x82000000
Status: CLOSED DUPLICATE of bug 203315
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-04 18:10 UTC by vladi
Modified: 2019-06-04 18:31 UTC (History)
0 users

See Also:
Kernel Version: 5.1.6
Tree: Mainline
Regression: No


Attachments
kernel config (109.07 KB, text/plain)
2019-06-04 18:12 UTC, vladi
Details

Description vladi 2019-06-04 18:10:17 UTC
Getting this in dmesg after trying to iperf my ac wifi connection speed then drops down to 20Mps and I see this in the dmesg.
[ 1573.839829] iwlwifi 0000:02:00.0: Microcode SW error detected.  Restarting 0x82000000.
[ 1573.839981] iwlwifi 0000:02:00.0: Start IWL Error Log Dump:
[ 1573.839986] iwlwifi 0000:02:00.0: Status: 0x00000100, count: 6
[ 1573.839988] iwlwifi 0000:02:00.0: Loaded firmware version: 36.9f0a2d68.0
[ 1573.839992] iwlwifi 0000:02:00.0: 0x00000EDC | ADVANCED_SYSASSERT          
[ 1573.839994] iwlwifi 0000:02:00.0: 0x00000220 | trm_hw_status0
[ 1573.839997] iwlwifi 0000:02:00.0: 0x00000000 | trm_hw_status1
[ 1573.839999] iwlwifi 0000:02:00.0: 0x0002485C | branchlink2
[ 1573.840002] iwlwifi 0000:02:00.0: 0x0003A7CA | interruptlink1
[ 1573.840004] iwlwifi 0000:02:00.0: 0x00000000 | interruptlink2
[ 1573.840006] iwlwifi 0000:02:00.0: 0x0A97001C | data1
[ 1573.840008] iwlwifi 0000:02:00.0: 0x20000606 | data2
[ 1573.840011] iwlwifi 0000:02:00.0: 0x00001140 | data3
[ 1573.840013] iwlwifi 0000:02:00.0: 0xAA4155A1 | beacon time
[ 1573.840015] iwlwifi 0000:02:00.0: 0x0B65B227 | tsf low
[ 1573.840018] iwlwifi 0000:02:00.0: 0x00000008 | tsf hi
[ 1573.840020] iwlwifi 0000:02:00.0: 0x00000000 | time gp1
[ 1573.840022] iwlwifi 0000:02:00.0: 0x5BDDB689 | time gp2
[ 1573.840024] iwlwifi 0000:02:00.0: 0x00000001 | uCode revision type
[ 1573.840027] iwlwifi 0000:02:00.0: 0x00000024 | uCode version major
[ 1573.840029] iwlwifi 0000:02:00.0: 0x9F0A2D68 | uCode version minor
[ 1573.840031] iwlwifi 0000:02:00.0: 0x00000230 | hw version
[ 1573.840033] iwlwifi 0000:02:00.0: 0x00489000 | board version
[ 1573.840035] iwlwifi 0000:02:00.0: 0x20000606 | hcmd
[ 1573.840038] iwlwifi 0000:02:00.0: 0x24022002 | isr0
[ 1573.840040] iwlwifi 0000:02:00.0: 0x00000000 | isr1
[ 1573.840042] iwlwifi 0000:02:00.0: 0x08001802 | isr2
[ 1573.840044] iwlwifi 0000:02:00.0: 0x004178C1 | isr3
[ 1573.840046] iwlwifi 0000:02:00.0: 0x00000000 | isr4
[ 1573.840048] iwlwifi 0000:02:00.0: 0x0A73001C | last cmd Id
[ 1573.840051] iwlwifi 0000:02:00.0: 0x00000000 | wait_event
[ 1573.840053] iwlwifi 0000:02:00.0: 0x00000094 | l2p_control
[ 1573.840055] iwlwifi 0000:02:00.0: 0x00018030 | l2p_duration
[ 1573.840057] iwlwifi 0000:02:00.0: 0x0000000F | l2p_mhvalid
[ 1573.840059] iwlwifi 0000:02:00.0: 0x00000085 | l2p_addr_match
[ 1573.840061] iwlwifi 0000:02:00.0: 0x0000000D | lmpm_pmg_sel
[ 1573.840064] iwlwifi 0000:02:00.0: 0x04120134 | timestamp
[ 1573.840066] iwlwifi 0000:02:00.0: 0x00003048 | flow_handler
[ 1573.840142] iwlwifi 0000:02:00.0: Start IWL Error Log Dump:
[ 1573.840145] iwlwifi 0000:02:00.0: Status: 0x00000100, count: 7
[ 1573.840147] iwlwifi 0000:02:00.0: 0x00000070 | NMI_INTERRUPT_LMAC_FATAL
[ 1573.840150] iwlwifi 0000:02:00.0: 0x00000000 | umac branchlink1
[ 1573.840152] iwlwifi 0000:02:00.0: 0xC00868A4 | umac branchlink2
[ 1573.840154] iwlwifi 0000:02:00.0: 0xC0083A94 | umac interruptlink1
[ 1573.840156] iwlwifi 0000:02:00.0: 0xC0083A94 | umac interruptlink2
[ 1573.840158] iwlwifi 0000:02:00.0: 0x00000800 | umac data1
[ 1573.840160] iwlwifi 0000:02:00.0: 0xC0083A94 | umac data2
[ 1573.840163] iwlwifi 0000:02:00.0: 0xDEADBEEF | umac data3
[ 1573.840165] iwlwifi 0000:02:00.0: 0x00000024 | umac major
[ 1573.840167] iwlwifi 0000:02:00.0: 0x9F0A2D68 | umac minor
[ 1573.840169] iwlwifi 0000:02:00.0: 0xC088628C | frame pointer
[ 1573.840171] iwlwifi 0000:02:00.0: 0xC088628C | stack pointer
[ 1573.840173] iwlwifi 0000:02:00.0: 0x00E4014E | last host cmd
[ 1573.840175] iwlwifi 0000:02:00.0: 0x00000000 | isr status reg
[ 1573.840183] ieee80211 phy0: Hardware restart was requested
[ 1574.342554] iwlwifi 0000:02:00.0: Failing on timeout while stopping DMA channel 8 [0x07fd0001]
[ 1574.663875] iwlwifi 0000:02:00.0: Microcode SW error detected.  Restarting 0x82000000.
[ 1574.664031] iwlwifi 0000:02:00.0: Start IWL Error Log Dump:
[ 1574.664034] iwlwifi 0000:02:00.0: Status: 0x00000100, count: 6
[ 1574.664037] iwlwifi 0000:02:00.0: Loaded firmware version: 36.9f0a2d68.0
[ 1574.664041] iwlwifi 0000:02:00.0: 0x0000105C | ADVANCED_SYSASSERT          
[ 1574.664043] iwlwifi 0000:02:00.0: 0x00000220 | trm_hw_status0
[ 1574.664046] iwlwifi 0000:02:00.0: 0x00000000 | trm_hw_status1
[ 1574.664048] iwlwifi 0000:02:00.0: 0x0002485C | branchlink2
[ 1574.664050] iwlwifi 0000:02:00.0: 0x0003A7CA | interruptlink1
[ 1574.664053] iwlwifi 0000:02:00.0: 0x00000000 | interruptlink2
[ 1574.664055] iwlwifi 0000:02:00.0: 0xDEADBEEF | data1
[ 1574.664057] iwlwifi 0000:02:00.0: 0xDEADBEEF | data2
[ 1574.664059] iwlwifi 0000:02:00.0: 0xDEADBEEF | data3
[ 1574.664062] iwlwifi 0000:02:00.0: 0x00417F2D | beacon time
[ 1574.664064] iwlwifi 0000:02:00.0: 0xAF89E6D5 | tsf low
[ 1574.664066] iwlwifi 0000:02:00.0: 0x00000008 | tsf hi
[ 1574.664068] iwlwifi 0000:02:00.0: 0x00000000 | time gp1
[ 1574.664071] iwlwifi 0000:02:00.0: 0x0001D792 | time gp2
[ 1574.664073] iwlwifi 0000:02:00.0: 0x00000001 | uCode revision type
[ 1574.664075] iwlwifi 0000:02:00.0: 0x00000024 | uCode version major
[ 1574.664077] iwlwifi 0000:02:00.0: 0x9F0A2D68 | uCode version minor
[ 1574.664080] iwlwifi 0000:02:00.0: 0x00000230 | hw version
[ 1574.664082] iwlwifi 0000:02:00.0: 0x00489000 | board version
[ 1574.664084] iwlwifi 0000:02:00.0: 0x0AA4001C | hcmd
[ 1574.664086] iwlwifi 0000:02:00.0: 0x24022002 | isr0
[ 1574.664089] iwlwifi 0000:02:00.0: 0x00000000 | isr1
[ 1574.664091] iwlwifi 0000:02:00.0: 0x08001802 | isr2
[ 1574.664093] iwlwifi 0000:02:00.0: 0x004128C1 | isr3
[ 1574.664095] iwlwifi 0000:02:00.0: 0x00000000 | isr4
[ 1574.664097] iwlwifi 0000:02:00.0: 0x0506001C | last cmd Id
[ 1574.664099] iwlwifi 0000:02:00.0: 0x00000000 | wait_event
[ 1574.664101] iwlwifi 0000:02:00.0: 0x000000D4 | l2p_control
[ 1574.664104] iwlwifi 0000:02:00.0: 0x00018030 | l2p_duration
[ 1574.664106] iwlwifi 0000:02:00.0: 0x00000007 | l2p_mhvalid
[ 1574.664108] iwlwifi 0000:02:00.0: 0x00000081 | l2p_addr_match
[ 1574.664110] iwlwifi 0000:02:00.0: 0x0000000D | lmpm_pmg_sel
[ 1574.664112] iwlwifi 0000:02:00.0: 0x04120134 | timestamp
[ 1574.664115] iwlwifi 0000:02:00.0: 0x00004858 | flow_handler
[ 1574.664192] iwlwifi 0000:02:00.0: Start IWL Error Log Dump:
[ 1574.664194] iwlwifi 0000:02:00.0: Status: 0x00000100, count: 7
[ 1574.664197] iwlwifi 0000:02:00.0: 0x00000070 | NMI_INTERRUPT_LMAC_FATAL
[ 1574.664199] iwlwifi 0000:02:00.0: 0x00000000 | umac branchlink1
[ 1574.664202] iwlwifi 0000:02:00.0: 0xC00868A4 | umac branchlink2
[ 1574.664204] iwlwifi 0000:02:00.0: 0xC0083A94 | umac interruptlink1
[ 1574.664206] iwlwifi 0000:02:00.0: 0xC0083A94 | umac interruptlink2
[ 1574.664208] iwlwifi 0000:02:00.0: 0x00000800 | umac data1
[ 1574.664210] iwlwifi 0000:02:00.0: 0xC0083A94 | umac data2
[ 1574.664212] iwlwifi 0000:02:00.0: 0xDEADBEEF | umac data3
[ 1574.664215] iwlwifi 0000:02:00.0: 0x00000024 | umac major
[ 1574.664217] iwlwifi 0000:02:00.0: 0x9F0A2D68 | umac minor
[ 1574.664219] iwlwifi 0000:02:00.0: 0xC088628C | frame pointer
[ 1574.664221] iwlwifi 0000:02:00.0: 0xC088628C | stack pointer
[ 1574.664223] iwlwifi 0000:02:00.0: 0x004A012C | last host cmd
[ 1574.664225] iwlwifi 0000:02:00.0: 0x00000000 | isr status reg
[ 1574.664231] ieee80211 phy0: Hardware restart was requested
[ 1575.168454] iwlwifi 0000:02:00.0: Failing on timeout while stopping DMA channel 8 [0x07fd0003]
Comment 1 vladi 2019-06-04 18:10:53 UTC
emerge --info @ https://bpaste.net/show/9a699cd1bfcb
Comment 2 vladi 2019-06-04 18:12:09 UTC
Created attachment 283101 [details]
kernel config

[?] sys-kernel/linux-firmware
     Available versions:  20190502^bs **20190514^bsd **99999999^bs {+redistributable savedconfig unknown-license}
     Installed versions:  20190514^bs(10:12:08 AM 05/20/2019)(redistributable -savedconfig -unknown-license)
     Homepage:            https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git
     Description:         Linux firmware files
Comment 3 Emmanuel Grumbach 2019-06-04 18:31:08 UTC

*** This bug has been marked as a duplicate of bug 203315 ***

Note You need to log in before you can comment on or make changes to this bug.