Bug 203783 - iwlwifi 0000:02:00.0: EDC
Summary: iwlwifi 0000:02:00.0: EDC
Status: CLOSED DUPLICATE of bug 203315
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: x86-64 Linux
: P1 blocking
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-02 14:01 UTC by Slavi
Modified: 2019-06-02 14:24 UTC (History)
0 users

See Also:
Kernel Version: 5.1.5.arch1-2
Tree: Mainline
Regression: No


Attachments
dmesg.log (94.05 KB, text/plain)
2019-06-02 14:01 UTC, Slavi
Details
firmware dump (803.55 KB, application/octet-stream)
2019-06-02 14:04 UTC, Slavi
Details

Description Slavi 2019-06-02 14:01:17 UTC
Created attachment 283037 [details]
dmesg.log

I'm running Archlinux and have recently upgraded the following (at the same time):
- linux (5.0.13.arch1-1 -> 5.1.4.arch1-1)
- linux-firmware (20190424.4b6cf2b-1 -> 20190514.711d329-1)

Since then, Wi-Fi would frequently stop working. I'd have to disconnect and reconnect to get it working again (but that only lasts for a while).

I've tried downgrading linux-firmware to the known-working version (20190424.4b6cf2b-1) while keeping the kernel at 5.1.4, but that didn't help.

Using the older kernel (Archlinux's linux-lts, which is at version 4.19.47-1) seems to solve the problem - Wi-Fi is stable.

I've waited for a few kernel upgrades since then (now on kernel 5.1.5.arch1-2), but the problem persists.

This is on an HP Elitebook 850 G1 with an Intel(R) Dual Band Wireless N 7260, REV=0x144.

I'm providing debug data when running:
- Linux 5.1.5.arch1-2
- the debugging firmware for the 7260: iwlwifi-7260-17.ucode (`ethtool -i wlan0 | grep firmware` says: firmware-version: 17.3216344376.0)

Looks like the last time it happened, it crashed multiple times in a row (as evident from dmesg.log).
Comment 1 Slavi 2019-06-02 14:04:22 UTC
Created attachment 283039 [details]
firmware dump

This is the first dump that got generated by the debugging firmware. There are 19 more that follow it (they all happened within an interval of 2 minutes).
Comment 2 Emmanuel Grumbach 2019-06-02 14:22:45 UTC

*** This bug has been marked as a duplicate of bug 203315 ***

Note You need to log in before you can comment on or make changes to this bug.