Bug 203649 - iwlwifi: ASSERT EDC
Summary: iwlwifi: ASSERT EDC
Status: CLOSED DUPLICATE of bug 203315
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-19 22:05 UTC by Chris van de Sande
Modified: 2019-05-20 06:51 UTC (History)
0 users

See Also:
Kernel Version: 5.1.2-arch1-1-ARCH
Tree: Mainline
Regression: Yes


Attachments
journal logs (14.94 KB, text/plain)
2019-05-19 22:05 UTC, Chris van de Sande
Details

Description Chris van de Sande 2019-05-19 22:05:29 UTC
Created attachment 282845 [details]
journal logs

Started experiencing this shortly after upgrading from linux-5.0.13.arch1-1-x86_64 to linux-5.1.2.arch1-1-x86_64.

This is pretty easily reproducible. I run a Win10 VM with the disk image stored on an NFS volume. The connection to the NFS server is via Wifi, as one would expect booting a Windows VM puts a heavy load on the Wifi. Under normal circumstances Windows boots in 3-4mins. Since upgrading to kernel 5.1.2 I lose complete connectivity shortly after booting Windows 10, the error displayed in my dmesg is:

May 15 22:35:16 nuc.opendmz.com kernel: iwlwifi 0000:02:00.0: Microcode SW error detected.  Restarting 0x2000000.
May 15 22:35:16 nuc.opendmz.com kernel: iwlwifi 0000:02:00.0: Start IWL Error Log Dump:
May 15 22:35:16 nuc.opendmz.com kernel: iwlwifi 0000:02:00.0: Status: 0x00000100, count: 6

More logs attached.

After the firmware crash, the Wifi will eventually recover, and NetworkManager will reconnect. After a few minutes, it will crash again.

If I roll back to 5.0.13 or the LTS kernel I experience no errors whatsoever. Something has definitely changed with the 5.1.2 kernel.
Comment 1 Chris van de Sande 2019-05-19 22:06:45 UTC
Forgot to cc linuxwifi@intel.com, adding now.
Comment 2 Emmanuel Grumbach 2019-05-20 06:51:01 UTC
What device do you have?
Comment 3 Emmanuel Grumbach 2019-05-20 06:51:13 UTC

*** This bug has been marked as a duplicate of bug 203315 ***

Note You need to log in before you can comment on or make changes to this bug.