Bug 203627 - [Regression] Boot fails with linux-firmware 20190514
Summary: [Regression] Boot fails with linux-firmware 20190514
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-17 04:39 UTC by Aleksandr Mezin
Modified: 2019-06-20 13:07 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.19.44
Tree: Mainline
Regression: Yes


Attachments

Description Aleksandr Mezin 2019-05-17 04:39:18 UTC
After commit https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=2579167548be33afb1fe2a9a5c141561ee5a8bbe system doesn't boot anymore with kernels 4.19.x (at least 4.19.40 and 4.19.44). 5.1 boots fine.

Displays turn off early when amdgpu driver loads, never turn on again. Can't reach the system over ssh. Also can't get any logs from journald (that boot attempt just doesn't get recorded)

GPU: RX Vega 64 (Sapphire Nitro+)
Dual 4K displays connected over DisplayPort
Comment 1 Alex Deucher 2019-05-23 01:39:48 UTC
Can you narrow down which firmware file causes the regression?
Comment 2 Aleksandr Mezin 2019-05-26 03:29:20 UTC
vega10_sos.bin

Copying that file from previous firmware release into /lib/firmware/amdgpu makes the system boot again with 4.19.45
Comment 3 Arne Fahrenwalde 2019-05-27 18:38:47 UTC
I'm just here to state that I'm affected as well.

Kernel versions 5.x boot fine with linux-firmware 20190514.711d329-1,
Kernel version 4.19.x crashes directly after trying to load the amdgpu driver. The screen turns off and the system only hangs/reacts to the reset button (CTRL-ALT-DELETE won't work either). Unfortunately nothing is logged.

Downgrading to linux-firmware 20190424.4b6cf2b-1 fixed it for me for now.

OS: Manjaro Linux
Hardware affected: AMD Vega 64 (10) (ASUS ROG STRIX)
Comment 4 Aleksandr Mezin 2019-06-01 00:31:16 UTC
Nothing changed with 4.19.46 and 4.19.47
Comment 5 Aleksandr Mezin 2019-06-12 02:47:36 UTC
(In reply to Aleksandr Mezin from comment #2)
> vega10_sos.bin
> 
> Copying that file from previous firmware release into /lib/firmware/amdgpu
> makes the system boot again with 4.19.45

4.19.50 - still doesn't boot with current vega10_sos.bin

Note You need to log in before you can comment on or make changes to this bug.