Bug 203525 - brightness with function buttons Acer Aspire A315-41 notebook with AMD Ryzen 5 2500U
Summary: brightness with function buttons Acer Aspire A315-41 notebook with AMD Ryzen ...
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-06 14:02 UTC by Erik
Modified: 2019-05-08 14:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.19.37 5.0.11 5.1
Tree: Mainline
Regression: No


Attachments
dmesg fixed 4.19.39 (74.20 KB, text/plain)
2019-05-06 15:39 UTC, Erik
Details
dmesg broken 4.19.35 (68.60 KB, text/plain)
2019-05-06 15:40 UTC, Erik
Details
dmesg fixed 4.19.37 (68.92 KB, text/plain)
2019-05-06 17:41 UTC, Erik
Details

Description Erik 2019-05-06 14:02:26 UTC
I got an Acer Aspire A315-41 notebook with AMD Ryzen 5 2500U and i have had problems with brightness not working out of the box (OTB) if i used function buttons.
The thing is that i found that it started to work with linux-4.19.37 (fixed) but it didn't work with linux-4.19.35 (broken).

It works from 4.19.37 but it doesn't work in later kernel series such as linux-5.0.11 or linux-5.1 and i think the fix should also be in newer kernels.
I started to bisect but linux-4.19.36 doesn't boot with my hardware and after many bisect skip and compiling i gave up.
Do anyone know what commit that could have fixed it?
Or why 4.19.36 won't boot on my hardware (if there was some known regression) so i can perform an bisect.
Comment 1 Alex Deucher 2019-05-06 14:07:05 UTC
Can you attach your dmesg outputs for both the working kernels and non-working kernels?
Comment 2 Erik 2019-05-06 15:39:54 UTC
Created attachment 282647 [details]
dmesg fixed 4.19.39
Comment 3 Erik 2019-05-06 15:40:32 UTC
Created attachment 282649 [details]
dmesg broken 4.19.35
Comment 4 Erik 2019-05-06 17:41:15 UTC
Created attachment 282653 [details]
dmesg fixed 4.19.37
Comment 5 Erik 2019-05-06 22:43:52 UTC
By adding commit b59dfdaef173677b0b7e10f375226c0a1114fd20 i was able to boot 4.19.36.
I tried 4.19.36 but it was broken.
4.19.36 broken and 4.19.37 fixed.
I then ran a bisect but i wasn't able to to find the commit that fixed it.
I don't know why the bisect went thru all steps without finding the fix.
Comment 6 Erik 2019-05-08 10:42:33 UTC
The bisect was working i only didn't trust it.
What causes the change in behavior wasn't caused by resent fixes, well it was but it wasn't.
What makes it work is bumping SUBLEVEL above 36.
I tried bumping SUBLEVEL of 5.1 and 5.1.36 was broken while 5.1.37 was working.
Comment 7 Erik 2019-05-08 14:21:35 UTC
Is there anything more i can do to find out what's going on?

Note You need to log in before you can comment on or make changes to this bug.