Bug 20352 - Fwd: Re: UML kernel crash of v2.6.36-rcX kernel
Fwd: Re: UML kernel crash of v2.6.36-rcX kernel
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: UML
All Linux
: P1 normal
Assigned To: Jeff Dike
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-10-14 18:10 UTC by Maciej Rutecki
Modified: 2010-12-06 22:11 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-10-14 18:10:18 UTC
Subject    : Fwd: Re: UML kernel crash of v2.6.36-rcX kernel
Submitter  : Toralf Förster <toralf.foerster@gmx.de>
Date       : 2010-10-13 11:28
Message-ID : 201010131328.06465.toralf.foerster@gmx.de
References : http://marc.info/?l=linux-kernel&m=128696930132503&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Maciej Rutecki 2010-10-15 18:40:38 UTC
Caused by:

commit 365b18189789bfa1acd9939e6312b8a4b4577b28
Author: Christoph Hellwig <hch@lst.de>
Date:   Wed Jul 7 18:53:25 2010 +0200

    add f_flags to struct statfs(64)

    Add a flags field to help glibc implementing statvfs(3) efficiently.

    We copy the flag values from glibc, and add a new ST_VALID flag to
    denote that f_flags is implemented.

    Signed-off-by: Christoph Hellwig <hch@lst.de>
    Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>

First-Bad-Commit : 365b18189789bfa1acd9939e6312b8a4b4577b28
Comment 2 Dan Carpenter 2010-10-26 19:10:07 UTC
It was an out of bounds array access.  Richard Weinberger has posted a fix and Toralf Förster has tested it and it works.

http://marc.info/?l=user-mode-linux-devel&m=128740099820484&w=2
Comment 3 Toralf Förster 2010-10-26 19:51:18 UTC
In the mean while a improved patch was send 

http://article.gmane.org/gmane.linux.kernel/1050737

and AFAIK  is included in the the -mm tree :
Comment 4 Toralf Förster 2010-11-19 09:14:28 UTC
You can close it b/c the patch is already in the main tree now, isn't it ?
Comment 5 Florian Mickler 2010-12-06 16:57:48 UTC
Indeed, thx for the note. 

It is in the mainline

commit 1b627d5771312c92404b66f0a0b16f66036dd2e1
Author: Richard Weinberger <richard@nod.at>
Date:   Tue Oct 26 14:21:18 2010 -0700

    hostfs: fix UML crash: remove f_spare from hostfs
Comment 6 Rafael J. Wysocki 2010-12-06 22:11:01 UTC
On Monday, December 06, 2010, Toralf Förster wrote:
> Hello,
> 
> the issue is solved in the main line with commit 1b627d57 (2.6.37-rc1)

Note You need to log in before you can comment on or make changes to this bug.