Bug 203157 - PCI device appears intermittently
Summary: PCI device appears intermittently
Status: RESOLVED WILL_NOT_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-05 00:25 UTC by Ron Murray
Modified: 2019-06-26 18:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.0.6 and earlier
Tree: Mainline
Regression: No


Attachments
tarball of 'lspci -vvv' and 'dmesg' outputs (23.98 KB, application/x-xz)
2019-04-05 00:25 UTC, Ron Murray
Details
dmesg (good, extracted from 282129) (64.45 KB, text/plain)
2019-04-05 12:40 UTC, Bjorn Helgaas
Details
dmesg (bad, extracted from 282129) (66.79 KB, text/plain)
2019-04-05 12:41 UTC, Bjorn Helgaas
Details
lspci (good, extracted from 282129) (30.75 KB, text/plain)
2019-04-05 12:41 UTC, Bjorn Helgaas
Details
lspci (bad, extracted from 282129) (37.22 KB, text/plain)
2019-04-05 12:42 UTC, Bjorn Helgaas
Details

Description Ron Murray 2019-04-05 00:25:02 UTC
Created attachment 282129 [details]
tarball of 'lspci -vvv' and 'dmesg' outputs

I have an ASRock 970A-G/3.1 motherboard, which, with current Linux kernels, occasionally "finds" an extra PCI device on the initial scan. I wouldn't mind, but it finds it early in the piece, and that changes the PCI allocation of my Ethernet board from 02:06.0 to 03:06.0, and, with systemd, Linux comes up with no network connection. A reboot fixes it, mostly.

This has been in evidence for a few months now, since I replaced the motherboard last November (old one was a different brand). I'm not sure whether it's a regression or not; I don't recall it happening until some time in January, but it may have been doing it before then. I will try to get an earlier kernel (~November) installed and see if that helps.

Problem currently always occurs on startup from cold. Restart doesn't fix it; it needs to be powered off and on again, and then it's usually ok. The box dual-boots with Windows, but I rarely run it on Windows these days.

I can't seem to find any information on what the intermittent port is. lspci labels it as

00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 4) (prog-if 00 [Normal decode])

(whatever that is). I don't think I have anything connected to it.

I'm attaching a tarball of 'lspci -vvv' and 'dmesg' outputs for both bad (device exists) and good (device not in evidence).Let me know if you need anything else.

Thanks,

 .....Ron

-- 
Ron Murray <rjmx@rjmx.net>
PGP Fingerprint: 4D99 70E3 2317 334B 141E  7B63 12F7 E865 B5E2 E761
Comment 1 Bjorn Helgaas 2019-04-05 12:40:46 UTC
Created attachment 282135 [details]
dmesg (good, extracted from 282129)
Comment 2 Bjorn Helgaas 2019-04-05 12:41:27 UTC
Created attachment 282137 [details]
dmesg (bad, extracted from 282129)
Comment 3 Bjorn Helgaas 2019-04-05 12:41:56 UTC
Created attachment 282139 [details]
lspci (good, extracted from 282129)
Comment 4 Bjorn Helgaas 2019-04-05 12:42:26 UTC
Created attachment 282141 [details]
lspci (bad, extracted from 282129)
Comment 5 Ron Murray 2019-06-26 18:56:15 UTC
On further investigation, the same problem appears when I boot into Windows. It would appear, then, to be a hardware problem in the motherboard. 
I think we can close this bug.

Note You need to log in before you can comment on or make changes to this bug.