Bug 202675 - [Bisected] 04e04009bb01: Autonegotiation fails for various Lenovo notebooks when resuming inside the docking station
Summary: [Bisected] 04e04009bb01: Autonegotiation fails for various Lenovo notebooks w...
Status: RESOLVED DUPLICATE of bug 200611
Alias: None
Product: ACPI
Classification: Unclassified
Component: EC (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: acpi_ec
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-25 14:07 UTC by cs_gon
Modified: 2019-09-03 07:09 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.0-rc8
Tree: Mainline
Regression: No


Attachments

Description cs_gon 2019-02-25 14:07:38 UTC
The autonegotiation fails sporadically for various Lenovo notebooks (e.g. T450s, T550, W540) when resuming inside the docking station. The speed ethtool reports is 10Mb/s, full duplex, even though that is not the speed the connected switch uses. So the systems are unable to send/receive any packages.

Issuing the command "ethtool -r eth0" does not lead to a successful renegotiation. To get a correct link, I have to either undock the notebook for about 15 seconds, and then re-dock it, or disconnect the LAN cable for about 15 seconds, and then reconnect the cable.

In my case the problem appears about one time in 10-20 suspend/resume cycles.

I found the problem in the 4.15 Ubuntu Bionic kernel, but the problem is still present in kernel 5.0-rc8.


I've done a git bisect and the following commit seems to have introduced the problem:

commit 04e04009bb01502f8023c707d7569ea42fba903b
Author: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
Date:   Fri Feb 9 22:55:28 2018 +0100

    ACPI / EC: Restore polling during noirq suspend/resume phases
    
    BugLink: http://bugs.launchpad.net/bugs/1774063
    
    [ Upstream commit 3cd091a773936c54344a519f7ee1379ccb620bee ]
    
    Commit 662591461c4b (ACPI / EC: Drop EC noirq hooks to fix a
    regression) modified the ACPI EC driver so that it doesn't switch
    over to busy polling mode during noirq stages of system suspend and
    resume in an attempt to fix an issue resulting from that behavior.
    
    However, that modification introduced a system resume regression on
    Thinkpad X240, so make the EC driver switch over to the polling mode
    during noirq stages of system suspend and resume again, which
    effectively reverts the problematic commit.
    
    Fixes: 662591461c4b (ACPI / EC: Drop EC noirq hooks to fix a regression)
    Link: https://bugzilla.kernel.org/show_bug.cgi?id=197863
    Reported-by: Markus Demleitner <m@tfiu.de>
    Tested-by: Markus Demleitner <m@tfiu.de>
    Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
    Signed-off-by: Sasha Levin <alexander.levin@microsoft.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
    Signed-off-by: Kamal Mostafa <kamal@canonical.com>
    Signed-off-by: Khalid Elmously <khalid.elmously@canonical.com>

I was primarily interested in fixing this bug in the 4.15 Ubuntu Bionic kernel, and have reverted the commit in the Ubuntu kernel, and cannot reproduce the problem any longer.
Comment 1 Zhang Rui 2019-09-03 07:09:27 UTC

*** This bug has been marked as a duplicate of bug 200611 ***

Note You need to log in before you can comment on or make changes to this bug.