Bug 202543 - [ 0.581177] gpio gpiochip1: (INT33FF:01): detected irqchip that is shared with multiple gpiochips: please fix the driver.
Summary: [ 0.581177] gpio gpiochip1: (INT33FF:01): detected irqchip that is shared ...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Andy Shevchenko
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-10 00:35 UTC by Christoph Marz
Modified: 2020-01-13 18:50 UTC (History)
2 users (show)

See Also:
Kernel Version: Since 4.20
Tree: Mainline
Regression: No


Attachments
Patch for drivers/pinctrl/intel/pinctrl-cherryview.c (2.08 KB, patch)
2019-02-13 21:41 UTC, Christoph Marz
Details | Diff
Patch for drivers/pinctrl/intel/pinctrl-cherryview.c (2.08 KB, patch)
2019-03-10 20:27 UTC, Christoph Marz
Details | Diff

Description Christoph Marz 2019-02-10 00:35:49 UTC

    
Comment 1 Christoph Marz 2019-02-10 01:33:51 UTC
Happens on each system start, but beyond that, everything works normally.
Comment 2 Christoph Marz 2019-02-13 21:37:04 UTC
https://lkml.org/lkml/2019/1/10/140

States the reason for the bug and contains a fix for drivers/gpio/gpio-pcf857x.c.

I found that the driver for my device (INT33FF:01) is drivers/pinctrl/intel/pinctrl-cherryview.c and changed it accordingly; the error message is gone now.

I have created a diff file I'm goint to attach.
Comment 3 Christoph Marz 2019-02-13 21:41:00 UTC
Created attachment 281129 [details]
Patch for drivers/pinctrl/intel/pinctrl-cherryview.c
Comment 4 Christoph Marz 2019-03-10 20:21:25 UTC
Problem still persists in 5.0.1.

There was a commit in 4.20.13 that fixed the exactly same issue for a different driver (gpio: MT7621: use a per instance irq_chip structure).

This is not meant as a complaint, but I have the impression that my report is not taken seriously because no one else has confirmed it.
Comment 5 Christoph Marz 2019-03-10 20:27:51 UTC
Created attachment 281687 [details]
Patch for drivers/pinctrl/intel/pinctrl-cherryview.c

Changed paths so it can be applied normally via quilt.
Comment 6 Christoph Marz 2019-05-12 13:14:22 UTC
Still not fixed in 5.1.1, although I provided a working patch three months ago. Unbelievable...
Comment 7 RussianNeuroMancer 2019-07-27 08:56:35 UTC
Christoph, please follow this guide: https://www.kernel.org/doc/html/v5.2/process/submitting-patches.html
Comment 8 Andy Shevchenko 2019-09-16 12:26:12 UTC
Thank you for the patch! Yes, please follow the instructions in the comment 7 to submit the patch properly.

Note You need to log in before you can comment on or make changes to this bug.