Bug 202529 - Lenovo Ideapad 530S-14ARR Ryzen 5 2500U: Touchpad (ITE 8396?) is not detected at all
Summary: Lenovo Ideapad 530S-14ARR Ryzen 5 2500U: Touchpad (ITE 8396?) is not detected...
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-08 22:18 UTC by Jonas Platte
Modified: 2019-02-08 22:18 UTC (History)
0 users

See Also:
Kernel Version: 4.20.6
Tree: Mainline
Regression: No


Attachments

Description Jonas Platte 2019-02-08 22:18:20 UTC
See also https://bbs.archlinux.org/viewtopic.php?pid=1830745

The Touchpad on my Lenovo Ideapad 530S is not detected. libinput list-devices doesn't show a touchpad / pointing device at all and neither do lspci and lsusb.

I don't know where to start debugging this. There are a few things that me and the first poster on the arch linux forum have tried, none of which have really resulted in anything interesting. I'm happy to compile a few kernels with different options or patches, but have never worked on it myself (though I do have *some* experience with low-level programming).

Note You need to log in before you can comment on or make changes to this bug.