Bug 202137 - systemctl suspend doesn't sleep cpu properly anymore - acer cb3-532, banon, braswell chromebook
Summary: systemctl suspend doesn't sleep cpu properly anymore - acer cb3-532, banon, b...
Status: RESOLVED DUPLICATE of bug 202679
Alias: None
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-04 14:39 UTC by Chris Gorman
Modified: 2019-03-11 03:17 UTC (History)
4 users (show)

See Also:
Kernel Version: 4.19-rc4
Tree: Mainline
Regression: No


Attachments
acpidump of acer cb3-532, braswell, banon, (103.74 KB, text/plain)
2019-01-06 23:58 UTC, Chris Gorman
Details

Description Chris Gorman 2019-01-04 14:39:23 UTC
I am trying to upgrade my kernel and have run into a problem with the way the newer kernels suspend.  I have a acer cb3-532, banon, braswell chromebook.  The current working kernel will work after a call to systemctl suspend, but newer ones wont.  The working kernel will suspend the system causing a blue power on led to turn orange indicating the suspend to ram state.  To recover I press the power button once and then any one of the keys and the machine wakes.  

With 4.20 and 4.19-rc4 the system no longer turns the blue power on led to an orange suspend to ram.  The screen is blanked and I can only recover by power cycling the machine.  I found that 4.18 worked, so I performed a git bisect to see where my problem lies.  I get...

chris@banach:~/src/linux$ git bisect good
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[be45bf5395e0886a93fc816bbe41a008ec2e42e2] watchdog/softlockup: Fix cpu_stop_queue_work() double-queue bug

Let me know if you need any testing done.
Comment 1 Chris Gorman 2019-01-04 19:13:25 UTC
To restate the problem.

When calling systemctl suspend on 4.20 and 4.19-rc4, the system won't wake.  On 4.18 and 4.16.13 the computer will wake after the call by one press to the power button and then depressing any key on the keyboard.  

The git bisection was done between 7876320f8880 (bad) and 94710cac0ef4 (good).   

The kernel version of the bug is incorrect, it occurs in 4.19-rc4.  The 4.18-rc5+ is the kernel version of the last kernel built by the git bisect process.
Comment 2 Chris Gorman 2019-01-06 17:41:59 UTC
I have found that this bug is related to the patch found by git-bisect.  There is something else wrong with the kernel and I will try to debug whatever is broken using https://www.kernel.org/doc/Documentation/ABI/testing/sysfs-power.  Apologies for the incorrect bug report.
Comment 3 Chris Gorman 2019-01-06 23:58:59 UTC
Created attachment 280287 [details]
acpidump of acer cb3-532, braswell, banon,
Comment 4 Chris Gorman 2019-01-07 00:20:01 UTC
The previous post should have said that the bug was not related to the patch found during my git bisect.  In fact this is wrong.  When I use a 4.20.0+ kernel with be45bf5395e0886a93fc816bbe41a008ec2e42e2 reverted, the laptop performs as it did with the distribution's factory 4.16.13-galliumos.  That is ...

Enters STR, when left unattended.  Wakes by depressing the power switch once and then any key.

Apologies for closing the bug before testing it.
Comment 5 Pepe Ga 2019-02-08 17:49:37 UTC
I see the same freeze when trying to suspend my system (Acer TravelMate 8471, Intel Core 2 Duo SU9400). It happens with kernel 4.19 up to 5.0rc5.
Comment 6 Pepe Ga 2019-03-06 09:20:43 UTC
Another report:
https://bugzilla.kernel.org/show_bug.cgi?id=202679
Comment 7 Zhang Rui 2019-03-11 03:17:23 UTC

*** This bug has been marked as a duplicate of bug 202679 ***

Note You need to log in before you can comment on or make changes to this bug.