Bug 202121 - iwlwifi intel 8265 does not load
Summary: iwlwifi intel 8265 does not load
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: DO NOT USE - assign "network-wireless-intel" component instead
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-03 16:15 UTC by Bjorn Stange
Modified: 2019-01-14 11:40 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.19
Tree: Mainline
Regression: Yes


Attachments
dmesg with patch (89.78 KB, text/plain)
2019-01-10 13:36 UTC, Bjorn Stange
Details
lspci output (41.64 KB, text/plain)
2019-01-11 02:26 UTC, Bjorn Stange
Details
dmesg working (79.23 KB, text/plain)
2019-01-11 04:44 UTC, Bjorn Stange
Details
lspci after firmware update (41.64 KB, text/plain)
2019-01-11 04:55 UTC, Bjorn Stange
Details
lspci after update more verbose (128.59 KB, text/plain)
2019-01-11 04:56 UTC, Bjorn Stange
Details

Description Bjorn Stange 2019-01-03 16:15:15 UTC
Description: iwlwifi - Intel Wireless 8265 / 8275 broken

Am on a system76 Gazelle. If I downgrade to 4.14.x things seem to work fine. >=4.19 is where things broke for me.

Additional info:
* using netctl for wireless config

dmesg output: 
$ sudo dmesg | grep iwlwifi
[ 6.803728] iwlwifi 0000:03:00.0: enabling device (0000 -> 0002)
[ 6.811282] iwlwifi 0000:03:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
[ 7.164029] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
[ 7.222573] iwlwifi 0000:03:00.0: base HW address: f8:34:41:d4:47:cf
[ 7.378522] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[ 49.115455] iwlwifi 0000:03:00.0: Failed to load firmware chunk!
[ 49.115462] iwlwifi 0000:03:00.0: iwlwifi transaction failed, dumping registers
[ 49.115466] iwlwifi 0000:03:00.0: iwlwifi device config registers:
[ 49.115521] iwlwifi 0000:03:00.0: 00000000: 24fd8086 00100000 02800078 00000000 00000004 00000000 00000000 00000000
[ 49.115527] iwlwifi 0000:03:00.0: 00000020: 00000000 00000000 00000000 10108086 00000000 000000c8 00000000 00000100
[ 49.115530] iwlwifi 0000:03:00.0: iwlwifi device memory mapped registers:
[ 49.115564] iwlwifi 0000:03:00.0: 00000000: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff
[ 49.115570] iwlwifi 0000:03:00.0: 00000020: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff
[ 49.115577] iwlwifi 0000:03:00.0: iwlwifi device AER capability structure:
[ 49.115605] iwlwifi 0000:03:00.0: 00000000: 14010001 00000000 00000000 00462031 00002000 00002000 00000000 00000000
[ 49.115609] iwlwifi 0000:03:00.0: 00000020: 00000000 00000000 00000000
[ 49.115613] iwlwifi 0000:03:00.0: iwlwifi parent port (0000:00:1c.6) config registers:
[ 49.115641] iwlwifi 0000:00:1c.6: 00000000: a1168086 00100007 060400f1 00810010 00000000 00000000 00030300 200000f0
[ 49.115646] iwlwifi 0000:00:1c.6: 00000020: df00df00 0001fff1 00000000 00000000 00000000 00000040 00000000 001003ff
[ 49.115651] iwlwifi 0000:03:00.0: iwlwifi root port (0000:00:1c.6) AER cap structure:
[ 49.115665] iwlwifi 0000:00:1c.6: 00000000: 14010001 00000000 00010000 00060011 00000000 00002000 00000000 00000000
[ 49.115670] iwlwifi 0000:00:1c.6: 00000020: 00000000 00000000 00000000 00000000 00000000 00000000
[ 49.133218] WARNING: CPU: 2 PID: 1193 at drivers/net/wireless/intel/iwlwifi/pcie/trans.c:2009 iwl_trans_pcie_grab_nic_access+0x1e1/0x220 [iwlwifi]
[ 49.133218] Modules linked in: joydev mousedev arc4 iwlmvm snd_hda_codec_hdmi snd_hda_codec_realtek mac80211 snd_hda_codec_generic iwlwifi vboxnetflt(OE) vboxnetadp(OE) vboxpci(OE) uvcvideo btusb btrtl btbcm videobuf2_vmalloc btintel snd_hda_intel intel_rapl videobuf2_memops snd_hda_codec videobuf2_v4l2 bluetooth videobuf2_common vboxdrv(OE) snd_hda_core x86_pkg_temp_thermal vboxvideo(C) intel_powerclamp coretemp nls_iso8859_1 snd_hwdep videodev ttm nls_cp437 vfat snd_pcm iTCO_wdt fat iTCO_vendor_support media cfg80211 kvm_intel snd_timer r8169 ecdh_generic crct10dif_pclmul ghash_clmulni_intel rtsx_pci_ms snd intel_cstate intel_uncore input_leds memstick rfkill libphy soundcore psmouse intel_rapl_perf i2c_i801 pcspkr vboxguest intel_pch_thermal pcc_cpufreq evdev mac_hid ac battery wmi system76_io(OE)
[ 49.133265] RIP: 0010:iwl_trans_pcie_grab_nic_access+0x1e1/0x220 [iwlwifi]
[ 49.133277] iwl_clear_bits_prph+0x37/0x90 [iwlwifi]
[ 49.133281] iwl_pcie_load_section+0x4f3/0x510 [iwlwifi]
[ 49.133287] iwl_pcie_load_cpu_sections_8000.isra.4+0xe9/0x290 [iwlwifi]
[ 49.133291] iwl_trans_pcie_start_fw+0x41a/0x6b0 [iwlwifi]
[ 49.133308] ? iwl_trans_pcie_start_hw+0x59/0x1b0 [iwlwifi]
[ 49.133384] iwlwifi 0000:03:00.0: Could not load the [2] uCode section
[ 49.133388] iwlwifi 0000:03:00.0: Failed to start INIT ucode: -110
[ 49.133407] iwlwifi 0000:03:00.0: Failed to run INIT ucode: -110
[ 49.133408] iwlwifi 0000:03:00.0: Failed to start RT ucode: -110
[ 51.688247] iwlwifi 0000:03:00.0: Could not load the [0] uCode section
[ 51.688251] iwlwifi 0000:03:00.0: Failed to start INIT ucode: -5
[ 51.688252] iwlwifi 0000:03:00.0: Failed to run INIT ucode: -5
[ 51.688253] iwlwifi 0000:03:00.0: Failed to start RT ucode: -5

If I can provide any additional data in some way please let me know I am happy to try to help!
Comment 1 Emmanuel Grumbach 2019-01-03 19:18:52 UTC
Please look at https://bugzilla.kernel.org/show_bug.cgi?id=201469

Try to revert the patch incriminated there.

thanks.
Comment 2 Bjorn Stange 2019-01-05 16:57:48 UTC
Revert? Do you mean apply this patch (https://bugzilla.kernel.org/attachment.cgi?id=280175&action=diff) and post the dmesg? I am not entirely sure what you are asking me to do, apologies.
Comment 3 Emmanuel Grumbach 2019-01-05 20:44:27 UTC
I meant to revert https://github.com/torvalds/linux/commit/9ab105deb60fa76d66cae5548819b4e8703d2056
Comment 4 Bjorn Stange 2019-01-10 13:36:06 UTC
Created attachment 280389 [details]
dmesg with patch

The results are the same after applying the patch. dmesg attached. Is there anything else I can try?
Comment 5 Bjorn Stange 2019-01-10 13:36:45 UTC
Apologies, I meant reverting the patch.
Comment 6 Emmanuel Grumbach 2019-01-10 13:57:55 UTC
I added Bjorn Helgass.

Hi,

Again, memory mapped registers not available.

"
Am on a system76 Gazelle. If I downgrade to 4.14.x things seem to work fine. >=4.19 is where things broke for me.
"
Comment 7 Emmanuel Grumbach 2019-01-10 15:03:21 UTC
Bjorn Stange,

Can you please attach the output of

sudo lspci -xxxvvv

Thanks
Comment 8 Bjorn Stange 2019-01-11 02:26:13 UTC
Created attachment 280395 [details]
lspci output

Sure thing. lspci output attached
Comment 9 Bjorn Stange 2019-01-11 02:27:20 UTC
I would also like to mention that ethernet is also broken, not sure if that information is entirely relevant, just trying to provide context.
Comment 10 Bjorn Stange 2019-01-11 04:44:09 UTC
Created attachment 280401 [details]
dmesg working

So I ended up installing PopOS on to another drive on the laptop. From there I ran the firmware updater for the gazelle. Now I am able to load iwlwifi with kernel 4.20. dmesg attached.
Comment 11 Emmanuel Grumbach 2019-01-11 04:50:20 UTC
sudo lspci -xxxxvvvv after the update please :)
Comment 12 Bjorn Stange 2019-01-11 04:55:00 UTC
Created attachment 280403 [details]
lspci after firmware update

This doesn't seem to be working 100%. I can't seem to get more than 500KB/s on ethernet or wireless. The driver loads now but the interface does not seem to be fully functional.

lspci -xxxvvv attached
Comment 13 Bjorn Stange 2019-01-11 04:56:29 UTC
Created attachment 280405 [details]
lspci after update more verbose

Apologies, I did not see the arguments correctly. lspci -xxxxvvvv output attached
Comment 14 Bjorn Stange 2019-01-11 05:22:23 UTC
I confirmed that downgrading back to 4.14.90 allows me to download the same files much faster (~35MB/s when working properly)
Comment 15 Bjorn Helgaas 2019-01-11 18:52:47 UTC
I assume attachment 280405 [details] is lspci output from v4.20, with iwlwifi working but at low performance.  Can you collect similar dmesg and lspci output from v4.14.90, where iwlwifi works better?  I'm marking this as a regression because of the performance issue.
Comment 16 Bjorn Stange 2019-01-14 03:41:11 UTC
After doing some more testing I have determined that it is my ethernet driver that is not working anymore. The wireless driver seems to be behaving the same on v4.20 and v4.14.90. I think this can be closed and I will probably be able to troubleshoot the ethernet issues elsewhere. Thanks so much for all the support, and apologies for my delayed responses.

Note You need to log in before you can comment on or make changes to this bug.