Bug 201985 - mc: Failed to load firmware "amdgpu/polaris11_k_mc.bin"
Summary: mc: Failed to load firmware "amdgpu/polaris11_k_mc.bin"
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-13 16:23 UTC by nancy
Modified: 2018-12-13 17:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.20.0-rc6
Tree: Mainline
Regression: No


Attachments
Config-4.20-rc6 (125.38 KB, text/plain)
2018-12-13 16:23 UTC, nancy
Details
dmesg-4.20.0-rc6 (67.17 KB, text/plain)
2018-12-13 16:27 UTC, nancy
Details

Description nancy 2018-12-13 16:23:56 UTC
Created attachment 279995 [details]
Config-4.20-rc6

Kernel 4.20.0-rc5 starts fine and is stable on my system.
With the same .config I get kernel 4.20.0-rc6 in dmesg the error given above: "mc: Failed to load firmware" amdgpu / polaris11_k_mc.bin "".
The GPU will not initialize and Xorg will not start.

I found this e-mail:
https://lists.freedesktop.org/archives/amd-gfx/2018-December/029175.html

The problem is, in Linux firmware there is no polaris11_k_mc.bin.
There is only one polaris11_k_smc.bin.

My question: is this a typo or will polaris11_k_mc.bin be delivered soon?

Thank you for your attention
Comment 1 nancy 2018-12-13 16:27:33 UTC
Created attachment 279999 [details]
dmesg-4.20.0-rc6
Comment 2 Alex Deucher 2018-12-13 16:32:06 UTC
The patch was sent to linux-firmware a couple of weeks ago.  It should land any day now.  In the mean time you can grab it here:
https://people.freedesktop.org/~agd5f/radeon_ucode/
Comment 3 nancy 2018-12-13 17:29:34 UTC
Thank you for the quick hint:
Now the system starts without problems.

$ uname -a
Linux tux 4.20.0-rc6 # 1 SMP Thu Dec 13 18:15:31 CET 2018 x86_64 AMD Ryzen 5 1600 Six-Core Processor AuthenticAMD GNU / Linux

Solved

Note You need to log in before you can comment on or make changes to this bug.