Bug 201981 - ACPI Error Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT - HP Envy x360
Summary: ACPI Error Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT - HP Envy...
Status: RESOLVED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: acpi_acpica-core@kernel-bugs.osdl.org
URL: https://bugzilla.redhat.com/show_bug....
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-13 08:35 UTC by Luya Tshimbalanga
Modified: 2020-05-02 13:54 UTC (History)
4 users (show)

See Also:
Kernel Version: 5.4
Tree: Mainline
Regression: No


Attachments
acpidump data from HP Envy x360 15-cp0xxx (873.53 KB, text/plain)
2018-12-29 19:07 UTC, Luya Tshimbalanga
Details
dmesg | grep ACPI (9.33 KB, text/plain)
2019-03-21 05:44 UTC, Luya Tshimbalanga
Details
acpidump data from HP Envy x360 15-cp0xxx (873.97 KB, text/plain)
2019-04-05 07:31 UTC, Luya Tshimbalanga
Details

Description Luya Tshimbalanga 2018-12-13 08:35:02 UTC
I brought a brand new HP Envy x360 laptop and install a distribution. The issue occurred on both with the following error:

mesg | grep Error
[    1.275414] RAS: Correctable Errors collector initialized.
[    4.957640] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
[    4.957647] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.957655] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.957701] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
[    4.957705] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.957710] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.957755] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
[    4.957759] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.957764] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.958354] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
[    4.958358] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.958365] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.958513] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
[    4.958517] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
[    4.958523] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)


With some researches, it looks like all HP laptops are affected by this issue
https://bugzilla.kernel.org/show_bug.cgi?id=200999
https://h30434.www3.hp.com/t5/Notebook-Operating-System-and-Recovery/acpi-error-with-linux/td-p/6021489
Comment 1 Luya Tshimbalanga 2018-12-14 02:29:14 UTC
Additional link to related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1520703
Comment 2 Serdar Sağlam 2018-12-20 04:07:10 UTC
Hi
Hp Amd A10 9600p
[    3.546921] RAS: Correctable Errors collector initialized.
[    9.979321] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[    9.979438] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.979484] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.979764] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[    9.979872] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.988903] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.989220] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[    9.989318] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.989358] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.990180] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[    9.990274] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.990312] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.990557] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[    9.990646] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[    9.990682] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
Comment 3 Luya Tshimbalanga 2018-12-29 19:07:00 UTC
Created attachment 280191 [details]
acpidump data from HP Envy x360 15-cp0xxx

Providing needed acpidump for debugging.
Comment 4 Luya Tshimbalanga 2018-12-29 19:07:59 UTC
Updated the priority and the kernel version.
Comment 5 Luya Tshimbalanga 2019-01-08 06:32:17 UTC
Switch to possibly right component
Comment 6 Serdar Sağlam 2019-01-23 17:10:43 UTC
Hp Device
Amd A10 9600P Cpu
R5 + R7 Apu Gpu
Kernel: 4.20.4

I've tried all the kernel versions that have come up to this day.

dmesg | grep Error
[    1.866329] RAS: Correctable Errors collector initialized.
[   11.573006] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[   11.573017] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573028] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573096] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[   11.573101] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573110] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573186] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[   11.573191] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573200] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573530] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[   11.573536] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573545] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573610] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[   11.573615] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[   11.573623] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
Comment 7 Serdar Sağlam 2019-01-23 17:12:05 UTC
All amd processors have this error
Comment 8 Luya Tshimbalanga 2019-02-20 06:54:59 UTC
Same issue with kernel 4.20.8

[    4.627396] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[    4.627404] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.627413] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.627458] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[    4.627461] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.627466] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.627510] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[    4.627541] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.627554] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.627774] input: HP WMI hotkeys as /devices/virtual/input/input20
[    4.628170] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[    4.628177] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.628185] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.628242] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181003/dsopcode-201)
[    4.628246] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
[    4.628253] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181003/psparse-516)
Comment 9 Serdar Sağlam 2019-02-20 20:05:43 UTC
Fedora 30 Raw
Kernel 5.0.0.0.rc6
[serdar@localhost Masaüstü]$ uname -a
Linux Fedora 5.0.0-0.rc6.git1.1.fc30.x86_64 #1 SMP Wed Feb 13 15:51:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[serdar@fedora Masaüstü]$ dmesg | grep Error
[    4.101815] RAS: Correctable Errors collector initialized.
[   21.486478] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[   21.486502] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.486540] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.486758] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[   21.486774] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.486809] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.487054] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[   21.487070] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.487104] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.489092] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[   21.489115] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.489154] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.489374] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[   21.489389] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[   21.489422] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
Comment 10 Luya Tshimbalanga 2019-03-02 07:44:26 UTC
Updated to 4.20.12
Comment 11 Serdar Sağlam 2019-03-14 04:06:20 UTC
[serdar@fedora Masaüstü]$ uname -a
Linux fedora 5.0.0-300.fc30.x86_64 #1 SMP Mon Mar 4 22:46:48 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


[serdar@fedora Masaüstü]$ dmesg | grep Error
[    2.105732] RAS: Correctable Errors collector initialized.
[    7.181605] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.181613] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.181622] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.181668] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.181671] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.181677] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.181720] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.181724] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.181730] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.182034] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.182038] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.182044] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.182086] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20181213/dsopcode-197)
[    7.182089] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[    7.182095] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20181213/psparse-529)
[serdar@fedora Masaüstü]$
Comment 12 Luya Tshimbalanga 2019-03-21 05:44:18 UTC
Created attachment 281941 [details]
dmesg | grep ACPI

The bug still occurs on kernel 4.20.16 notably firmware related. Is it possible for someone from HP addressing the issue as it happened on all HP powered device running on Linux?
Comment 13 Luya Tshimbalanga 2019-04-05 07:31:15 UTC
Created attachment 282133 [details]
acpidump data from HP Envy x360 15-cp0xxx

New info with kernel 5.0
Comment 14 Luya Tshimbalanga 2019-07-01 19:06:41 UTC
Follow-up,
The current ACPI status still remain unresolved to this date. The dmesg is located on https://linux-hardware.org/index.php?probe=ce83006200

Is there someone from HP willing to take a look?
Comment 15 Serdar Sağlam 2019-07-01 19:55:38 UTC
Hp is a complete Linux enemy

Hp Computer:

[serdar@archlinux Desktop]$ uname -a
Linux archlinux 5.1.12-arch1-1-ARCH #1 SMP PREEMPT Wed Jun 19 09:16:00 UTC 2019 x86_64 GNU/Linux

[serdar@archlinux Desktop]$ dmesg | grep Error
[    1.813390] RAS: Correctable Errors collector initialized.
[    4.818789] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20190215/dsopcode-198)
[    4.818801] ACPI Error: Aborting method \HWMC due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.818813] ACPI Error: Aborting method \_SB.WMID.WMAA due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.820585] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20190215/dsopcode-198)
[    4.820592] ACPI Error: Aborting method \HWMC due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.820601] ACPI Error: Aborting method \_SB.WMID.WMAA due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.821508] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20190215/dsopcode-198)
[    4.821514] ACPI Error: Aborting method \HWMC due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.821522] ACPI Error: Aborting method \_SB.WMID.WMAA due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.824655] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20190215/dsopcode-198)
[    4.824667] ACPI Error: Aborting method \HWMC due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.824679] ACPI Error: Aborting method \_SB.WMID.WMAA due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.824756] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20190215/dsopcode-198)
[    4.824762] ACPI Error: Aborting method \HWMC due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
[    4.824771] ACPI Error: Aborting method \_SB.WMID.WMAA due to previous error (AE_AML_BUFFER_LIMIT) (20190215/psparse-529)
Comment 16 Hans de Goede 2019-11-27 13:37:40 UTC
I've recently hit this seem issue, this is caused by the hp-wmi driver passing a buffer which is not big enough when making WMI related ACPI calls. I've submitted a patch-series which fixes this upstream:

https://lore.kernel.org/patchwork/project/lkml/list/?series=419906
Comment 17 Hans de Goede 2019-12-03 22:27:02 UTC
The fixes for this have landed upstream, closing.
Comment 18 Jeffrey Walton 2020-05-02 04:27:41 UTC
Add a mee too. Hardware is ProLiant DL360 G5. Software is Fedora Server 32 released Apeil 2020. Machine is fully patched.
Comment 19 Hans de Goede 2020-05-02 12:36:48 UTC
(In reply to Jeffrey Walton from comment #18)
> Add a mee too. Hardware is ProLiant DL360 G5. Software is Fedora Server 32
> released Apeil 2020. Machine is fully patched.

You are still seeing this with a Fedora 32? This should be fixed at least on HP laptops. I guess we still hve some work to do for the servers.

Can you file a bug against Fedora (bugzilla.redhat.com, component kernel) and attach an acpidump and dmesg output from Fedora 32 there please?

And please provide a link to the filed bug here, then I will take a look as time permits.
Comment 20 Hans de Goede 2020-05-02 12:40:52 UTC
I see that you have already filed:
https://bugzilla.redhat.com/show_bug.cgi?id=1830475

Can you please attach full dmesg output and an acpidump ("sudo acpidump -o acpidump.txt") there ?
Comment 21 Jeffrey Walton 2020-05-02 13:54:15 UTC
(In reply to Hans de Goede from comment #20)
> I see that you have already filed:
> https://bugzilla.redhat.com/show_bug.cgi?id=1830475
> 
> Can you please attach full dmesg output and an acpidump ("sudo acpidump -o
> acpidump.txt") there ?

Thanks Hans.

Yes, I'll get you the docs on the other issue report.

Sorry to bring this up again. I understand HP does not make it easy on you.

Note You need to log in before you can comment on or make changes to this bug.