Bug 201815 - Mouse Pointer Disappears when touching top of the screen
Summary: Mouse Pointer Disappears when touching top of the screen
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-29 13:42 UTC by siyia
Modified: 2019-01-21 19:05 UTC (History)
5 users (show)

See Also:
Kernel Version: 4.20-5.0rc1
Tree: Mainline
Regression: Yes


Attachments
4.19.4 dmesg (88.14 KB, text/plain)
2018-11-30 08:45 UTC, siyia
Details
4.20 mainline dmesg (90.43 KB, text/plain)
2018-11-30 08:46 UTC, siyia
Details

Description siyia 2018-11-29 13:42:47 UTC
When the mouse cursor touches the top border of the desktop screen it dissapears,bug is only reproducable with kernel 4.20, on previous kernels 4.19 and 4.18 it works as it should,affected pc is a laptop with a single screen.

specs:
acer aspire a315-41
cpu ryzen 3 2200u
gpu1 vega 3
gpu2 radeon 535

OS: Fedora 29, Archlinux

DE: xfce4
Comment 1 Michel Dänzer 2018-11-29 15:07:28 UTC
Please attach the output of dmesg with 4.20 and 4.19.

Can you bisect?
Comment 2 siyia 2018-11-30 08:45:34 UTC
Created attachment 279751 [details]
4.19.4 dmesg
Comment 3 siyia 2018-11-30 08:46:00 UTC
Created attachment 279753 [details]
4.20 mainline dmesg
Comment 4 siyia 2018-11-30 08:47:35 UTC
sorry cant bisect even if i could it requires a lot of time,since it is graphical and the laptop uses only amd gpus,it is likely a commit to the amdgpu that caused it.
Comment 5 siyia 2018-12-06 15:38:24 UTC
kernel 4.20rc5 completely broke on my laptop cannot boot or look at logs it freezes after grub with cursor blink and cpu fan at 100%
Comment 6 siyia 2018-12-07 05:07:21 UTC
that was an issue with the kernel fedora mainline repo, kernel 4.20rc5 boots on my laptop on archlinux, but the mouse pointer issue remains
Comment 7 siyia 2018-12-07 05:59:20 UTC
A workaround that works is to enable software cursor in Xorg,
i edited 10-amdgpu.conf and 10-radeon.conf
and added:

  Option "SWCursor" "True"
Comment 8 siyia 2018-12-30 20:04:07 UTC
Hello issue persists on latest kernel 4.20 stable
Comment 9 siyia 2018-12-30 20:07:12 UTC
tried both wayland and xorg on kde
Comment 10 Sam Bazley 2019-01-02 17:02:23 UTC
This issue also affects 2500U and 2700U, but not Vega 64.
Comment 11 siyia 2019-01-07 05:04:20 UTC
bug exists in kernel 5.0rc1 too
Comment 12 Nicholas Kazlauskas 2019-01-07 15:14:18 UTC
There's a fix for this bug coming soon.

The bug only affects Raven systems and was a regression introduced in 4.20.
Comment 13 siyia 2019-01-20 18:50:34 UTC
regression is still present at linux 4.20.3
Comment 15 siyia 2019-01-21 19:05:05 UTC
Finally!!! i applied the fix in kernel 4.20.3 and it works!!!thx i ve been waiting for a month for this

Note You need to log in before you can comment on or make changes to this bug.