Bug 201813 - iwlwifi: 9560: can't load INIT firmware
Summary: iwlwifi: 9560: can't load INIT firmware
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-29 12:59 UTC by Maarten
Modified: 2019-12-02 15:00 UTC (History)
3 users (show)

See Also:
Kernel Version: SMP Debian 4.18.10-2 & SMP Debian 4.19.5
Tree: Mainline
Regression: No


Attachments
Error log of failing wifi with latest module and firmware (137.73 KB, text/plain)
2018-12-07 10:22 UTC, Maarten
Details
firmware (2.82 MB, application/octet-stream)
2018-12-16 07:59 UTC, Emmanuel Grumbach
Details
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-41.ucode (65.68 KB, text/plain)
2019-01-07 07:14 UTC, jian-hong
Details
Original dmesg of Linux 4.20 with -38.ucode (65.35 KB, text/plain)
2019-01-07 08:10 UTC, jian-hong
Details
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-43.ucode (71.54 KB, text/plain)
2019-01-08 06:36 UTC, jian-hong
Details
dmesg of Linux kernel 4.19 with iwlwifi-9000-pu-b0-jf-b0-43.ucode (214.90 KB, text/plain)
2019-01-08 07:27 UTC, jian-hong
Details
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-43.ucode (43.95eb4e97.0) (137.54 KB, text/plain)
2019-01-08 09:52 UTC, jian-hong
Details
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-43.ucode (43.95eb4e97.0) and patch (67.74 KB, text/plain)
2019-01-09 03:49 UTC, jian-hong
Details

Description Maarten 2018-11-29 12:59:46 UTC
From the system log (on reloading the iwlwifi kernel module):

Nov 29 13:26:28 kernel: Intel(R) Wireless WiFi driver for Linux
Nov 29 13:26:28 kernel: Copyright(c) 2003- 2015 Intel Corporation
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-38.ucode
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: loaded firmware version 38.c0e03d94.0 op_mode iwlmvm
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x240f
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Nov 29 13:26:28 kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 1 Emmanuel Grumbach 2018-11-29 13:07:10 UTC
Please test latest upstream kernel. Fixes for BT could help here.
Comment 2 Maarten 2018-11-29 14:45:29 UTC
No dice:

maarten@test:~$ uname -a
Linux test 4.19.5 #1 SMP Thu Nov 29 14:34:57 CET 2018 x86_64 GNU/Linux

maarten@test:~$ sudo journalctl -f
-- Logs begin at Thu 2018-11-29 15:42:43 CET. --
Nov 29 15:43:23 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Nov 29 15:43:24 test kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Nov 29 15:43:24 test kernel: iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
Nov 29 15:43:24 test kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x240f
Nov 29 15:43:24 test kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Nov 29 15:43:24 test kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 3 Maarten 2018-11-29 14:54:50 UTC
Sorry, here's the full log:

Nov 29 15:52:56 test kernel: Intel(R) Wireless WiFi driver for Linux
Nov 29 15:52:56 test kernel: Copyright(c) 2003- 2015 Intel Corporation
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-38.ucode
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: loaded firmware version 38.c0e03d94.0 op_mode iwlmvm
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x240f
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Nov 29 15:52:56 test kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 4 Maarten 2018-11-29 20:34:25 UTC
woops, sorry, thought the title was an error on my part ;)
Comment 5 Emmanuel Grumbach 2018-12-04 17:35:57 UTC
please backlist btusb and give your system a cold reboot.

Let us know what happens then.

thanks.b
Comment 6 Maarten 2018-12-04 19:42:01 UTC
Already had it blacklisted before:

root@test:~$ uname -a
Linux test 4.18.0-3-amd64 #1 SMP Debian 4.18.20-2 (2018-11-23) x86_64 GNU/Linux
root@test:/home/test# cat /etc/modprobe.d/blacklist-btusb.conf 
blacklist btusb
root@test:/home/test# lsm
lsmem  lsmod  
root@test:/home/test# cat /etc/modprobe.d/blacklist-btusb.conf 
blacklist btusb
root@test:/home/test# lsmod | grep btusb
root@test:/home/test# sudo dmesg | grep iwlwifi
[    7.870376] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    7.898253] iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-38.ucode
[    7.898713] iwlwifi 0000:00:14.3: loaded firmware version 38.c0e03d94.0 op_mode iwlmvm
[    7.948552] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    8.190383] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    8.190386] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[    8.190464] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x2410
[    8.190465] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[    8.202184] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 7 Emmanuel Grumbach 2018-12-04 19:46:39 UTC
Please install the master branch of our backport driver: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release

And use the latest firmware: -41.ucode.

Thank you.
Comment 8 Maarten 2018-12-04 21:57:20 UTC
Works! With the 4.18.0-3 debian kernel as well as the 4.19.6 upstream. Thanks for the help.

Dec 04 22:55:50 test kernel: Intel(R) Wireless WiFi driver for Linux
Dec 04 22:55:50 test kernel: Copyright(c) 2003- 2015 Intel Corporation
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwl-dbg-cfg.ini (-2)
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-45.ucode (-2)
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-44.ucode (-2)
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-43.ucode (-2)
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-43.ucode failed with error -2
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-42.ucode (-2)
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-42.ucode failed with error -2
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-41.ucode
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: loaded firmware version 41.1f1e8d4a.0 op_mode iwlmvm
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Dec 04 22:55:50 test kernel: iwlwifi 0000:00:14.3: base HW address: 64:5d:86:ea:76:67
Dec 04 22:55:50 test kernel: ieee80211 phy1: copying sband (band 1) due to VHT EXT NSS BW flag
Dec 04 22:55:50 test kernel: thermal thermal_zone8: failed to read out thermal zone (-61)
Dec 04 22:55:50 test kernel: Unable to register with Frequency Manager: -22
Comment 9 Maarten 2018-12-07 10:22:22 UTC
Created attachment 279895 [details]
Error log of failing wifi with latest module and firmware

My wifi stopped working again, this time with the latest module from master and the latest firmware. See the attached error log.

The problem occurs here (full stack trace in the error log):
Dec 07 10:25:17 test kernel: iwlwifi 0000:00:14.3: Error sending STATISTICS_CMD: time out after 2000ms.
Dec 07 10:25:17 test kernel: iwlwifi 0000:00:14.3: Current CMD queue read_ptr 112 write_ptr 113
Dec 07 10:25:17 test kernel: ------------[ cut here ]------------
Dec 07 10:25:17 test kernel: Timeout waiting for hardware access (CSR_GP_CNTRL 0x0c04000c)
Dec 07 10:25:17 test kernel: WARNING: CPU: 4 PID: 864 at /home/test/Desktop/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/pcie/trans.c:2079 iwl_tr
Dec 07 10:25:17 test kernel: Modules linked in: ctr ccm ipt_MASQUERADE nf_conntrack_netlink xfrm_user xfrm_algo nft_counter nft_chain_nat_ipv4 nf_conntrack
Dec 07 10:25:17 test kernel:  intel_uncore efi_pstore media drm_kms_helper snd_hwdep joydev intel_rapl_perf snd_pcm evdev snd_timer tpm_crb serio_raw efiva
Dec 07 10:25:17 test kernel:  libcrc32c crc32c_generic raid1 raid0 multipath linear md_mod sd_mod hid_generic crct10dif_pclmul crc32_pclmul crc32c_intel gh

And subsequent reloads of the kernel module then produce this:
Dec 07 10:27:31 test kernel: Intel(R) Wireless WiFi driver for Linux
Dec 07 10:27:31 test kernel: Copyright(c) 2003- 2015 Intel Corporation
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwl-dbg-cfg.ini (-2)
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-45.ucode (-2)
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-44.ucode (-2)
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-43.ucode (-2)
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-43.ucode failed with error -2
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-42.ucode (-2)
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-42.ucode failed with error -2
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-41.ucode
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: loaded firmware version 41.1f1e8d4a.0 op_mode iwlmvm
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x4c77
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Dec 07 10:27:31 test kernel: iwlwifi 0000:00:14.3: Collecting data: trigger 16 fired.
Dec 07 10:27:32 test kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

I've left the temperature stuff at the top of the log on the off-chance that it's related.
Comment 10 Emmanuel Grumbach 2018-12-12 09:23:29 UTC
Please try with this:

diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/utils.c b/drivers/net/wireless/intel/iwlwifi/mvm/utils.c
index 1c04e06..e1b4c4f 100644
--- a/drivers/net/wireless/intel/iwlwifi/mvm/utils.c
+++ b/drivers/net/wireless/intel/iwlwifi/mvm/utils.c
@@ -503,6 +503,8 @@ static void iwl_mvm_dump_lmac_error_log(struct iwl_mvm *mvm, u8 lmac_num)
                        base = mvm->fw->inst_errlog_ptr;
        }
 
+
+       base = 0x47c4ac;
        if (base < 0x400000) {
                IWL_ERR(mvm,
                        "Not valid error log pointer 0x%08X for %s uCode\n",


It won't fix anything of course, but should allow to learn more.

Thanks.
Comment 11 Emmanuel Grumbach 2018-12-13 18:43:24 UTC
Harder to reproduce? :)
Comment 12 Maarten 2018-12-14 18:57:43 UTC
Just tried:

Dec 14 19:53:31 test kernel: Intel(R) Wireless WiFi driver for Linux
Dec 14 19:53:31 test kernel: Copyright(c) 2003- 2015 Intel Corporation
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwl-dbg-cfg.ini (-2)
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-45.ucode (-2)
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-44.ucode (-2)
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-43.ucode (-2)
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-43.ucode failed with error -2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-42.ucode (-2)
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-42.ucode failed with error -2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-41.ucode
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: loaded firmware version 41.1f1e8d4a.0 op_mode iwlmvm
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Status: 0x00000000, count: -1284309395
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Loaded firmware version: 41.1f1e8d4a.0
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x61C0C038 | ADVANCED_SYSASSERT
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x0C80D70C | trm_hw_status0
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x99282624 | trm_hw_status1
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x005215D9 | branchlink2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xDAB3B8DF | interruptlink1
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x31F76CFA | interruptlink2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x4FFEFD66 | data1
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x3C9B3B6E | data2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xB8C5C550 | data3
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x20903007 | beacon time
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x5B040D55 | tsf low
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xBA080038 | tsf hi
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xB9AD3FFC | time gp1
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xB93ED3DF | time gp2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xF5B9EB32 | uCode revision type
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xBDDD3BF6 | uCode version major
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x7CC8021C | uCode version minor
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x6E536CEA | hw version
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x010687D2 | board version
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x6BBA4DE7 | hcmd
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x15DB81FB | isr0
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x1618C061 | isr1
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x004B0720 | isr2
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x099C0EC0 | isr3
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xF1DE0502 | isr4
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xF7735F8A | last cmd Id
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xCFCECDCF | wait_event
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xCDDFF539 | l2p_control
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x5FFBFBFE | l2p_duration
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x47B6CC30 | l2p_mhvalid
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x08320040 | l2p_addr_match
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x318310ED | lmpm_pmg_sel
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0x03940442 | timestamp
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: 0xABD32ECD | flow_handler
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x4c77
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Dec 14 19:53:31 test kernel: iwlwifi 0000:00:14.3: Collecting data: trigger 16 fired.
Dec 14 19:53:32 test kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 13 Emmanuel Grumbach 2018-12-15 16:40:15 UTC
Sorry, I must have done a mistake somewhere.

Will get back to you
Comment 14 Emmanuel Grumbach 2018-12-16 07:59:17 UTC
Created attachment 280029 [details]
firmware

Please use the firmware attached and keep the patch.
Comment 15 Maarten 2018-12-17 15:36:52 UTC
No change as far as I can see. Should I be seeing a different firmware version?

Dec 17 16:32:17 test kernel: Intel(R) Wireless WiFi driver for Linux
Dec 17 16:32:17 test kernel: Copyright(c) 2003- 2015 Intel Corporation
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-43.ucode failed with error -2
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-42.ucode failed with error -2
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: loaded firmware version 41.1f1e8d4a.0 op_mode iwlmvm
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x4c77
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Collecting data: trigger 16 fired.
Dec 17 16:32:17 test kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 16 Maarten 2018-12-17 15:41:49 UTC
I noticed there's a 43 firmware as well, tested that too (with the patch in the module). Didn't help:

Dec 17 16:39:11 test kernel: Intel(R) Wireless WiFi driver for Linux
Dec 17 16:39:11 test kernel: Copyright(c) 2003- 2015 Intel Corporation
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: loaded firmware version 43.c73114b3.0 op_mode iwlmvm
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x23f5
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Collecting data: trigger 16 fired.
Dec 17 16:39:11 test kernel: iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 17 Emmanuel Grumbach 2018-12-17 16:31:31 UTC
are you sure you had the patch in the driver when you produced the log in comment 15?
Comment 18 Emmanuel Grumbach 2019-01-03 20:56:54 UTC
Ping?

You didn't seem to have the patch applied?
Comment 19 Maarten 2019-01-04 20:50:53 UTC
Hi, sorry for the delay, holidays and all.

I'm glad to report I now have working wifi again, using the backport master (with patch) at commit e5486d1a7 and latest firmware version 43 ->


maarten@test:~/Source/backport-iwlwifi(master)$ uname -a
Linux test 4.19.0-1-amd64 #1 SMP Debian 4.19.12-1 (2018-12-22) x86_64 GNU/Linux

[   25.914573] Loading modules backported from iwlwifi
[   25.914574] iwlwifi-stack-public:master:7471:b7580da0
[   26.160649] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   26.162132] iwlwifi 0000:00:14.3: firmware: failed to load iwl-dbg-cfg.ini (-2)
[   26.162136] iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
[   26.162152] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-46.ucode (-2)
[   26.162155] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-46.ucode failed with error -2
[   26.162162] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-45.ucode (-2)
[   26.162165] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
[   26.162172] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-44.ucode (-2)
[   26.162175] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
[   26.178721] iwlwifi 0000:00:14.3: firmware: direct-loading firmware iwlwifi-9000-pu-b0-jf-b0-43.ucode
[   26.179150] iwlwifi 0000:00:14.3: loaded firmware version 43.c73114b3.0 op_mode iwlmvm
[   26.381805] iwlwifi 0000:00:14.3: Detected Intel(R) Wireless-AC 9560 160MHz, REV=0x318
[   26.429842] iwlwifi 0000:00:14.3: base HW address: 64:5d:86:ea:76:67
[   26.597846] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   26.601686] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
[   27.311511] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
[   27.524419] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
Comment 20 Emmanuel Grumbach 2019-01-05 15:58:48 UTC
Thanks. Glad it works.
Comment 21 jian-hong 2019-01-07 07:14:48 UTC
Created attachment 280293 [details]
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-41.ucode

I tried Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-41.ucode on ASUS UX392FN laptop equipped with Intel 9560.  But it still gets the error message:

dmesg | grep iwlwifi
[    2.906053] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.915695] iwlwifi 0000:00:14.3: loaded firmware version 41.fc1a7aea.0 op_mode iwlmvm
[    2.925189] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    3.170016] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    3.170121] iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
[    3.170126] iwlwifi 0000:00:14.3: Status: 0x00000000, count: 6
[    3.170129] iwlwifi 0000:00:14.3: Loaded firmware version: 41.fc1a7aea.0
[    3.170133] iwlwifi 0000:00:14.3: 0x00002BAE | ADVANCED_SYSASSERT          
[    3.170136] iwlwifi 0000:00:14.3: 0x000022F0 | trm_hw_status0
[    3.170139] iwlwifi 0000:00:14.3: 0x00000000 | trm_hw_status1
[    3.170143] iwlwifi 0000:00:14.3: 0x00025800 | branchlink2
[    3.170146] iwlwifi 0000:00:14.3: 0x008E76EC | interruptlink1
[    3.170149] iwlwifi 0000:00:14.3: 0x00000000 | interruptlink2
[    3.170152] iwlwifi 0000:00:14.3: 0xDEADBEEF | data1
[    3.170155] iwlwifi 0000:00:14.3: 0xDEADBEEF | data2
[    3.170158] iwlwifi 0000:00:14.3: 0xDEADBEEF | data3
[    3.170161] iwlwifi 0000:00:14.3: 0x00000000 | beacon time
[    3.170164] iwlwifi 0000:00:14.3: 0x0000003B | tsf low
[    3.170166] iwlwifi 0000:00:14.3: 0x00000000 | tsf hi
[    3.170169] iwlwifi 0000:00:14.3: 0x00000000 | time gp1
[    3.170172] iwlwifi 0000:00:14.3: 0x0000003C | time gp2
[    3.170175] iwlwifi 0000:00:14.3: 0x00000009 | uCode revision type
[    3.170178] iwlwifi 0000:00:14.3: 0x00000029 | uCode version major
[    3.170181] iwlwifi 0000:00:14.3: 0xFC1A7AEA | uCode version minor
[    3.170184] iwlwifi 0000:00:14.3: 0x00000312 | hw version
[    3.170187] iwlwifi 0000:00:14.3: 0x18C89008 | board version
[    3.170190] iwlwifi 0000:00:14.3: 0x00000000 | hcmd
[    3.170193] iwlwifi 0000:00:14.3: 0x00022000 | isr0
[    3.170196] iwlwifi 0000:00:14.3: 0x08000000 | isr1
[    3.170199] iwlwifi 0000:00:14.3: 0x08001802 | isr2
[    3.170202] iwlwifi 0000:00:14.3: 0x004000C0 | isr3
[    3.170205] iwlwifi 0000:00:14.3: 0x00000000 | isr4
[    3.170208] iwlwifi 0000:00:14.3: 0x00000000 | last cmd Id
[    3.170211] iwlwifi 0000:00:14.3: 0x00000000 | wait_event
[    3.170214] iwlwifi 0000:00:14.3: 0x00000000 | l2p_control
[    3.170216] iwlwifi 0000:00:14.3: 0x00000000 | l2p_duration
[    3.170219] iwlwifi 0000:00:14.3: 0x00000000 | l2p_mhvalid
[    3.170222] iwlwifi 0000:00:14.3: 0x00000000 | l2p_addr_match
[    3.170225] iwlwifi 0000:00:14.3: 0x00000000 | lmpm_pmg_sel
[    3.170228] iwlwifi 0000:00:14.3: 0x00000000 | timestamp
[    3.170231] iwlwifi 0000:00:14.3: 0x0000F81C | flow_handler
[    3.170341] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x2425
[    3.170346] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[    3.170353] iwlwifi 0000:00:14.3: Collecting data: trigger 15 fired.
[    3.389506] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

lsusb 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f3:0903 Elan Microelectronics Corp. 
Bus 001 Device 003: ID 13d3:56dc IMC Networks 
Bus 001 Device 006: ID 192f:0916 Avago Technologies, Pte. 
Bus 001 Device 005: ID 8087:0aaa Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The wifi adapter still disappears.
Comment 22 Emmanuel Grumbach 2019-01-07 07:31:36 UTC
You comment on a bug which is closed by a code fix on a firmware version that you don't run.
So your comment is not helpful.
Comment 23 jian-hong 2019-01-07 07:36:02 UTC
(In reply to Emmanuel Grumbach from comment #22)
> You comment on a bug which is closed by a code fix on a firmware version
> that you don't run.
> So your comment is not helpful.

Should I open another ticket for it?
Comment 24 Emmanuel Grumbach 2019-01-07 07:42:04 UTC
No, you should be using -43.ucode from:

https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-9000-pu-b0-jf-b0-43.ucode
Comment 25 jian-hong 2019-01-07 08:10:39 UTC
Created attachment 280295 [details]
Original dmesg of Linux 4.20 with -38.ucode

(In reply to Emmanuel Grumbach from comment #24)
> No, you should be using -43.ucode from:
> 
> https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/
> plain/iwlwifi-9000-pu-b0-jf-b0-43.ucode

Uh ...  The system does not have iwlwifi-9000-pu-b0-jf-b0-41.ucode originally. 
Here are the original iwlwifi messages:

dmesg | grep iwlwifi
[    2.890654] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.897924] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-41.ucode failed with error -2
[    2.897938] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-40.ucode failed with error -2
[    2.897947] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-39.ucode failed with error -2
[    2.906388] iwlwifi 0000:00:14.3: loaded firmware version 38.755cfdd8.0 op_mode iwlmvm
[    2.923709] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    3.165416] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    3.165488] iwlwifi 0000:00:14.3: Loaded firmware version: 38.755cfdd8.0
...
[    3.165614] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x240f
[    3.165616] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[    3.165620] iwlwifi 0000:00:14.3: Collecting data: trigger 15 fired.
[    3.382676] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

System tried to load the ucode and started from iwlwifi-9000-pu-b0-jf-b0-41.ucode.  But it failed until it loaded iwlwifi-9000-pu-b0-jf-b0-38.ucode.  Then I copy the iwlwifi-9000-pu-b0-jf-b0-43.ucode into /lib/firmware/ manually.

Should I applied another commits to make iwlwifi load newer ucode like iwlwifi-9000-pu-b0-jf-b0-43.ucode?
Comment 26 Emmanuel Grumbach 2019-01-07 08:21:48 UTC
Please also install our backport driver so that you'll be able to use our latest firmware:

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release#how_to_install_the_driver
Comment 27 jian-hong 2019-01-08 06:36:24 UTC
Created attachment 280321 [details]
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-43.ucode

Thanks for your information.

I have tried the backport driver and iwlwifi-9000-pu-b0-jf-b0-43.ucode, but it bumps another errors:

[    2.573756] compat: loading out-of-tree module taints kernel.
[    2.575059] Loading modules backported from iwlwifi
[    2.575059] iwlwifi-stack-public:master:7471:b7580da0
[    2.583375] Intel(R) Wireless WiFi driver for Linux
[    2.583376] Copyright(c) 2003- 2015 Intel Corporation
[    2.583429] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.587690] iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
[    2.587840] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-46.ucode failed with error -2
[    2.587852] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
[    2.587862] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
[    2.592647] iwlwifi 0000:00:14.3: loaded firmware version 43.c73114b3.0 op_mode iwlmvm
[    2.606514] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    2.632418] eos-companion-a (370) used greatest stack depth: 13304 bytes left
[    2.658001] iwlwifi 0000:00:14.3: base HW address: a0:a4:c5:85:0a:25
[    2.712860] (s-paygd1) (420) used greatest stack depth: 13144 bytes left
[    2.724876] WARNING: CPU: 3 PID: 406 at net/wireless/core.c:736 wiphy_register+0x409/0x840
[    2.725814] Modules linked in: iwlmvm(O+) x86_pkg_temp_thermal mac80211(O) iwlwifi(O) compat(O) efivarfs
[    2.725819] CPU: 3 PID: 406 Comm: modprobe Tainted: G           O      4.20.0 #13
[    2.725820] Hardware name: ASUSTeK COMPUTER INC. ZenBook UX392FN_UX392FN/UX392FN, BIOS UX392FN.201 01/02/2019
[    2.725822] RIP: 0010:wiphy_register+0x409/0x840
[    2.725823] Code: ff ff ff e9 ca fe ff ff 80 7a 10 00 0f 85 86 fe ff ff 0f 0b b8 ea ff ff ff e9 b4 fe ff ff 0f 0b b8 ea ff ff ff e9 a8 fe ff ff <0f> 0b e9 3c fe ff ff 0f 0b b8 ea ff ff ff e9 95 fe ff ff 0f 0b b8
[    2.725824] RSP: 0018:ffffb3d70211ba70 EFLAGS: 00010246
[    2.725825] RAX: ffffffffc0242f60 RBX: ffff89c71abd0300 RCX: 00001d1f7d0300d0
[    2.725826] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff89c71abd0300
[    2.725826] RBP: ffffb3d70211bb00 R08: ffff89c71dae3c40 R09: ffff89c717fb8400
[    2.725827] R10: ffffb3d70211bb18 R11: 0000000000000000 R12: 0000000000000000
[    2.725827] R13: 0000000000000000 R14: 0000000000000033 R15: 0000000000000001
[    2.725828] FS:  00007f94dfecf700(0000) GS:ffff89c71dac0000(0000) knlGS:0000000000000000
[    2.725829] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    2.725830] CR2: 0000557a667e2018 CR3: 0000000457724006 CR4: 00000000003606e0
[    2.725830] Call Trace:
[    2.725834]  ? device_create_with_groups+0x3a/0x60
[    2.725836]  ? _cond_resched+0x11/0x40
[    2.725837]  ? _cond_resched+0x11/0x40
[    2.725839]  ? __kmalloc+0x196/0x1a0
[    2.725846]  ? ieee80211_register_hw+0x43c/0xcd0 [mac80211]
[    2.725851]  ieee80211_register_hw+0x43c/0xcd0 [mac80211]
[    2.746702]  iwl_mvm_mac_setup_register+0x94d/0xb40 [iwlmvm]
[    2.746709]  iwl_op_mode_mvm_start+0x8f4/0xc20 [iwlmvm]
[    2.748339]  _iwl_op_mode_start.isra.4+0x3c/0x90 [iwlwifi]
[    2.748342]  iwl_opmode_register+0x9e/0xd0 [iwlwifi]
[    2.750167]  ? 0xffffffffc01be000
[    2.750180]  __init_backport+0x34/0x1000 [iwlmvm]
[    2.751790]  ? 0xffffffffc01be000
[    2.751791]  do_one_initcall+0x45/0x1ac
[    2.751795]  ? _cond_resched+0x11/0x40
[    2.754415]  ? kmem_cache_alloc_trace+0x36/0x160
[    2.754417]  do_init_module+0x56/0x1e6
[    2.754418]  load_module+0x1f9f/0x25c0
[    2.754420]  ? vfs_read+0x114/0x130
[    2.754422]  ? __do_sys_finit_module+0xce/0xe0
[    2.754423]  __do_sys_finit_module+0xce/0xe0
[    2.754424]  do_syscall_64+0x39/0xe0
[    2.754426]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[    2.754427] RIP: 0033:0x7f94dfa12229
[    2.754429] Code: 00 f3 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 40 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 3f 4c 2b 00 f7 d8 64 89 01 48
[    2.754429] RSP: 002b:00007ffe73da02a8 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
[    2.754430] RAX: ffffffffffffffda RBX: 0000562e5e446780 RCX: 00007f94dfa12229
[    2.754431] RDX: 0000000000000000 RSI: 0000562e5e174638 RDI: 0000000000000001
[    2.754431] RBP: 0000562e5e174638 R08: 0000000000000000 R09: 0000000000000000
[    2.754432] R10: 0000000000000001 R11: 0000000000000246 R12: 0000000000000000
[    2.754432] R13: 0000562e5e448c70 R14: 0000000000040000 R15: 0000000000000000
[    2.754434] ---[ end trace d8e0797fdd86a7e2 ]---
[    2.754474] WARNING: CPU: 3 PID: 406 at net/wireless/core.c:814 wiphy_register+0x82d/0x840
[    2.802357] Modules linked in: iwlmvm(O+) x86_pkg_temp_thermal mac80211(O) iwlwifi(O) compat(O) efivarfs
[    2.802364] CPU: 3 PID: 406 Comm: modprobe Tainted: G        W  O      4.20.0 #13
[    2.802365] Hardware name: ASUSTeK COMPUTER INC. ZenBook UX392FN_UX392FN/UX392FN, BIOS UX392FN.201 01/02/2019
[    2.802369] RIP: 0010:wiphy_register+0x82d/0x840
[    2.802371] Code: 0b b8 ea ff ff ff e9 a3 fa ff ff 0f 0b b8 ea ff ff ff e9 97 fa ff ff 0f 0b e9 43 ff ff ff 48 8b bb 38 01 00 00 e9 52 fe ff ff <0f> 0b b8 ea ff ff ff e9 78 fa ff ff 0f 1f 80 00 00 00 00 53 89 fb
[    2.802372] RSP: 0018:ffffb3d70211ba70 EFLAGS: 00010246
[    2.802373] RAX: 0000000000000000 RBX: ffff89c71abd0300 RCX: 00001d1f7d0300d0
[    2.802374] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff89c71abd0300
[    2.802375] RBP: ffffb3d70211bb00 R08: 0000000000000002 R09: 0000000000000003
[    2.802375] R10: ffffb3d70211bb18 R11: 0000000000000000 R12: 0000000000000000
[    2.802376] R13: 0000000000000000 R14: 0000000000000033 R15: 0000000000000001
[    2.802378] FS:  00007f94dfecf700(0000) GS:ffff89c71dac0000(0000) knlGS:0000000000000000
[    2.802379] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    2.802380] CR2: 0000557a667e2018 CR3: 0000000457724006 CR4: 00000000003606e0
[    2.802380] Call Trace:
[    2.802384]  ? device_create_with_groups+0x3a/0x60
[    2.802387]  ? _cond_resched+0x11/0x40
[    2.802388]  ? _cond_resched+0x11/0x40
[    2.802391]  ? __kmalloc+0x196/0x1a0
[    2.802404]  ? ieee80211_register_hw+0x43c/0xcd0 [mac80211]
[    2.802411]  ieee80211_register_hw+0x43c/0xcd0 [mac80211]
[    2.833038]  iwl_mvm_mac_setup_register+0x94d/0xb40 [iwlmvm]
[    2.833045]  iwl_op_mode_mvm_start+0x8f4/0xc20 [iwlmvm]
[    2.835087]  _iwl_op_mode_start.isra.4+0x3c/0x90 [iwlwifi]
[    2.835090]  iwl_opmode_register+0x9e/0xd0 [iwlwifi]
[    2.837138]  ? 0xffffffffc01be000
[    2.837145]  __init_backport+0x34/0x1000 [iwlmvm]
[    2.837146]  ? 0xffffffffc01be000
[    2.840015]  do_one_initcall+0x45/0x1ac
[    2.840018]  ? _cond_resched+0x11/0x40
[    2.840020]  ? kmem_cache_alloc_trace+0x36/0x160
[    2.840022]  do_init_module+0x56/0x1e6
[    2.840023]  load_module+0x1f9f/0x25c0
[    2.840025]  ? vfs_read+0x114/0x130
[    2.840026]  ? __do_sys_finit_module+0xce/0xe0
[    2.840027]  __do_sys_finit_module+0xce/0xe0
[    2.840028]  do_syscall_64+0x39/0xe0
[    2.840029]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[    2.840031] RIP: 0033:0x7f94dfa12229
[    2.840033] Code: 00 f3 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 40 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 3f 4c 2b 00 f7 d8 64 89 01 48
[    2.840034] RSP: 002b:00007ffe73da02a8 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
[    2.840035] RAX: ffffffffffffffda RBX: 0000562e5e446780 RCX: 00007f94dfa12229
[    2.840035] RDX: 0000000000000000 RSI: 0000562e5e174638 RDI: 0000000000000001
[    2.840036] RBP: 0000562e5e174638 R08: 0000000000000000 R09: 0000000000000000
[    2.840036] R10: 0000000000000001 R11: 0000000000000246 R12: 0000000000000000
[    2.840037] R13: 0000562e5e448c70 R14: 0000000000040000 R15: 0000000000000000
[    2.840038] ---[ end trace d8e0797fdd86a7e3 ]---
[    2.860582] systemd-udevd (345) used greatest stack depth: 12416 bytes left
[   62.895035] rfkill: input handler disabled

And no wireless interface:

ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: sit0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/sit 0.0.0.0 brd 0.0.0.0
3: enx002432168f82: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 00:24:32:16:8f:82 brd ff:ff:ff:ff:ff:ff

Anything else I can help or check more?
Comment 28 jian-hong 2019-01-08 07:27:10 UTC
Created attachment 280323 [details]
dmesg of Linux kernel 4.19 with iwlwifi-9000-pu-b0-jf-b0-43.ucode

I also have tried the backport driver with 4.19 kernel and iwlwifi-9000-pu-b0-jf-b0-43.ucode, and it also gets errors:

[    2.702182] compat: loading out-of-tree module taints kernel.
[    2.702373] Loading modules backported from iwlwifi
[    2.702374] iwlwifi-stack-public:master:7471:b7580da0
[    2.715253] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    2.734967] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    2.735582] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    2.736714] cfg80211: failed to load regulatory.db
[    2.738879] Intel(R) Wireless WiFi driver for Linux
[    2.739711] Copyright(c) 2003- 2015 Intel Corporation
[    2.740670] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.743650] iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
[    2.744695] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-46.ucode failed with error -2
[    2.745760] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
[    2.746586] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
[    2.753440] iwlwifi 0000:00:14.3: loaded firmware version 43.c73114b3.0 op_mode iwlmvm
[    2.811000] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    2.858570] iwlwifi 0000:00:14.3: base HW address: a0:a4:c5:85:0a:25
[    2.879692] systemd-udevd (309) used greatest stack depth: 13296 bytes left
[    2.881406] systemd-udevd (303) used greatest stack depth: 12544 bytes left
[    2.925660] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    2.925842] thermal thermal_zone2: failed to read out thermal zone (-61)
[    2.925886] Unable to register with Frequency Manager: -22
[    2.926820] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
[    2.976740] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[    3.175702] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
[    3.176615] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[    3.222213] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[    6.338735] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    6.338808] iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
[    6.338810] iwlwifi 0000:00:14.3: Status: 0x00000100, count: 6
[    6.338811] iwlwifi 0000:00:14.3: Loaded firmware version: 43.c73114b3.0
[    6.338812] iwlwifi 0000:00:14.3: 0x00002B80 | ADVANCED_SYSASSERT          
[    6.338813] iwlwifi 0000:00:14.3: 0x00A022F0 | trm_hw_status0
[    6.338815] iwlwifi 0000:00:14.3: 0x00000000 | trm_hw_status1
[    6.338816] iwlwifi 0000:00:14.3: 0x0048973E | branchlink2
[    6.338817] iwlwifi 0000:00:14.3: 0x0047ACCA | interruptlink1
[    6.338818] iwlwifi 0000:00:14.3: 0x00000000 | interruptlink2
...
Comment 29 Emmanuel Grumbach 2019-01-08 07:32:36 UTC
You didn't take the FW from the URL in comment 24
Comment 30 jian-hong 2019-01-08 09:52:05 UTC
Created attachment 280329 [details]
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-43.ucode (43.95eb4e97.0)

I tried with kernel 4.20 and backport driver with iwlwifi-9000-pu-b0-jf-b0-43.ucode (43.95eb4e97.0) again.  The WiFi becomes more stable now.  However, it is still failed to start INIT ucode during booting some times. 

The easy way to reproduce that:
1. modprobe -r iwlwifi
2. sleep a while
3. modprobe iwlwifi
4. sleep a while
5. check the WiFi status
I did the steps in a loop.

[ 1002.005578] Loading modules backported from iwlwifi
[ 1002.005582] iwlwifi-stack-public:master:7471:b7580da0
[ 1002.010159] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 1002.010386] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[ 1002.010407] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 1002.010408] cfg80211: failed to load regulatory.db
[ 1002.012570] Intel(R) Wireless WiFi driver for Linux
[ 1002.012573] Copyright(c) 2003- 2015 Intel Corporation
[ 1002.013752] iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
[ 1002.013768] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-46.ucode failed with error -2
[ 1002.013775] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
[ 1002.013782] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
[ 1002.015166] iwlwifi 0000:00:14.3: loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
[ 1002.020845] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[ 1002.061700] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[ 1002.061716] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[ 1002.061846] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x23f4
[ 1002.061855] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[ 1002.061861] iwlwifi 0000:00:14.3: Collecting data: trigger 17 fired.
[ 1002.061874] iwlwifi 0000:00:14.3: Firmware not running - cannot dump error
[ 1002.074647] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
Comment 31 Emmanuel Grumbach 2019-01-08 10:14:03 UTC
Please apply the patch from comment 15.
Comment 32 Emmanuel Grumbach 2019-01-08 22:38:37 UTC
Note that patch will not fix anything but rather give us more data on the failure.
Comment 33 jian-hong 2019-01-09 03:49:10 UTC
Created attachment 280349 [details]
dmesg of Linux kernel 4.20 with iwlwifi-9000-pu-b0-jf-b0-43.ucode (43.95eb4e97.0) and patch

Is the patch Comment 10?

I applied it upon the backport driver and got the error:

[    2.424996] compat: loading out-of-tree module taints kernel.
[    2.425943] Loading modules backported from iwlwifi
[    2.425944] iwlwifi-stack-public:master:7471:b7580da0
[    2.431781] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    2.437833] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    2.440622] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    2.440624] cfg80211: failed to load regulatory.db
[    2.446129] Intel(R) Wireless WiFi driver for Linux
[    2.446964] Copyright(c) 2003- 2015 Intel Corporation
[    2.447766] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.456401] iwlwifi 0000:00:14.3: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
[    2.456557] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-46.ucode failed with error -2
[    2.456569] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-45.ucode failed with error -2
[    2.456579] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-44.ucode failed with error -2
[    2.461127] iwlwifi 0000:00:14.3: loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
[    2.477639] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    2.517535] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[    2.517609] iwlwifi 0000:00:14.3: Loaded firmware version: 43.95eb4e97.0
[    2.517610] iwlwifi 0000:00:14.3: 0x00000000 | ADVANCED_SYSASSERT          
[    2.517611] iwlwifi 0000:00:14.3: 0x00000000 | trm_hw_status0
[    2.517611] iwlwifi 0000:00:14.3: 0x00000000 | trm_hw_status1
[    2.517612] iwlwifi 0000:00:14.3: 0x00000000 | branchlink2
[    2.517612] iwlwifi 0000:00:14.3: 0x00000000 | interruptlink1
[    2.517613] iwlwifi 0000:00:14.3: 0x00000000 | interruptlink2
[    2.517613] iwlwifi 0000:00:14.3: 0x00000000 | data1
[    2.517614] iwlwifi 0000:00:14.3: 0x00000000 | data2
[    2.517615] iwlwifi 0000:00:14.3: 0x00000000 | data3
[    2.517615] iwlwifi 0000:00:14.3: 0x00000000 | beacon time
[    2.517616] iwlwifi 0000:00:14.3: 0x00000000 | tsf low
[    2.517616] iwlwifi 0000:00:14.3: 0x00000000 | tsf hi
[    2.517617] iwlwifi 0000:00:14.3: 0x00000000 | time gp1
[    2.517617] iwlwifi 0000:00:14.3: 0x00000000 | time gp2
[    2.517618] iwlwifi 0000:00:14.3: 0x00000000 | uCode revision type
[    2.517618] iwlwifi 0000:00:14.3: 0x00000000 | uCode version major
[    2.517619] iwlwifi 0000:00:14.3: 0x00000000 | uCode version minor
[    2.517619] iwlwifi 0000:00:14.3: 0x00000000 | hw version
[    2.517620] iwlwifi 0000:00:14.3: 0x00000000 | board version
[    2.517620] iwlwifi 0000:00:14.3: 0x00000000 | hcmd
[    2.517621] iwlwifi 0000:00:14.3: 0x00000000 | isr0
[    2.517621] iwlwifi 0000:00:14.3: 0x00000000 | isr1
[    2.517622] iwlwifi 0000:00:14.3: 0x00000000 | isr2
[    2.517622] iwlwifi 0000:00:14.3: 0x00000000 | isr3
[    2.517623] iwlwifi 0000:00:14.3: 0x00000000 | isr4
[    2.517623] iwlwifi 0000:00:14.3: 0x00000000 | last cmd Id
[    2.517624] iwlwifi 0000:00:14.3: 0x00000000 | wait_event
[    2.517624] iwlwifi 0000:00:14.3: 0x00000000 | l2p_control
[    2.517625] iwlwifi 0000:00:14.3: 0x00000000 | l2p_duration
[    2.517626] iwlwifi 0000:00:14.3: 0x00000000 | l2p_mhvalid
[    2.517626] iwlwifi 0000:00:14.3: 0x00000000 | l2p_addr_match
[    2.517627] iwlwifi 0000:00:14.3: 0x00000000 | lmpm_pmg_sel
[    2.517627] iwlwifi 0000:00:14.3: 0x00000000 | timestamp
[    2.517628] iwlwifi 0000:00:14.3: 0x00000000 | flow_handler
[    2.517664] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x23f4
[    2.517665] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[    2.517667] iwlwifi 0000:00:14.3: Collecting data: trigger 17 fired.
[    2.517672] iwlwifi 0000:00:14.3: Firmware not running - cannot dump error
[    2.529163] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5
[    2.586243] (s-paygd1) (370) used greatest stack depth: 13320 bytes left
[    2.739294] systemd-udevd (344) used greatest stack depth: 12640 bytes left
[   36.624618] rfkill: input handler disabled
Comment 34 Emmanuel Grumbach 2019-01-09 04:23:51 UTC
Oh well.

So even that didn't help.
I'll need get back to you but I am really really busy with other stuff.
Comment 35 Jonathan Dönszelmann 2019-03-17 15:44:06 UTC
I have had the exact same issue.  I discovered it actually has more to do with the wireless access point you're connected to than your own computer. I managed to fix it by adding a file to the /etc/modprobe.d directory called iwlwifi.conf (it may or may not be already there) and adding to it the line
```
options iwlwifi 11n-disable=1
```

I do not exactly know why it resolved the problem but it has removed all the errors so it must do something. 

To test if it's your access point you could try to connect to for example a 4g wifi hotspot or some other wifi router.

Hope it helps you and all future users.

Jonathan
Comment 36 Emmanuel Grumbach 2019-03-17 16:44:00 UTC
@Jonathan,

This can't be related.
Either you are facing a different issue, either you still see the problem.
Please open a different bug, add linuxwifi@intel.com to the bug, and attach both dmesg, with 11n_disable=1 and without it.
Comment 37 Jonathan Dönszelmann 2019-03-18 07:12:54 UTC
I'm sorry, but it definitely is. I have spent all day yesterday trying to resolve the exact same error as Maarten had: An error in the SW microcode with an invalid log pointer to 0x0. It definitely solved my issue and should solve maartens.
Comment 38 Jonathan Dönszelmann 2019-03-18 07:16:34 UTC
this is the relevant part of my dmesg:

Mar 17 12:52:02 null kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Mar 17 12:52:02 null kernel: iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
Mar 17 12:52:02 null kernel: iwlwifi 0000:00:14.3: Status: 0x00000100, count: 6
Mar 17 12:52:02 null kernel: iwlwifi 0000:00:14.3: Loaded firmware version: 43.95eb4e97.0
Comment 39 Emmanuel Grumbach 2019-03-18 07:19:23 UTC
So you don't have a failure in the INIT image.

Please attach the full dmesg
Comment 40 Jonathan Dönszelmann 2019-03-18 07:20:39 UTC
https://pastebin.com/pZuGvaE8
Comment 41 Emmanuel Grumbach 2019-03-18 07:26:01 UTC
Please open a new bug.
Comment 42 jian-hong 2019-03-19 08:54:04 UTC
I have sent ASUS UX392FN laptop equipped with Intel 9560 back to ASUS for rework.  I get the laptop back and try for testing again.  The issue is gone and system works fine now!
Comment 43 Emmanuel Grumbach 2019-03-19 11:40:10 UTC
Thanks.

I'll close this.
Comment 44 Jethro Beekman 2019-12-02 15:00:16 UTC
I ran into the same issue. After booting into Windows once, everything works in Linux as well.

I'm running Ubuntu 16.04 with Linux 4.15.0-70-generic and linux-firmware 1.157.22.

Note You need to log in before you can comment on or make changes to this bug.