Bug 201679 - Macbook Air 6,1: No battery detected with acpi_osi=; package c state no lower than pc3 without acpi_osi= boot parameter
Summary: Macbook Air 6,1: No battery detected with acpi_osi=; package c state no lower...
Status: RESOLVED DUPLICATE of bug 199981
Alias: None
Product: Power Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 11:43 UTC by David Purton
Modified: 2019-01-24 12:54 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.18.10
Tree: Mainline
Regression: No


Attachments

Description David Purton 2018-11-13 11:43:43 UTC
Since Linux 4.17, power management is broken on my Macbook Air 6,1.

Under 4.16 I get this kind of output from powertop:

C2 (pc2)    9.9%
C3 (pc3)    1.3%
C6 (pc6)    7.2%
C7 (pc7)   54.4%
C8 (pc8)    0.0%
C9 (pc9)    0.0%
C10 (pc10)  0.0%

This was from 4.16.0-2-amd64 #1 SMP Debian 4.16.16-2 (2018-06-22) x86_64 GNU/Linux

This is booted with the following parameters: quiet acpi_osi= i915.lvds_downclock=1 i915.enable_fbc=1

If I boot to 4.17 or 4.18 with the same boot parameters the battery is not detected. Output from powertop relating to package c states is similar (if not better).

Removing acpi_osi= from the boot parameters allows the battery to be detected under 4.17 and 4.18, but battery life drops through the floor and the system runs hot. powertop shows that the system doesn't drop below pc3.

Using acpi_osi= doesn't detect the thunderbolt device, but this is OK for me as I don't use it.

I have MacOS Mojave install on a Mac partition

Model Name: MacBook Air (11-inch, Early 2014)
Model Identifier: MacBookAir6,1
Model Number: MD712X/B
Comment 1 Zhang Rui 2018-12-27 15:54:43 UTC
Please confirm the patch in bug #199981 fixes the issue for you.

*** This bug has been marked as a duplicate of bug 199981 ***
Comment 2 Zhang Rui 2019-01-10 09:45:23 UTC
here is the latest patch,
https://patchwork.kernel.org/patch/10753143/
please apply it on top of 5.0-rc1 and check if it works or not.
Comment 3 David Purton 2019-01-24 11:47:05 UTC
Sorry for late reply.

I can confirm this patch does improve things.

I built 5.0-rc3 (which I gather includes this patch).

Battery now appears with and without acpi= command line parameter.

And the system now does drop to pc7 both with and without acpi.

However, my system is still running hotter and is more power hungry than with 4.16.

Perhaps this is to do with Thunderbolt devices being detected with and without acpi= which was not formally the case.

Oh well.

Close this bug for now.
Comment 4 David Purton 2019-01-24 12:47:21 UTC
Slight adjustment from above comment.

I realise I accidentally passed acpi= instead of acpi_osi= to 5.0-rc3 when I tested.

With acpi_osi=, 5.0-rc3 still does *not* detect my battery.

Without acpi_osi=, 5.0-rc3 does detect my battery and system drops to pc6 (so this is fixed at least).

But battery life still isn't as good as it was with 4.16 with acpi_osi=

Battery is more or less comparable to what I got with 4.16 without acpi_osi=.

I still preferred what I had with 4.16 when no thunderbolt was detected (if indeed this is what causes the power usage difference.) Is there a way I can return to 4.16 behaviour?
Comment 5 David Purton 2019-01-24 12:54:39 UTC
The difference is in the wakeups/second reported by powertop.

With my good 4.16 set up wakeups/second is consistently below 100. With 4.16 and 5.0-rc3 without acpi_osi wakeups/second fluctuates a lot and is often over 200.

Note You need to log in before you can comment on or make changes to this bug.