Bug 201675 - TMPFS allocations don't count as allocated RAM
Summary: TMPFS allocations don't count as allocated RAM
Status: RESOLVED CODE_FIX
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: 201673
  Show dependency tree
 
Reported: 2018-11-12 22:16 UTC by Artem S. Tashkinov
Modified: 2021-12-30 20:26 UTC (History)
1 user (show)

See Also:
Kernel Version: GIT
Tree: Mainline
Regression: No


Attachments

Description Artem S. Tashkinov 2018-11-12 22:16:00 UTC
It makes a lot of sense to make TMPFS a userspace application, so that it would be possible to kill it in case it overcommits memory (see bug 201673) and to understand real memory pressure using top/ps.

Right now, both `top` and `free` don't take the RAM consumed by TMPFS into consideration (and I presume the kernel itself) which leads to all sorts of bad situations.

This looks like a very serious bug probably needs to be fixed.
Comment 1 Artem S. Tashkinov 2020-08-14 13:20:36 UTC
What do you think Linus?
Comment 2 Artem S. Tashkinov 2021-12-30 20:26:17 UTC
AFAIK, this has been changed/fixed and now reported as shared memory.

Note You need to log in before you can comment on or make changes to this bug.