Bug 201613 - Distorted and robotic microphone input on ALC892
Summary: Distorted and robotic microphone input on ALC892
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Jaroslav Kysela
Depends on:
Reported: 2018-11-03 17:36 UTC by Luca
Modified: 2019-08-13 13:06 UTC (History)
8 users (show)

See Also:
Kernel Version: Every kernel version I tried, currently on 4.18.0
Tree: Mainline
Regression: No

alsa-info (55.85 KB, text/plain)
2018-11-03 17:36 UTC, Luca
Recording showing the noise (491.47 KB, audio/ogg)
2018-11-27 17:14 UTC, Luca

Description Luca 2018-11-03 17:36:51 UTC
Created attachment 279301 [details]

I always got this issue only on Linux, every distro I tried including Manjaro Linux, Debian, ubuntu had this problem.

Basically the microphone input sounds always distorted and "robotic" even on high pitch. In all the programs I tried.

Workarounds as listed on the ArchWiki ---> https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Microphone_crackling_with_Realtek_ALC892 have not changed anything.

Interesting thing though is that on FreeBSD this does not happen.

alsa-info on the attachments

Kernel version: Linux luky-MS-7A37 4.18.0-10-generic #11-Ubuntu SMP

Driver version:     k4.18.0-10-generic
Library version:    1.1.6
Utilities version:  1.1.6

Obviously this also happens on other kernels.
Comment 1 Luca 2018-11-27 17:14:54 UTC
Created attachment 279675 [details]
Recording showing the noise
Comment 2 Luca 2018-12-19 13:05:23 UTC
I may confirm that recording without pulseaudio using ffmpeg -alsa produces the same disturbed sound
Comment 3 Luca 2018-12-20 11:52:30 UTC
Motherboard model is an MSI B350M AM4 for Ryzen CPU's
Comment 4 Luca 2018-12-25 23:07:42 UTC
There are other people having the same issue on the same motherboard model
Comment 5 Luca 2019-01-03 23:18:24 UTC
A partial workaround which doesn't completely fix the issue but improves things is the following:

Adding to /etc/pulse/default.pa, use_ucm=0 tsched=0 right after module-udev-detect 

and /etc/pulse/daemon

resample-method = src-sinc-best-quality
default-sample-format = s16le
default-sample-rate = 48000

Don't know which what specific parameter improved this, because when I test each one of those singularly doesn't totally fix the problem. 

The best results I can obtain are with all those combined
Comment 6 Luca 2019-01-04 00:23:15 UTC
Actually this workaround adds another problem, in games the sound is delayed...
Comment 7 Alex 2019-04-23 19:40:39 UTC
I have the same problem with MSI B450 Tomahawk Motherboard
Comment 8 Axel 2019-08-13 13:06:28 UTC
IMHO this bug is could be closed because of https://bugzilla.kernel.org/show_bug.cgi?id=195303

Note You need to log in before you can comment on or make changes to this bug.