Bug 201563 - macchiatobin, could not attach PHY (-19)
Summary: macchiatobin, could not attach PHY (-19)
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-29 20:44 UTC by alpha_one_x86
Modified: 2021-05-04 22:54 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.18
Tree: Mainline
Regression: No


Attachments

Description alpha_one_x86 2018-10-29 20:44:27 UTC
Hi,

We have problem with our macchiatobin, the vanilla kernel not work:
[ 58.364030] mvpp2 f2000000.ethernet eth0: could not attach PHY (-19)
[ 58.381763] mvpp2 f2000000.ethernet eth0: could not attach PHY (-19)
[ 67.443146] mvpp2 f4000000.ethernet eth1: could not attach PHY (-19)
[ 67.460872] mvpp2 f4000000.ethernet eth1: could not attach PHY (-19)
How fix this?

Cheers,
Comment 1 Dmitriy 2019-01-20 20:55:40 UTC
up, some bugs in kernel 4.19.16
```
[    5.401915] mvpp2 f10f0000.ethernet eth0: Using hardware mac address 00:00:00:00:00:04
[   17.784700] mvpp2 f10f0000.ethernet eth0: could not attach PHY (-22)
[   78.929793] mvpp2 f10f0000.ethernet eth0: could not attach PHY (-22)
```

dst file: https://pastebin.com/5gSkKwYK
.config file: https://pastebin.com/Dw7abMz9

last kernel with work mvpp2 ethernet is 4.18.20, but not work in 4.19.1
Comment 2 Dmitriy 2019-01-20 21:45:03 UTC
i replace folder drivers/net/ethernet/marvell from kernel 4.18.20 to 4.19.1 and ethernet is working
Comment 3 Anton Hvornum 2021-05-04 21:22:34 UTC
I'd like to add to this old issue, that it might be related to the Single-Shot board and an issue discussed on the official Macchiato forums (http://macchiatobin.net/forums/topic/kernel-vanilla/page/4/).

The issue that causes these messages might be related to the armada kernel driver trying to access RJ45 specific instructions that won't be available (due to the Single-Shot board missing these physical ports).

The official wiki on Macchiato Bin (http://wiki.macchiatobin.net/tiki-index.php?page=Build+from+source+-+Kernel) mentions this briefly, and if anything this is more a shortcoming in the driver itself that it can not handle both setups.


To verify that this is the issue, you can download the single-shot armada driver provided by macchiatobin/solidrun or - if you run Arch Linux ARM - this driver is pre-shipped and can be found at /boot/dtbs/marvel/armada-8040-mcbin-singleshot.dtb, which has to be re-named to /boot/dtbs/marvel/armada-8040-mcbin.dtb

After a reboot, link should come up and iproute2 commands should work as expected.
Comment 4 alpha_one_x86 2021-05-04 22:54:23 UTC
Hi, updated kernel + vanilla updated uboot + single dts have resolved issue

Note You need to log in before you can comment on or make changes to this bug.