Bug 201449 - iwlwifi: 8265: TFD queue hang in AP mode
Summary: iwlwifi: 8265: TFD queue hang in AP mode
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: IA-64 Linux
: P1 normal
Assignee: Intel Linux Wireless
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-16 20:46 UTC by yana.n.tsareva
Modified: 2018-11-22 06:42 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.18
Tree: Mainline
Regression: No


Attachments
dmesg log for Ubuntu 18.04 /4.18 (2.71 KB, application/x-zip-compressed)
2018-10-16 20:46 UTC, yana.n.tsareva
Details
-36 firmware with debug enabled. (2.38 MB, application/octet-stream)
2018-10-17 06:07 UTC, Emmanuel Grumbach
Details
fix (1.59 KB, application/mbox)
2018-11-15 09:43 UTC, Emmanuel Grumbach
Details

Description yana.n.tsareva 2018-10-16 20:46:24 UTC
Created attachment 279057 [details]
dmesg log for Ubuntu 18.04 /4.18

Configuration:
HW: NUC7i5DNH: with Wireless-AC 8265 
SW tested (driver crash appears on all the tested versions below, logs attached):
Ubuntu Server 16.04 LTS, kernel 4.14.13
Ubuntu 17 Kernel 4.14.35 FW 34.0.1
Ubuntu 18 Kernel 4.18, fw 36

AC 8265 is set to AP mode, external USB dongle – wifi access STA
Sometimes iwlwifi driver generates an OOPS. A device reboot is needed to recover.
Sometimes iwlwifi driver just crashes and restarts itself, creating ~2 second delay in all communications.

Customer doesn't have a reliable way to reproduce either case. IPv6 has been disabled, as it is though to reduce problem frequency.

Tested:
Kernel 4.18 
After installing this kernel , fw 36 did load by itself.
This configuration crashed frequently, due to reasons beyond WiFi.
Apparently this kernel is not intended to work well with Ubuntu 16.04

Upgrading to 18.04 /4.18
The errors seems to occur with this kernel as well.
Attached a dmesg log (2018-10-12-Ubuntu18.04-Kernel-4.18.13-iwlwifi.txt)

Various WiFi STA variations
Customer attempted several WiFi module replacements for the STA connection to the dental office. i.e. the Intel module remains the local AP network.
Customer reported that it does makes a difference . Crash frequency is dependent on the module. The one they had initially used seems to fair well relatively.

Intel module as STA, external AP dongle
Customer had switched the use of the Intel module to STA, and used an AP capable USB dongle as AP.
The external AP worked fine, but the crash frequency of the iwlwifi went up.
Comment 1 Luca Coelho 2018-10-16 21:01:44 UTC
We will look into it.
Comment 2 Emmanuel Grumbach 2018-10-17 06:07:56 UTC
Created attachment 279071 [details]
-36 firmware with debug enabled.

There are two logs attached.
* ASSERT 1007 which we will not handled since it has been happened with an old firmware (34.0.1).
* TFD queue hang with the latest firmware.

For the TFD queue hang, we need the customer to collect debug data with the firmware attached.
Please see the instructions here:
https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging#firmware_debugging

We also need to record tracing as explained here:
https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging#tracing

The best would be to have the tracing and the firmware dump of the same run.


Please note that we don't provide business level support, but rather community support which is a different engagement and commitment.
Comment 3 Emmanuel Grumbach 2018-10-17 06:09:27 UTC
I forget to say that you should pay attention to the privacy note here:
https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging#privacy_aspects

before sending private data to us.

Thank you.
Comment 4 Emmanuel Grumbach 2018-11-15 09:43:36 UTC
Created attachment 279459 [details]
fix
Comment 5 Emmanuel Grumbach 2018-11-22 06:42:13 UTC
This bug is being handled over emails.

Note You need to log in before you can comment on or make changes to this bug.