Bug 201345 - Micro stuttering in RocketLeague
Summary: Micro stuttering in RocketLeague
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-08 14:35 UTC by Matthias Heinz
Modified: 2018-10-08 14:37 UTC (History)
0 users

See Also:
Kernel Version: 4.19.0-rc6
Tree: Mainline
Regression: No


Attachments
Shader clock and fps directly after a boot (684.35 KB, image/png)
2018-10-08 14:35 UTC, Matthias Heinz
Details
Shader clock and fps after setting performance level to high (644.64 KB, image/png)
2018-10-08 14:36 UTC, Matthias Heinz
Details
Shader clock and fps after setting performance level back to auto (754.86 KB, image/png)
2018-10-08 14:37 UTC, Matthias Heinz
Details

Description Matthias Heinz 2018-10-08 14:35:38 UTC
Created attachment 278951 [details]
Shader clock and fps directly after a boot

Hi,

everytime I start RocketLeague the first time after a boot I have some kind of  micro stuttering. This happens with my RX550 and on a Vega 56.

A workaround is to set power_dpm_force_performance_level to "high".

Setting it back to "auto" on the RX550 makes the stuttering return. Doing the same thing on the Vega 56 not and the stuttering is gone until the next boot.

I'll attach three screenshots that display the shader clock and fps via gallium hud. One directly after a boot, one with performance_level set to "high" and one after resetting it to "auto". All screenshots were made with the Vega 56 and Mesa 18.2.0.

Best regards
Matthias
Comment 1 Matthias Heinz 2018-10-08 14:36:32 UTC
Created attachment 278953 [details]
Shader clock and fps after setting performance level to high
Comment 2 Matthias Heinz 2018-10-08 14:37:07 UTC
Created attachment 278955 [details]
Shader clock and fps after setting performance level back to auto

Note You need to log in before you can comment on or make changes to this bug.