Bug 201175 - Touchpad not working for HP ZBook Studio G5
Summary: Touchpad not working for HP ZBook Studio G5
Status: RESOLVED DUPLICATE of bug 203995
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-18 20:21 UTC by Bo
Modified: 2019-09-10 10:40 UTC (History)
6 users (show)

See Also:
Kernel Version: 4.18.8
Tree: Mainline
Regression: No


Attachments
dmesg upon boot under kernel 4.18.8 (93.57 KB, text/plain)
2018-09-18 20:21 UTC, Bo
Details
dmesg | grep -i irq (2.08 KB, text/plain)
2018-09-18 20:23 UTC, Bo
Details
dmesg upon boot under kernel 4.18.rc6 (92.06 KB, text/plain)
2018-09-18 20:37 UTC, Bo
Details

Description Bo 2018-09-18 20:21:17 UTC
Created attachment 278643 [details]
dmesg upon boot under kernel 4.18.8

Hello,

The touchpad of my HP Studio G5 is not working in Ubuntu 18.04.1.
I have tried with these kernels: 4.15(comes with the image), 4.18.8

Output of xinput -list

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse              	id=10	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ HP HD Camera: HP HD Camera              	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
    ↳ HP Wireless hotkeys                     	id=14	[slave  keyboard (3)]
    ↳ HP WMI hotkeys                          	id=15	[slave  keyboard (3)]
Comment 1 Bo 2018-09-18 20:23:31 UTC
Created attachment 278645 [details]
dmesg | grep -i irq

I think it is related to interrupt. Because of the last line:

i2c_hid i2c-SYNA307B:00: Could not register for SYNA307B:00 interrupt, irq = 136, ret = -1
Comment 2 Bo 2018-09-18 20:27:59 UTC
Another strange behavior: every time I start the system, touchpad not working. However, if i suspend the system and wake it up again, the touchpad starts working !! (left click, scrolling work, right click not working)
Comment 3 Bo 2018-09-18 20:35:03 UTC
I am following bug 199911, https://bugzilla.kernel.org/show_bug.cgi?id=199911
which looks like a similar problem. 

I followed the solution suggested in that post, (comment 68). I compiled 4.18.rc6 with the two suggested patch. The touchpad is still not working. Again, only upon reboot. If I manually suspend and wake Ubuntu, the touchpad can be partly used.
Comment 4 Bo 2018-09-18 20:37:16 UTC
Created attachment 278647 [details]
dmesg upon boot under kernel 4.18.rc6
Comment 5 Bo 2018-09-18 20:39:09 UTC
Please let me know if more information is requested. Sorry for the broken massages, this is my first bug report :)
Comment 6 Valentin Borgeaud 2018-10-07 12:06:41 UTC
I have the same problem, but suspending the system and wake it up again does not allow the touchpad to partially work again. If you need more information, let me know, I am completely new to this.
Comment 7 Bo 2018-10-30 21:34:21 UTC
The issue is solved under the current 4.19 stable release.
Comment 8 Tomasz 2019-07-10 07:59:11 UTC
Sorry, the issue seems not to be resolved entirely. I am using a Zbook Studio G5 with Ubuntu 19.04 (Kernel 5.0.0-20-generic) right now. The Touchpad seems to work nicely, but after waking up from suspend (open a closed lid), the touchpad starts to act jaggy/wiredly, it is nearly impossible to use it anymore, it feels like the mouse pointer would "stutter"- A rebood fixes this issue - until I close and open the lid again and the Zbooks wakes up from sleep-mode. The issue is not present when using a mouse after waking up from suspend, just the touchpad.
Comment 9 PV 2019-08-21 12:42:50 UTC
(In reply to Tomasz from comment #8)
> Sorry, the issue seems not to be resolved entirely. I am using a Zbook
> Studio G5 with Ubuntu 19.04 (Kernel 5.0.0-20-generic) right now. The
> Touchpad seems to work nicely, but after waking up from suspend (open a
> closed lid), the touchpad starts to act jaggy/wiredly, it is nearly
> impossible to use it anymore, it feels like the mouse pointer would
> "stutter"- A rebood fixes this issue - until I close and open the lid again
> and the Zbooks wakes up from sleep-mode. The issue is not present when using
> a mouse after waking up from suspend, just the touchpad.

I am also having this same issue at the moment. The issue is definitely not resolved
Comment 10 Bo 2019-09-10 08:37:11 UTC
ok, the issue is not resolved. Touchpad does not act normal after waking up from suspend. what can we do? at lease i reopened the issue.
Comment 11 Bo 2019-09-10 08:41:45 UTC
(In reply to PV from comment #9)
> (In reply to Tomasz from comment #8)
> > Sorry, the issue seems not to be resolved entirely. I am using a Zbook
> > Studio G5 with Ubuntu 19.04 (Kernel 5.0.0-20-generic) right now. The
> > Touchpad seems to work nicely, but after waking up from suspend (open a
> > closed lid), the touchpad starts to act jaggy/wiredly, it is nearly
> > impossible to use it anymore, it feels like the mouse pointer would
> > "stutter"- A rebood fixes this issue - until I close and open the lid again
> > and the Zbooks wakes up from sleep-mode. The issue is not present when
> using
> > a mouse after waking up from suspend, just the touchpad.
> 
> I am also having this same issue at the moment. The issue is definitely not
> resolved

Maybe, we should also report this in bug 199911, which was closely related to this issue.
Comment 12 Tomasz 2019-09-10 08:52:24 UTC
Hello,
just some additional Info: I tried different Distros (Debian 10, Fedora, Manjaro with Kernel 5.2rc) - the bug, as described above, persists in all the Distributions.
Comment 13 Kai-Heng Feng 2019-09-10 09:16:14 UTC
Seems like it's the same as #203995?
Comment 14 Andy Shevchenko 2019-09-10 10:40:49 UTC
Based on comments 8 and 9 I close it as duplicate.

*** This bug has been marked as a duplicate of bug 203995 ***

Note You need to log in before you can comment on or make changes to this bug.