Bug 20112 - dmesg spam: "scsi host5: __pm_runtime_resume() returns 1" (DVD writer)
dmesg spam: "scsi host5: __pm_runtime_resume() returns 1" (DVD writer)
Status: RESOLVED OBSOLETE
Product: SCSI Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: scsi_drivers-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 21:20 UTC by Daniel Hahler
Modified: 2012-05-12 00:04 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.36-rc7- ubuntu i686
Tree: Mainline
Regression: No


Attachments

Description Daniel Hahler 2010-10-11 21:20:59 UTC
The system log gets spammed via dmesg with several of the following errors per second:

Oct 11 22:53:39 base kernel: [ 2147.766956] scsi host5: __pm_runtime_resume()!
Oct 11 22:53:39 base kernel: [ 2147.766962] scsi host5: __pm_runtime_resume() returns 1!

Apparently this refers to my DVD drive, according to the /proc files:

From /proc/scsi/scsi:
Host: scsi5 Channel: 00 Id: 01 Lun: 00
  Vendor: HL-DT-ST Model: DVDRAM GSA-4163B Rev: A100
  Type:   CD-ROM                           ANSI  SCSI revision: 05

% cat /proc/scsi/sg/devices 
[...]
5       0       1       0       5       1       1       0       1

% cat /proc/scsi/sg/device_strs 
[...]
HL-DT-ST        DVDRAM GSA-4163B        A100

This might be caused by CONFIG_PM_DEBUG=y, and might actually be expected.
In this case, please excuse this report then - but consider making it less
verbose.

My /proc/config.gz unzipped: http://pastebin.com/knXt8nmw
lspci -vvv: http://pastebin.com/iMWbaUPC

Might this be related to the writer failing to detect rewritable media? (which might be a regression I still would have to investigate deeper into)

(This might be related to https://bugzilla.kernel.org/show_bug.cgi?id=19712 - where only a "__pm_runtime_resume()!" is posted repeatedly.)
Comment 1 Daniel Hahler 2010-10-21 18:31:24 UTC
This is related to CONFIG_PM_VERBOSE=y, unsetting it does not cause this message spam.

Is this intentional?
Does it indicate some bug or broken hardware?
Comment 2 Nix 2010-10-31 20:48:55 UTC
I can confirm this logspam. In my case it relates to SCSI host 3, "CDDVDW SH-S223F", a DVD writer. (The writer contains no media.)

Note You need to log in before you can comment on or make changes to this bug.