Bug 200911 - This bug resets the network adapter enp0s31f6 unexpectedly.
Summary: This bug resets the network adapter enp0s31f6 unexpectedly.
Status: RESOLVED DUPLICATE of bug 199783
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-23 14:17 UTC by Christian Forler
Modified: 2018-08-24 13:33 UTC (History)
0 users

See Also:
Kernel Version: 4.17.0-1-amd64 #1 Debian 4.17.8-1
Tree: Mainline
Regression: No


Attachments

Description Christian Forler 2018-08-23 14:17:34 UTC
$ cat kernel-error-e1000e.log  | cut -d ":" -f 4- 
------------[ cut here ]------------
 WARNING: CPU: 3 PID: 0 at /build/linux-0buYvw/linux-4.17.8/net/sched/sch_generic.c:473 dev_watchdog+0x20d/0x220
 Modules linked in: rfcomm ctr ccm hid_cherry hid_generic cmac bnep usbhid hid btusb btrtl btbcm btintel bluetooth uvcvideo videobuf2_vmalloc videobuf2_memops
  drm nvram mei_me sg snd i2c_algo_bit intel_pch_thermal shpchp mei soundcore ac battery rfkill wmi video button binfmt_misc loop parport_pc ppdev lp parport 
 CPU: 3 PID: 0 Comm: swapper/3 Not tainted 4.17.0-1-amd64 #1 Debian 4.17.8-1
 Hardware name: LENOVO 20FN003NGE/20FN003NGE, BIOS R06ET33W (1.07 ) 01/05/2016
 RIP: 0010:dev_watchdog+0x20d/0x220
 RSP: 0018:ffff88c062583e88 EFLAGS: 00010286
 RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000000000
 RDX: 0000000000040400 RSI: 00000000000000f6 RDI: 0000000000000300
 RBP: ffff88c04df3845c R08: 0000000000000340 R09: 0000000000000004
 R10: ffff88c062583ef8 R11: 0000000000000001 R12: ffff88c04df38000
 R13: 0000000000000003 R14: ffff88c04df38478 R15: 0000000000000001
 FS:  0000000000000000(0000) GS:ffff88c062580000(0000) knlGS:0000000000000000
 CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
 CR2: 00007ffb871f3000 CR3: 0000000216a0a003 CR4: 00000000003606e0
 Call Trace:
  <IRQ>
  ? pfifo_fast_change_tx_queue_len+0x2d0/0x2d0
  call_timer_fn+0x2b/0x120
  run_timer_softirq+0x3e4/0x430
  ? tick_sched_timer+0x37/0x70
  ? __hrtimer_run_queues+0x118/0x290
  ? recalibrate_cpu_khz+0x10/0x10
  __do_softirq+0xde/0x2b4
  irq_exit+0xae/0xb0
  smp_apic_timer_interrupt+0x6c/0x120
  apic_timer_interrupt+0xf/0x20
  </IRQ>
 RIP: 0010:cpuidle_enter_state+0xa0/0x2b0
 RSP: 0018:ffffb6a8c194fe98 EFLAGS: 00000246 ORIG_RAX: ffffffffffffff13
 RAX: ffff88c0625a1a00 RBX: 00000ddeaaee74ec RCX: 000000000000001f
 RDX: 00000ddeaaee74ec RSI: 0000000035555555 RDI: 0000000000000000
 RBP: 0000000000000006 R08: ffff88c06259cd00 R09: 00000000ffffffff
 R10: ffffb6a8c194fe78 R11: 00000000000006f2 R12: ffff88c0625a9c00
 R13: ffffffff8f2b3778 R14: 0000000000000000 R15: 00000ddea9ba25d9
  ? cpuidle_enter_state+0x90/0x2b0
  do_idle+0x200/0x270
  cpu_startup_entry+0x6f/0x80
  start_secondary+0x1a4/0x1f0
  secondary_startup_64+0xa5/0xb0
 Code: 42 00 49 63 4e e8 eb 92 4c 89 e7 c6 05 08 de b1 00 01 e8 d7 12 fd ff 89 d9 48 89 c2 4c 89 e6 48 c7 c7 b0 3c 0b 8f e8 b3 23 aa ff <0f> 0b eb c0 66 66 2e
 ---[ end trace ab28e44287f98f50 ]---
 e1000e 0000:00:1f.6 enp0s31f6: Reset adapter unexpectedly



$ lspci -vv -k -s 00:1f.6
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-V (rev 21)
	Subsystem: Lenovo Ethernet Connection I219-V
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 121
	Region 0: Memory at f1200000 (32-bit, non-prefetchable) [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: e1000e
	Kernel modules: e1000e

Hope the information above help to fix this issue.

Best Regards,
Christian
Comment 1 Christian Forler 2018-08-24 13:33:53 UTC

*** This bug has been marked as a duplicate of bug 199783 ***

Note You need to log in before you can comment on or make changes to this bug.